Aller au contenu


Photo
- - - - -

Bases de données sous Delphi...


  • Veuillez vous connecter pour répondre
13 réponses à ce sujet

#11 Yaggi

Yaggi

    Junior Member

  • Membres
  • 10 messages

Posté 23 juillet 2001 - 12:29

ouais en fait ca me mettait seulement "violation de clé"... ca arrivait sur plusieurs actions :



Table.Last

ou Table.Delete

ou encore Table.Append

et enfin quand je cliquai sur ma DBGrid (cad quand je change la position du curseur d'enregistrement...)



tout ca ca arrivait en fait quand j'ajoutais un enregistrement avec append (donc rien a voir avec le batchmove) et puis je faisait pas post donc le programme était pommé quand je voulais en ajouter un autre ou alors quand je déplacais le curseur...



je sais pas trop si t'as capté (moi meme g un peu de mal... mais bon ca marche maintenant !
  • 0

PUBLICITÉ

    Annonces Google

#12 KewlCat

KewlCat

    Modérateur

  • Attente Validation
  • 24 812 messages

Posté 23 juillet 2001 - 12:31

... pas tout, non, mais l'essentiel 'est que tu aies résolu ton pb !



:P
  • 0

#13 badaze

badaze

    Power Member

  • Membres
  • 113 messages

Posté 24 juillet 2001 - 11:57

Même si l'utilisation d'un index permet d'ordonner le résultat, je préféte utiliser un composant TQuery qui permet via le SQL de faire des tris en fonction d'un paramétrage.



Par exemple j'ai dans un de mes projets: Nom + Date + Dossier + Résidence; tous ces critères étant combinables. Tu te rends compte du nombre d'index !



Si cela t'intéresse je peux retrouver le code
  • 0

#14 badaze

badaze

    Power Member

  • Membres
  • 113 messages

Posté 24 juillet 2001 - 12:04

Concernant le problème de la violation de clé.

Peut être qu'en testant l'existence de l'enregistrement avec un autre composant TTable dans l'évènement BeforeInsert du composant TTable principal et en utilisant la méthode Abort tu peux éviter ce problème.
  • 0









Sujets similaires :     x