Aller au contenu






- - - - -

Installer le module CoolPreviews sur Firefox 48.0 et +

Posté par Wullfk, dans Navigateur 08 août 2016 · 892 visite(s)

Installer le module CoolPreviews sur Firefox 48.0 et + Bonjour,
 
Ça fait déjà quelque temps que l'extension CoolPreviews, n'est plus développée, et pour ceux qui ont effectuées la mise à jour Firefox 48.0, comble de malchance cette excellente extension se retrouve désactivée car non signée par Mozilla.
 
Voir : Installer des add-ons non signés sous Firefox 48
 
Heureusement, nombres d'internautes organisent la résistances et partagent librement leurs astuces pour contourner les mécanismes de ces nouvelles menottes numériques sous prétexte de sécurité accrue pour l’utilisateur.
 
C'est le cas de Sylvain (de Tutoriaux-Excalibur) qui à trouvé le moyen de modifier l'extension pour quelle puisse à nouveau fonctionner sur Firefox 48.0 et +
 
Ceci dit ça demande préalablement l'installation d'un Patch Firefox, disponible ici : Patch Firefox.zip
 
Image IPB Cette manipulation qui modifie l'intégrité du binaire, est à faire en ayant pleinement conscience que cela va à l'encontre de toutes notions de sécurité..

Une fois le patch installée, il faut télécharger le module CoolPreviews modifié disponilble ici :
CoolPreviews-4.6.zip
 
Après il n'y a plus qu'a l'installer comme une extension dans Thunderbird, cet à dire via le fichier .xpi

Pour ceux qui veulent aller plus loin, je vous recommande le tuto suivant qui permet de rendre compatible une extension avec Firefox 48.0 et +
 
Comment modifier un module pour le faire fonctionner sur toutes les versions Firefox
 
Image IPB Garder à l’esprit que cette manipulation est tout de même à réaliser avec précaution car elle pourrait rendre votre navigateur instable et donc le faire crasher régulièrement.

Aucune garantie que ça puisse fonctionner avec toutes les extensions, certaines sont assez complexe, et il faut pouvoir disposer d'un fichier .xpi avec une dénomination explicite, il y a des extensions qui portent des noms (ID) barbare comme :
 
{75CEEE46-9B64-46f8-94BF-54012DE155F0}.xpi
 
Pour savoir à quel module ça correspond, Copier/Coller about:support dans la barre d'adresse de votre navigateur, pour connaître l'ID de l'extension.

ex: Video DownloadHelper/ 6.0.0/ true/ {b9db16a4-6edc-47ec-a1f4-b86292ed211d}
 
Aucun éditeur de texte n'est en mesure de lire les fichiers .xpi

Pour pouvoir éditer le fichier install.rdf afin d'effectuer les modifications, il faut au préalable renommer votre fichier .xpi en .zip et là vous obtiendrez un répertoire dans lequel on peut naviguer !!
 
Voir l'article suivant qui date de 2011 : Comment forcer la compatibilité d’un module Firefox

J'ai testé le Patch et le module d'extension modifié, et tout fonctionne parfaitement, alors que demander de plus.

Merci à Sylvain pour le partage
 
 

  • 0



Août 2017

D L M M J V S
  12345
6789101112
1314151617 18 19
20212223242526
2728293031  

Ma photo

Rechercher dans le blog

utilisateur(s) actif(s)

membre(s), invité(s), utilisateur(s) anonyme(s)