Aller au contenu


Photo
- - - - -

DivX --- FlaskMpeg


  • Veuillez vous connecter pour répondre
12 réponses à ce sujet

#1 rige47

rige47

    Member

  • Membres
  • 28 messages

Posté 21 janvier 2001 - 09:13

J'ai un probleme avec FlaskMpeg ou plutôt je ne saisi pas exactement les différents parametres du codec DivX low motion.



Keyframe every ... second

smoothness ---> crispness

Data rade ----> bon ok celui la j'ai compris



Mon probleme c'est que certains films (en fait presque tous) que j'ai compresse, il y a souvent des saccades de l'image. En faisant quelques tests on peut voir que les saccades ne se font pas aux mêmes endroits ce qui me dit que le probleme ne vient pas de la compression en elle même. Ca ne vient pas non plus de mon PC enfin je pense (Athlon 800,KT7,GeForce2MX).



Si quelqu'un pouvait m'expliquer clairement les différents parametres et leurs effets sur le résultat final et me conseiller sur la marche a suivre pour effacer ces saccades. Ah si quelqu'un pouvait ...



J'ai déja cherché dans les sites traitant du sujet mais pour le moment j'en ai trouvé aucun qui m'aide vraiment. Alors si vous êtes un spécialiste ou que vous connaissez un bonne adresse n'hésiter pas à me repondre.
  • 0

PUBLICITÉ

    Annonces Google

#2 Torkdul

Torkdul

    Junior Member

  • Membres
  • 1 messages

Posté 21 janvier 2001 - 11:34

Eh bien j'en viens à me demander si la MX n'a pas quelques prob de lecture sur les Div X. Je viens de faire le test sur deux config opposées et le constat est là le film saccade

Céléron 550 - 128Mo et Duron 750 - 128 Mo

A l'opposé c'est fluide sur

PIII-600 - 192Mo - Ati 128 pro ViVo et

Céléron 500 - 64 Mo - Voodoo 3 2000

Le problème est posé a suivre
  • 0

#3 Toine

Toine

    Member

  • Membres
  • 31 messages

Posté 21 janvier 2001 - 11:56

Pour ma part, je n'ai jamais vraiment réussi à compresser proprement quoi que ce soit avec Flask.

Je vous conseille vivement Virtual Dub. On peut compresser ce qu'on veut (pas forcément du mpeg) et puis c'est fait par GNU alors on peut dire que c'est béton.



http://www.geocities.com/virtualdub/ (664ko)
  • 0

#4 rige47

rige47

    Member

  • Membres
  • 28 messages

Posté 22 janvier 2001 - 12:20

Je viens de telecharger virtualdub mais apparament il faut déja un fichier .avi pour le programme. Comment faire avec les morceaux ripper du dvd sur mon disque.
  • 0

#5 lord samael

lord samael

    Junior Member

  • Membres
  • 17 messages

Posté 22 janvier 2001 - 11:02

keyframe c'est l'image cle (oui je sais merci pour la traduction)

je le regle a 1 (2 si c'est un gros film)

c'est l'image a partir de laquelle les suivantes seront bati

exemple si tu le met a 1 et bien tu auras toute les secondes une image cle et les 24 images suivantes seront des variantes de celle ci (seul les mouvements seront enregistrés ) c'est aussi avec cette image que le son se cale



pour le cripness je me souviient plus mais laisse le a 100 %



le dataframe bon bah tu as compris donc pas d'explication sinon prefere le divx low motion au fast motion

et emploi une resolution d'encodage de 384*288 puis aprés tu crop



voila si tu as des questions n'hesite pas !
  • 0

#6 Seiju

Seiju

    Godlike Member

  • Membres
  • 2 059 messages

Posté 22 janvier 2001 - 12:24

Pour le problème de saccades, il serait peut-être bon aussi de regarder les paramètres du player DivX :

si tu utilises le média player 6.4 de Windoz vas dans fichier/propriétés/[onglet le plus à droite]/Codec DivX[double cliquer dessus]. (Désolé j'ai pas le player sous la main ).

Si tu utilises le player 7 .... ben laisses tomber (Quelle merde ce player !)



Car il y a un curseur qui permet de donner une qualité de décodage. Plus ta machine est puissante, plus tu peux le mettre haut. Il suffit peut-être de descendre ce curseur pour que ca marche mieux.



Pour Virtualdub ... il est trés bien certes mais il lui faut bien une source AVI. Donc pour les mpegs et vobs ....



Seiju
  • 0

#7 rige47

rige47

    Member

  • Membres
  • 28 messages

Posté 22 janvier 2001 - 02:37

Ouaiiii, j'ai résolu le problème de saccade. Ce que j'ai fait : Je compresse le film avec FlaskMpeg avec les paramètres que je veux et j'obtiens un film... euhh avec des saccades.



Ensuite j'ouvre avec Virtualdub le fichier .avi que j'ai obtenu, je change les options pour la video et l'audio que je met en direct streamcopy et je sauve. Virtualdub va recompiler un nouveau fichier .avi(très rapidement jusqu'a plus de 500 fps) qui lui bizarement est niquel dépourvu de saccades impeccable quoi !!



Merci à ceux qui m'on répondu voila, vive virtualdub et ceux qui on encore des astuces n'hésiter pas à les mettres.



Fred.
  • 0

#8 Seiju

Seiju

    Godlike Member

  • Membres
  • 2 059 messages

Posté 22 janvier 2001 - 05:51

Oki j'ai compris pourquoi ca saccadait tes DivX !

C'est à cause de l'entrelacement de la piste Audio avec la piste Video !

Sous virtualdub, ce parametre par défaut est correct. Et ca expliquerai que juste le directstream copy te permette de ne plus saccader.



Seiju
  • 0

#9 Toine

Toine

    Member

  • Membres
  • 31 messages

Posté 22 janvier 2001 - 09:21

Ok, ça marche donc.

Pour ce qui est de virtual dub, je vous assure qu'on peut compresser des mpegs.

Je le fais tout le temps.

Il a juste besoin d'analyser le fichier au début (je sais pas pourquoi) et ça prend quelques minutes, mais c'est tout.
  • 0

#10 rige47

rige47

    Member

  • Membres
  • 28 messages

Posté 23 janvier 2001 - 05:16

Help, j'ai mis Flask sur mon deuxieme ordi et quand je choisis mon codec audio je n'ai plus de "mp3" en 48000 Hz mais seulement en 44000 Hz. Comment faire pour faire réaparaitre cette option. Je me souviens que j'avais eu le meme probleme avant mais impossible de me rappeler comment j'avais fait. Ca fait des heures que je cherche please help me !
  • 0









Sujets similaires :     x