Aller au contenu


Photo

[Info] Réparer le support SSD de Windows 10 Anniversary


  • Veuillez vous connecter pour répondre
10 réponses à ce sujet

#1 Wullfk

Wullfk

    Mega Power Extrem Member

  • Membres
  • 8 709 messages

Posté 29 août 2016 - 04:13

Bonjour,

Décidément la mise à niveau Windows Anniversary (1607), cumule les bugs, après le problème des WebCam, puis celui des liseuses KINDLE, c'est maintenant le support de certains SSD qui pose problème.

 

Windows 10 Anniversary Update rencontre de lourds problèmes avec certains SSD. Problèmes pouvant mener à des pertes de données. Comment les détecter ? Comment les résoudre ? Nos réponses.

../..

Un des soucis les plus pernicieux de Windows 10 AU (Anniversary Update) est lié au support des unités de stockage flash. Sous certaines configurations, des lenteurs peuvent être constatées, voire des blocages. Un problème lié à des déconnexions du disque arrivant lors de grosses opérations d’écriture. Déconnexions temporaires qui peuvent mener à des pertes de données. Certains conseillent de purement et simplement désactiver le support AHCI (Advanced Host Controller Interface, le mécanisme matériel permettant à la couche logicielle de communiquer avec des périphériques SATA) dans le Bios de l’ordinateur. Ceci résout parfois le problème, effectivement, mais au prix d’une importante chute des performances.

Êtes-vous concerné par ce problème ?

La première étape consiste à déceler si votre machine est concernée par ce souci. Même si elle semble fonctionner correctement, cela est peut-être (voire probablement) le cas.

Pour le vérifier, il faut se rendre dans l’Observateur d’événements, section « Journaux Windows > Système ». Si des messages liés au composant storeahci de type « Une réinitialisation au périphérique, \Device\RaidPort0, a été émise » sont présents dans le journal, votre machine est concernée et devra être remise en état rapidement. Sur notre PC en Intel Core, un SSD Crucial rencontre ce problème.

Le défaut est double : le pilote AHCI proposé par Microsoft est trop ancien. Il date en effet de juin 2006. Non seulement il n’est pas adapté à certaines configurations modernes (types de SSD ou de chipsets), mais il rencontre aussi des soucis avec la mise en sommeil des unités de stockage.

La solution au problème

Le premier réflexe est donc d’installer le pilote AHCI du constructeur de chipset. En général celui d’Intel, à choisir dans la gamme Rapid Storage Technology (RST). Cette page résume les options accessibles. Le pilote proposé par le constructeur du PC sera dans la plupart des cas bien adapté. Dans notre cas, le pilote Intel RST 12.9.4.1000 du 07/04/2014 s’est avéré le plus récent pour notre configuration.

Seconde étape, la configuration de la gestion de l’énergie des liens AHCI. Par défaut, l’option nécessaire n’est pas présente dans Windows. Il faut donc l’activer, via les instructions proposées sur cette page web. Une fois fait, le panneau « Options d’alimentation > Modifier les paramètres du mode > Modifier les paramètres d’alimentation avancés » proposera une nouvelle option ; « AHCI Link Power Management – HIPM/DIPM ». Désactivez toutes les options d’économie d’énergie en fixant les paramètres sur « Active ». Le lien sera alors actif en permanence… sans que cela fasse une réelle différence sur l’autonomie de la machine d’ailleurs.

Bien entendu, cette procédure sera à renouveler lors du passage à « Redstone 2 », la prochaine version de Windows 10, ou lors d’une mise à jour des pilotes AHCI.

 

Source : silicon.fr


Modifié par Wullfk, 22 septembre 2016 - 08:05 .

  • 0

PUBLICITÉ

    Annonces Google

#2 GOTCHA

GOTCHA

    Extrem Member

  • Membres
  • 977 messages

Posté 17 septembre 2016 - 09:16

Salut,

 

J'ai installé la mise à jour anniversaire de Windows 10 la semaine dernière et depuis, j'ai des freeze/blocages de plusieurs secondes qui apparaissent de façons aléatoire (en surfant sur le net, jeux, explorateur Windows et même en ne faisant rien !)

Dans le journal Windows, j'ai les messages du "storeahci " et accompagné d'un "disk" (Une erreur a été détectée sur le périphérique \Device\Harddisk0\DR0 lors d'une opération de pagination.) dans la même seconde.

 

Pour ce qui concerne la solution, j'ai une carte mère "ASUS M5A99X EVO", SSD "Crucial M500" et processeur AMD FX8350. Donc inutile d'installer RST vu que je suis avec AMD non ?

Tous mes pilotes et chipset sont à jour.

 

Du coup, j'ai juste appliqué la seconde étape en espérant que cela suffit


  • 0

#3 Wullfk

Wullfk

    Mega Power Extrem Member

  • Membres
  • 8 709 messages

Posté 17 septembre 2016 - 11:34

Bonjour,

 

Oui effectivement si ton processeur est un AMD inutile d'installer RST qui est spécifique à INTEL.

 

Pour le reste, afin de ne pas polluer ce topic ouvre un nouveau sujet avec un titre explicite et effectue dans un invite de commande en tan qu'admin un sfc /scannow (vérification des fichiers système corrompu) et après un chkdsk /f/r

 

Si tu sais pas comment faire, je t'expliquerais la procédure dans le sujet que tu auras ouvert.


  • 0

#4 GOTCHA

GOTCHA

    Extrem Member

  • Membres
  • 977 messages

Posté 18 septembre 2016 - 12:37

C'est fait, je n'ai aucunes erreurs avec sfc /scannow.

​Avec chkdsk /f/r​, mon pc a rebooté pour démarrer l'analyse et réparation. Il est resté quelques minutes sur 14% puis à rebooté sur Windows sans aucuns messages.


  • 0

#5 GOTCHA

GOTCHA

    Extrem Member

  • Membres
  • 977 messages

Posté 21 septembre 2016 - 10:58

Problème enfin résolu !

 

J'ai réussi a passé du AHCI de Windows datant de 2006 à celui d'AMD de 2015. Je n'ai plus aucuns plantages désormais.

Avant ça, je suis même passé en IDE dans le bios mais j'ai appris que ce n'est pas très bon pour la durée de vie du SSD, en plus de perdre en performance.

 

Est-ce vraiment utile de faire la seconde étape du coup ?


  • 0

#6 Wullfk

Wullfk

    Mega Power Extrem Member

  • Membres
  • 8 709 messages

Posté 21 septembre 2016 - 11:22

Bonjour,
 
Si ton système est stable, je pense pas qu'il soit utile de poursuivre, tu seras à même de le faire si tu as des plantages.
 
Si tu considères qu'ici la question est réglée, n'oublie pas de le signaler en ajoutant le mot [Résolu] au début du titre de ton sujet…

[1] En bas du premier message de ton sujet, clique sur [Modifier],
[2] En bas de l'éditeur qui s'ouvre, clique sur [Utiliser l'éditeur complet],
[3] En haut de l'éditeur complet, ajoute [Résolu] au titre de ton sujet,
[4] Clique sur le bouton [Enregistrer le message modifié] pour valider.

Ceci dans un soucis de clarté du forum, pour les problèmes n'ayant pas encore de solution, ou en cours.

Merci

Cordialement


  • 0

#7 GOTCHA

GOTCHA

    Extrem Member

  • Membres
  • 977 messages

Posté 21 septembre 2016 - 11:16

Salut,

 

Je ne peux pas éditer le premier message car ce n'est pas moi qui est créé le sujet :)


  • 0

#8 Wullfk

Wullfk

    Mega Power Extrem Member

  • Membres
  • 8 709 messages

Posté 22 septembre 2016 - 12:30

Salut,

 

doh.gif Que je suis bête icon_Fou.gif , c'est moi qui est créé le sujet d'origine, et comme il ne s'agit pas d'un problème mais d'une information, je ne vais pas mettre [Résolu]


  • 0

#9 Notpa

Notpa

    Modérateur

  • Modérateur [Notpa]
  • 26 155 messages

Posté 22 septembre 2016 - 09:21

Bonjour à vous !

 

Wullfk, à défaut de Résolu, tu peux mettre Info car il s'agit d'une procédure de correction de bug.

 

A+

 

Notpa


  • 0

#10 Wullfk

Wullfk

    Mega Power Extrem Member

  • Membres
  • 8 709 messages

Posté 22 septembre 2016 - 08:06

icon_Super.gif Bien vu Notpa, c'est fait maitre.gif


  • 0









Sujets similaires :     x