Aller au contenu


Photo
- - - - -

Prob. Wifi


  • Veuillez vous connecter pour répondre
11 réponses à ce sujet

#1 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 08 août 2010 - 05:23

Bonjour, j'essaye désespérément de mettre le Wifi sur linux Xubuntu 10.4

j'ai suivie la démarche de plusieurs forum sans succès.

J'utilise une carte wifi Intel Wireless WiFi Link 5300 PCI

J'ai également une Livebox mini Thompson

J'espère vous aider à comprendre un peu plus avec ces test que l' on m'a dit de faire sur l'un des tuto du site

/sbin/iwconfig


masg@ubuntu:~$ /sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off

pan0 no wireless extensions.


sbin/ifconfig

masg@ubuntu:~$ /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr b8:ac:6f:5b:7d:c9
inet adr:192.168.1.19 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::baac:6fff:fe5b:7dc9/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:20920 erreurs:0 :0 overruns:0 frame:0
TX packets:14374 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:23764475 (23.7 MB) Octets transmis:2106858 (2.1 MB)
Interruption:17

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:4 erreurs:0 :0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:240 (240.0 B) Octets transmis:240 (240.0 B)

/sbin/route -n



masg@ubuntu:~$ /sbin/route -n
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0

cat /etc/resolv.conf

masg@ubuntu:~$ cat /etc/resolv.conf
# Generated by NetworkManager
domain home
search home
nameserver 192.168.1.1

nslookup www.google.fr


masg@ubuntu:~$ nslookup www.google.fr
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
www.google.fr canonical name = www.google.com.
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 66.249.92.104


ping -c2 www.google.fr

masg@ubuntu:~$ ping -c2 www.google.fr
PING www.l.google.com (66.249.92.104) 56(84) bytes of data.
64 bytes from 66.249.92.104: icmp_seq=1 ttl=54 time=241 ms
64 bytes from 66.249.92.104: icmp_seq=2 ttl=54 time=241 ms

--- www.l.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 5486ms
rtt min/avg/max/mdev = 241.159/241.332/241.506/0.520 ms



contenu des fichiers de configurations wifi :


cat /etc/network/interfaces

auto eth0
iface eth0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

cat /etc/wpa_supplicant/wpa_supplicant.conf


ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid=Livebox-2462
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk=ABD36856E414FCD10XXXXXXXX
priority=5
}





Merci d'avance pour votre aide.
  • 0

PUBLICITÉ

    Annonces Google

#2 Greywolf

Greywolf

    Tera Power Extrem Member

  • Membres
  • 9 309 messages

Posté 09 août 2010 - 07:48

sauf erreur ton interface wifi est la wlan0 et aucune entrée dans /etc/network/interfaces la concernant n'y figure

ta clé WPA est mal renseignée dans le fichier wpa_supplicant.conf

une clé WPA est dérivée du ssid et d'une phrase de passe constituée de caractères ASCII (de 8 à 63) et donne une clé de 64 caractères hexadécimaux (256 bits)

la clé renseignée dans ton fichier doit être la clé WEP d'origine de ta livebox (26 caractères hexadécimaux) et constitue, par défaut, la phrase de passe ASCII en mode WPA.
Tu dois donc renseigner cette phrase de passe entre guillemets dans ton fichier wpa_supplicant.conf

cat /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

cat /etc/wpa_supplicant/wpa_supplicant.conf


ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid=Livebox-2462
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="ABD36856E414FCD10XXXXXXXX"
priority=5
}
  • 0

#3 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 12:16

masg@ubuntu:~$ /sbin/ifconfig


eth0 Link encap:Ethernet HWaddr b8:ac:6f:5b:7d:c9
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
Interruption:17

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:8 erreurs:0 :0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:480 (480.0 B) Octets transmis:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:21:6a:af:2b:62
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

wlan0:avahi Link encap:Ethernet HWaddr 00:21:6a:af:2b:62
inet adr:169.254.6.153 Bcast:169.254.255.255 Masque:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1

Après modification par rapport au indication d'un site j'obtiens ça

Modifié par Masg, 09 août 2010 - 12:18 .

  • 0

#4 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 12:19

ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1
fast_reauth=1

network={
ssid=Livebox-2462
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="XXXXXXXXXXXXXXXXXXXXXXXX"
priority=5
}

J'ai rajouté ce que vous m'avez demandé, ma livebox est bien configuré en WPA

Modifié par Greywolf, 09 août 2010 - 12:32 .
suppression de la passphrase WPA en clair sur le forum

  • 0

#5 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 12:23

masg@ubuntu:~$ cat /etc/network/interfaces


auto wlan0

iface eth0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

masg@ubuntu:~$

La diode WIFI s'allume au démarrage mais pas d'internet Wifi.

Modifié par Masg, 09 août 2010 - 12:24 .

  • 0

#6 Greywolf

Greywolf

    Tera Power Extrem Member

  • Membres
  • 9 309 messages

Posté 09 août 2010 - 12:40

le firmware de la carte a-t-il été installé? => package firmware-iwlwifi à installer

ta carte voit-elle ta livebox ?
sudo iwlist wlan0 scanning

Que raconte wpa_cli?
sudo wpa_cli status

la livebox a-t-elle "appris" l'interface wifi de ton PC => bouton 1 au dos de la livebox pour forcer le mode association
  • 0

#7 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 03:57

sudo iwlist wlan0 scanning


masg@ubuntu:~$ sudo iwlist wlan0 scanning
[sudo] password for masg:
wlan0 Scan completed :
Cell 01 - Address: 00:19:70:23:E2:0E
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=26/70 Signal level=-84 dBm
Encryption key:on
ESSID:"Livebox-AA7B"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000002545804198
Extra: Last beacon: 3160ms ago
IE: Unknown: 000C4C697665626F782D41413742
IE: Unknown: 010882848B960C121824
IE: Unknown: 030101
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: 2A0100
IE: Unknown: 32043048606C
IE: Unknown: DD180050F20201018B0003A4000027A4000042435E0062322F00
IE: Unknown: DD0900037F01010000FF7F
IE: Unknown: DD0A00037F04010000000000
Cell 02 - Address: 00:18:E7:65:12:7E
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=70/70 Signal level=-33 dBm
Encryption key:on
ESSID:"Livebox-2462"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000004fa6e7e181
Extra: Last beacon: 3080ms ago
IE: Unknown: 000C4C697665626F782D32343632
IE: Unknown: 010882848B960C121824
IE: Unknown: 030106
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: 2A0100
IE: Unknown: 32043048606C
IE: Unknown: DD180050F20201018A0003A4000027A4000042435E0062322F00
IE: Unknown: DD0900037F01010000FF7F
IE: Unknown: DD0A00037F04010000000000
  • 0

#8 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 04:00

sudo wpa_cli status

masg@ubuntu:~$ sudo wpa_cli status
Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
masg@ubuntu:~$

Modifié par Masg, 09 août 2010 - 04:01 .

  • 0

#9 Masg

Masg

    Junior Member

  • Membres
  • 8 messages

Posté 09 août 2010 - 05:32

la livebox a-t-elle "appris" l'interface wifi de ton PC => bouton 1 au dos de la livebox pour forcer le mode association ?


Oui j'ai appuyé sur le bouton association de ma Livebox
  • 0

#10 Greywolf

Greywolf

    Tera Power Extrem Member

  • Membres
  • 9 309 messages

Posté 09 août 2010 - 06:58

dans ton wpa_supplicant.conf
remplace
ctrl_interface=/var/run/wpa_supplicant
par
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

  • 0









Sujets similaires :     x