Aller au contenu


Photo
- - - - -

Speedtouch USB & Mandrake 8.1


  • Veuillez vous connecter pour répondre
19 réponses à ce sujet

#11 Myki

Myki

    Godlike Member

  • Membres
  • 3 936 messages

Posté 05 octobre 2001 - 01:51

Une petite adresse vaut mieux qu'un long discours.

http://lea-linux.org...lire.php3?id=86



Merci à Léon pour ce lien qui m'a bcp servi.



777
  • 0

PUBLICITÉ

    Annonces Google

#12 tetsuo

tetsuo

    Power Member

  • Membres
  • 142 messages

Posté 05 octobre 2001 - 02:18

C'est tres bien et beaux tout ça mais ca resoud pas le prob, l'usb n'est pas detecter, meme pas installer, sais pas pq ?

Ceci dis, je ne regrette pas mon XP, pour le moment
  • 0

#13 Myki

Myki

    Godlike Member

  • Membres
  • 3 936 messages

Posté 05 octobre 2001 - 02:23

L'USB est géré par Mandrake à partir de la 8.0.

Chez moi, j'ai mis la 8.0 (sans plus pour le USB) et fait comme marquer sur le lien, et ca marche nickel.



777
  • 0

#14 tetsuo

tetsuo

    Power Member

  • Membres
  • 142 messages

Posté 05 octobre 2001 - 03:27

Faudra que j'essaye mais je suis sceptique (comme une fosse)



Merci qd meme
  • 0

#15 Psyl0

Psyl0

    Junior Member

  • Membres
  • 1 messages

Posté 05 octobre 2001 - 09:42

Salut,

effectivement tout dépend déjà du hardware, les versions téléchargeables de mandrake 8.1 (3cd!)comprennent les drivers pour une certaine base de donnée de hard. Comme vous le savez tous sur Linux tout est à faire ! La version 8.1permet le support ADSL (elle vous demande même si votre modem est un speedtouch USB !!!!

Alors pour ceux que ça branche, voilà comment ça se passait sur la 8.0 :Assurez vous que votre noyau a été compilé avec les options suivantes:



Support for USB (CONFIG_USB) [M]

Preliminary USB device filesystem (CONFIG_USB_DEVICEFS) [Y]

UHCI (Intel PIIX4, VIA, ...) support (CONFIG_USB_UHCI) [M]

UHCI Alternate Driver (JE) support (CONFIG_USB_UHCI_ALT) [M]

OHCI (Compaq, iMacs, OPTi, SiS, ALi, ...) support (CONFIG_USB_OHCI) [M]



Pour le vérifier, "mount" doit vous donnez une ligne du style:

none on /proc/bus/usb type usbdevfs (rw)



Sinon, tapez:

mount -t usbdevfs none /proc/bus/usb



Ensuite, vérifiez que votre modem est là avec la commande:

cat /proc/bus/usb/devices



Cela vous donnera quelque chose de similaire à :

T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2

B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0

D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1

P: Vendor=0000 ProdID=0000 Rev= 0.00

S: Product=USB UHCI Root Hub

S: SerialNumber=e800

C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA

I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2

B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0

D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1

P: Vendor=0000 ProdID=0000 Rev= 0.00

S: Product=USB UHCI Root Hub

S: SerialNumber=e400

C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA

I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms

T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 4 Spd=12 MxCh= 0

D: Ver= 1.10 Cls=ff(vend.) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1

P: Vendor=06b9 ProdID=4061 Rev= 0.00

S: Manufacturer=ALCATEL

S: Product=Speed Touch USB

S: SerialNumber=0090D013AAB8

C:* #Ifs= 3 Cfg#= 1 Atr=80 MxPwr=500mA

I: If#= 0 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdevfs

E: Ad=81(I) Atr=03(Int.) MxPS= 16 Ivl= 50ms

I: If#= 1 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdevfs

I: If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdevfs

E: Ad=06(O) Atr=02(Bulk) MxPS= 64 Ivl= 0ms

E: Ad=07(O) Atr=02(Bulk) MxPS= 64 Ivl= 0ms

E: Ad=87(I) Atr=02(Bulk) MxPS= 64 Ivl= 0ms

I: If#= 1 Alt= 2 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdevfs

E: Ad=06(O) Atr=02(Bulk) MxPS= 32 Ivl= 0ms

E: Ad=07(O) Atr=02(Bulk) MxPS= 32 Ivl= 0ms

E: Ad=87(I) Atr=02(Bulk) MxPS= 64 Ivl= 0ms

I: If#= 1 Alt= 3 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=usbdevfs

E: Ad=06(O) Atr=02(Bulk) MxPS= 16 Ivl= 0ms

E: Ad=07(O) Atr=02(Bulk) MxPS= 16 Ivl= 0ms

E: Ad=87(I) Atr=02(Bulk) MxPS= 64 Ivl= 0ms

I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)

E: Ad=05(O) Atr=02(Bulk) MxPS= 8 Ivl= 0ms

E: Ad=85(I) Atr=02(Bulk) MxPS= 8 Ivl= 0ms



**********Allez ça a l'air chiant comme ça ... mais il est vraiment cool ce pengouin**********
  • 0

#16 tetsuo

tetsuo

    Power Member

  • Membres
  • 142 messages

Posté 07 octobre 2001 - 12:01

Merci du renseignement, mais le plus gros prob est le suivant : comment fait-on pour compiler le noyaux ??



Je suis un Newbie donc aidez moi SVp.

Pas à pas de préférence.

Et aussi, la lampe (rouge ou verte) du modem, la USB, clignote environ 3sec, rouge puis c'est fini. Plus rien.



A l'aide. Au secours.



MERCi



Allez une tournée



Au fait, linux c'est la

[ Ce Message a été édité par: tetsuo le 2001-10-07 01:01 ]
  • 0

#17 St4n

St4n

    Junior Member

  • Membres
  • 9 messages

Posté 07 octobre 2001 - 12:27

tu demandes comment compiler un noyau Linux?



saches que des personnes compêtentes prennent de leur temps pour écrire de la doc sur linux. va sur le site de lea-linux.org et tu trouveras toute la doc nécessaire en français en plus, lis-la et pose des questions spécifiques si des choses t'ont échappé. En général, ces docs sont très bien faites. Mieux vaut prendre un peu de son temps pour bien pigé un truc que de demander étape par étape,

c'est un investissement...
  • 0

#18 tetsuo

tetsuo

    Power Member

  • Membres
  • 142 messages

Posté 07 octobre 2001 - 03:19

C'est bien vrais mais, si j'ai pas l'adsl sous linux, ca me sert pas. Dans un 1er temps je veux juste pouvoir surfer(sous linux) et non devoir le faire sous xp puis imprimer les pages, puis rebooter ......

c'est juste pour ça. Apres, je peux aller sur le site et découvrir pas moi meme.

Mais ds un 1er temps, je veux seulement mon ADSL sous linux.



Merci de votre comprehension lol
  • 0

#19 tetsuo

tetsuo

    Power Member

  • Membres
  • 142 messages

Posté 07 octobre 2001 - 03:26

Je viens de lire sur le site lea-linux.org que l'on pouvait faire des scripts, pourais-je mettre le "drivers" usb dans un script et le lancer puisqu'il me semble qu'il n'est pas actif. Cette solution pourrait etre une bonne ou non ?
  • 0

#20 KewlCat

KewlCat

    Modérateur

  • Membres
  • 24 812 messages

Posté 09 octobre 2001 - 11:10

dans les scripts de démarrage (/etc/rc.d/chaipukoi-paskejutiliseslackware-etpasmandrake) tu dois rajouter tous les insmod (ou les modprobe) qui manquent pour rajouter le support USB à ton noyau...

Normalement, c'est déjà prévu, mais mis en commentaire pour éviter de surcharger le démarrage...

Bon courage !
  • 0









Sujets similaires :     x