Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Trouver le bon pilote pour ma carte graphique.


regis56
 Partager

Messages recommandés

Bonsoir tout le monde !

 

Si quelqu'un peut m'aider à trouver le bon pilote pour ma carte graphique ce serait sympa !

 

Je pense en avoir essayer plusieurs :

ati

fglrx

raddeon

 

Et tous ne fonctionnent pas correctement... :P

 

Il doit y avoir quelques chose que je ne fais pas correctement mais quoi ??? :P

 

En ce moment dès que j'en essai un nouveau => X ne veut plus se lancer...

Je vous explique pas la galère !!! :P

 

La j'ai récupéré X mais dès que je lance un test glxgears ca plante. :P

 

Si quelqu'un peut m'aider ce serait sympa. :P

 

Ma distrib est ubuntu noyau en K7 carte ati radeon 9550 256Mo en agp 8x chipset VIA

 

si vous souhaitez plus d'info pas de problème.

 

Merci.

 

Régis.

Lien vers le commentaire
Partager sur d’autres sites

ati et radeon sont des implémentations libres du pilote graphique, ati offrant un peu d'accélération 3D je crois

 

fglrx est le driver propriétaire avec l'accélération 3D proprio (donc pas Mesa)

 

tu peux développer ce que tu as fais?

Lien vers le commentaire
Partager sur d’autres sites

Bonsoir Greywolf !

 

Décidement y a que toi pour t'y coller aux problèmes sur linux :P !!

 

tu peux développer ce que tu as fais?

Ce soir je t'écris du boulot j'ai donc pas toutes les infos mais dès demain je te posterai les logs si tu veux.

 

En gros sinon voici ce que j'ai fais

1/ Installation de easy ubuntu avec normalement l'installation du driver proprio inclut dans le package.

=> Je n'avais pas d'accélaration 3D et le screensaver plantait ! :P

 

2/Installation du pilote ATI proprio d'après le tuto du forum ubuntu

=> Plantage lors du lancement de glxgears

 

3/ Installation du pilote raddeon libre d'après le tuto sur le forum ubuntu

=> Pareille même plantage...

 

4/ Installation du pilote proprio trouvez sur le site officiel ati

=> Un peu plus stable mais des scores vraimment minables une lecture de film en pleine écran avait de quoi faire rigoler...

 

5/ Installation et désintallation de tout ce que j'ai pu trouver sur le NET dont un script qu'y m'a installer tout un tas de trucs tout ca pour perdre X et mon Desktop plus problèmes au niveau de mes sessions enfin bon la mer*** quoi :P j'ai bien cru que j'allais devoir formater :P ca reste encore une de mes solutions...mais bon si on peut éviter j'aime autant.

 

Franchement je ne sait plus trop quoi tenter !!

 

En ce moment je dois avoir fglrx comme pilote mais glxinfo me donne mesa comme constructeur et faut pas que je lance glxgears car sinon plantage.

 

J'avais l'intention de tout redésinstaller et tout reprendre à zero pour au moins la quatrième fois là ! :P

Mon problème c'est que j'ai tellement installé/désisntallé qu'il va falloir tout bien supprimer avant de recommencer...

 

Merci de bien vouloir me guider vers la lumière ! :P

 

Régis.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour tout le monde !

 

Bon voici ce que je fait aujourd'hui

 

J'essai de tout désinstaller proprement pour repartir de zéro

 

=> désisntaller le pilote fglrx

cd /usr/share/fglrx

sudo sh ./fglrx-uninstall.sh

 

Je continu comme ceci

sudo apt-get remove xorg-driver-fglrx

sudo apt-get remove fglrx-control

sudo apt-get remove linux-restricted-modules-common

 

Je vérifie que mes fichiers sont revenus à l'etat initial

sudo gedit /etc/modules

# /etc/modules: kernel modules to load at boot time.

#

# This file contains the names of kernel modules that should be loaded

# at boot time, one per line. Lines beginning with "#" are ignored.

lp

psmouse

pppoatm

sudo gedit /etc/X11/xorg.conf

Section "Device"

Identifier "ATI Technologies, Inc. RV350 AS [Radeon 9600]"

 

Driver "ati"

EndSection

 

sudo gedit /etc/default/linux-restricted-modules-common

DISABLED_MODULES=""

 

Est ce que vous pensez que je suis sur d'avoir bien tout désinstallé comme ca ?

Sinon que feriez vous de plus ?

 

 

=> Je pense que je vais retenter l'installation du pilote radeon libre qui n'as besoin d'aucune installation au moins pas de désintallation compliquée à faire...

Je vais resuivre ce tuto

http://forum.ubuntu-fr.org/viewtopic.php?id=3803

 

Merci

Régis.

Lien vers le commentaire
Partager sur d’autres sites

Re

 

Bon l'installation c'est bien passé voici le score

 

[email protected]:~$ glxgears

922 frames in 5.1 seconds = 179.350 FPS

874 frames in 5.4 seconds = 163.115 FPS

878 frames in 5.2 seconds = 168.628 FPS

879 frames in 5.2 seconds = 170.421 FPS

878 frames in 5.2 seconds = 169.779 FPS

876 frames in 5.3 seconds = 164.733 FPS

875 frames in 5.2 seconds = 166.827 FPS

 

Vous en pensez quoi c'est satisfaisant ?

edit: bon plantage quand même au bout d'un moment alors que je surfais ???

 

Voici les logs après reboot:

[email protected]:~$ cat /var/log/Xorg.0.log | grep "(EE)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

 

et

[email protected]:~$ cat /var/log/Xorg.0.log | grep "(WW)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.

(WW) RADEON: No matching Device section for instance (BusID PCI:1:0:1) found

(WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled(WW) (1280x960,Acer 77e) mode clock 148.5MHz exceeds DDC maximum 110MHz

(WW) (1280x1024,Acer 77e) mode clock 135MHz exceeds DDC maximum 110MHz

(WW) (1280x1024,Acer 77e) mode clock 157.5MHz exceeds DDC maximum 110MHz

(WW) (1600x1200,Acer 77e) mode clock 162MHz exceeds DDC maximum 110MHz

(WW) (1600x1200,Acer 77e) mode clock 175.5MHz exceeds DDC maximum 110MHz

(WW) (1600x1200,Acer 77e) mode clock 189MHz exceeds DDC maximum 110MHz

(WW) (1600x1200,Acer 77e) mode clock 202.5MHz exceeds DDC maximum 110MHz

(WW) (1600x1200,Acer 77e) mode clock 229.5MHz exceeds DDC maximum 110MHz

(WW) (1792x1344,Acer 77e) mode clock 204.8MHz exceeds DDC maximum 110MHz

(WW) (1792x1344,Acer 77e) mode clock 261MHz exceeds DDC maximum 110MHz

(WW) (1856x1392,Acer 77e) mode clock 218.3MHz exceeds DDC maximum 110MHz

(WW) (1856x1392,Acer 77e) mode clock 288MHz exceeds DDC maximum 110MHz

(WW) (1920x1440,Acer 77e) mode clock 234MHz exceeds DDC maximum 110MHz

(WW) (1920x1440,Acer 77e) mode clock 297MHz exceeds DDC maximum 110MHz

(WW) (1152x864,Acer 77e) mode clock 121.5MHz exceeds DDC maximum 110MHz

(WW) (1400x1050,Acer 77e) mode clock 122MHz exceeds DDC maximum 110MHz

(WW) (1400x1050,Acer 77e) mode clock 151MHz exceeds DDC maximum 110MHz

(WW) (1400x1050,Acer 77e) mode clock 155.8MHz exceeds DDC maximum 110MHz

(WW) (1400x1050,Acer 77e) mode clock 184MHz exceeds DDC maximum 110MHz

(WW) (1680x1050,Acer 77e) mode clock 147.14MHz exceeds DDC maximum 110MHz

(WW) (1680x1050,Acer 77e) mode clock 146.25MHz exceeds DDC maximum 110MHz

(WW) (1680x1050,Acer 77e) mode clock 214.51MHz exceeds DDC maximum 110MHz

(WW) (1920x1200,Acer 77e) mode clock 193.16MHz exceeds DDC maximum 110MHz

(WW) (1920x1200,Acer 77e) mode clock 230MHz exceeds DDC maximum 110MHz

(WW) (1920x1440,Acer 77e) mode clock 341.35MHz exceeds DDC maximum 110MHz

(WW) (2048x1536,Acer 77e) mode clock 266.95MHz exceeds DDC maximum 110MHz

(WW) (2048x1536,Acer 77e) mode clock 340.48MHz exceeds DDC maximum 110MHz

(WW) (2048x1536,Acer 77e) mode clock 388.04MHz exceeds DDC maximum 110MHz

(WW) RADEON(0): Enabling DRM support

(WW) RADEON(0): DRI init changed memory map, adjusting ...

(WW) RADEON(0): MC_FB_LOCATION was: 0xcfffc000 is: 0xcfffc000

(WW) RADEON(0): MC_AGP_LOCATION was: 0xffffffc0 is: 0xe3ffe000

 

Ca n'as pas l'air méchant poutant...

 

Bon suite à une série de bug

J'ai remis mon fichier xorg.conf d'origine...

 

A plus.

Modifié par regis56
Lien vers le commentaire
Partager sur d’autres sites

Bonsoir Greywolf !

 

Décidement y a que toi pour t'y coller aux problèmes sur linux :P !!

 

Régis.

 

 

Je ne suis pas d'accord avec toi, en ce qui me concerne il me semble qu'il y a aussi Kewlcat et Emm' parfois.

 

Mais il est vrai que d'une manière général, j'ai remarqué qu'il n'y a pas foule sur le forum des OS et je le regrette. C'est peut être dû au fait que la conception de Linux n'est pas soumis au formattage universel (comme un autre OS qui se veut la référence universel de la world companie) et que le libre permet aussi des installations "ad hoc".

 

Perso, c'est le forum que je visite le plus mais je n'ai pas la compétence pour être d'une quelconque utilité à ce jour. Mais ça viendra, j'apprend :P

 

Moi j'ai des problèmes réccurrents de server X aprés certaines mise à jour. Au début je pensais que cela venait de ma carte graphique (NVIDIA) mais j'ai vite pris le coup de travailler en console et de rétablir mon système.

 

A plus

Lien vers le commentaire
Partager sur d’autres sites

Salut fantassin-06 !

 

Quand j'ai dis ca je ne voulait pas froisser des suceptibilitées...

 

En tout cas ca fait peu de temps que je viens sur ce forum ca c'est vrai je ne peut donc pas trop juger :P

Mais pour l'instant seul greywolf m'as répondu simple constatation.

 

Donc avis aux amateurs :P

Je suis ouvert à toutes propositions.

 

Je pense que ce soir je vais retenter l'installation de fglrx car même avec le pilote ati j'ai des bug...

 

Allez à plus.

 

Régis.

Lien vers le commentaire
Partager sur d’autres sites

Re,

 

:P

 

Alors pas mais vraiment pas pincé dans ma susceptibilité. Juste une petite remarque au passage et un semblant d'explication.

 

Il est vrai que j'aimerais plus d'animation sur le forum OS car je pense que le partage des découvertes même par le biais de problème est un bon moyen de progresser.

 

Monde linux réveillllllllllllles toiiiiiiiiiiiiiiiiiiiiii, les "netteurs" ont besoin de toi............

 

jsuis en forme ce soir......

 

:P

Lien vers le commentaire
Partager sur d’autres sites

Bonsoir tout le monde !

 

Bon j'ai réssayer d'installer fglrx :P

 

Voici ce que j'ai fait :

Installation de fglrx-control par synaptic

ensuite j'ai suivi ce tuto "Deuxiéme Méthode : Génération et installation de paquet Ubuntu pour les drivers ati (8.23.7) sur Dapper" à la lettre

http://linuxfacile.neuf.fr/astuces/Serveur...ti%20Ubuntu.htm

 

Voici mes premiers rapports plutot rassurant non ?

 

[email protected]:~$ fglrxinfo

display: :0.0 screen: 0

OpenGL vendor string: ATI Technologies Inc.

OpenGL renderer string: RADEON 9550 Generic

OpenGL version string: 2.0.5814 (8.25.18)

 

[email protected]:~$ dmesg | grep fglrx

[17180304.820000] fglrx: module license 'Proprietary. © 2002 - ATI Technologie s, Starnberg, GERMANY' taints kernel.

[17180304.820000] [fglrx] Maximum main memory to use for locked dma buffers: 679 MBytes.

[17180304.820000] [fglrx] module loaded - fglrx 8.25.18 [May 18 2006] on minor 0

[17180305.860000] [fglrx] Internal AGP support requested, but kernel AGP support active.

[17180305.860000] [fglrx] Have to use kernel AGP support to avoid conflicts.

[17180305.860000] [fglrx] AGP detected, AgpState = 0x1f000a0b (hardware caps o f chipset)

[17180305.864000] [fglrx] AGP enabled, AgpCommand = 0x1f000302 (selected caps)

[17180305.876000] [fglrx] total GART = 134217728

[17180305.876000] [fglrx] free GART = 118222848

[17180305.876000] [fglrx] max single GART = 118222848

[17180305.876000] [fglrx] total LFB = 126873600

[17180305.876000] [fglrx] free LFB = 116387840

[17180305.876000] [fglrx] max single LFB = 116387840

[17180305.876000] [fglrx] total Inv = 134217728

[17180305.876000] [fglrx] free Inv = 134217728

[17180305.876000] [fglrx] max single Inv = 134217728

[17180305.876000] [fglrx] total TIM = 0

 

[email protected]:~$ cat /var/log/Xorg.0.log | grep "(EE)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

(EE) xf86OpenSerial: Cannot open device /dev/wacom

 

[email protected]:~$ cat /var/log/Xorg.0.log | grep "(WW)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found

(WW) fglrx(0): board is an unknown third party board, chipset is supported

(WW) fglrx(0): Specified desktop setup not supported: 8

 

Maintenant j'ai peur de faire un fgl_glxgears écran noir ou pas :P

 

Je vous tiens au courant !

 

A plus.

Lien vers le commentaire
Partager sur d’autres sites

Re

 

Bon bah j'ai eu l'ecran noir de la mort comme d'hab :P

 

Un peu de recherche sur le net je tombe la dessus :

http://forum.ubuntu-fr.org/viewtopic.php?id=53202

 

J'applique :

 

Voici mon nouveau log

[email protected]:~$ cat /var/log/Xorg.0.log | grep "(EE)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

[email protected]:~$

 

Pas mal hein ! :P

 

Allez je vous tiendrait au courant !

 

A plus.

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous publiez en tant qu’invité. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.
Remarque : votre message nécessitera l’approbation d’un modérateur avant de pouvoir être visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Partager

  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
×
×
  • Créer...