Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

hben

Calculer entre des bornes sur Excel

Messages recommandés

Bonjour TLM

Je m'avisai de vous demander votre aide, pour ceux qui sont experimentés en matière de formules Excel!! je m'explique:

Au départ, pour mettre les notes de mes élèves en stats, j'ai la formule qui recense le nombre d'élèves ayant obtenu moins de 8:

=SI(D$42<>0;NB.SI(D$4:D$41;"<8");"") où D$42 contient le nbre total d'élèves notés

Puis celle qui recense le nombre d'élèves dont la note est supérieure à 8 et inférieure ou égale à 12.

=SI(D$42<>0;NB.SI(D$4:D$41;">=12");"")

Enfin, la formule qui permet de comptabiliser le nombre d'élèves dont la note est supérieure à 12 la voila:

=SI(D$42<>0;NB.SI(D$4:D$41;"<12")-D$48;""

 

b27d66a002fd852e331c273afb709e3d.jpg

 

Mais voila, les nouvelles instructions commandent de relever le nombre d'élèves ayant successivement leur note comprise:

Entre 0 et 4.5, puis entre 5 et 9.5, puis entre 10 et 12.5 puis entre 12.5 et 15 puis au dela de 15!!!

Il faut une formule pour chaque catégorie!!! Alors si vous êtes partant! Je suis preneur avec mes remerciements anticipés!!!

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir,

il n'y aurait pas une inversion entre les deux dernières formules ?

Sinon, as-tu essayé de règler ce pb avec un filtre élaboré ?

Bonsoir Gazo

Merci de ton intervention!!!

En effet je crois bien que tu as raison!!! mais si tu m'en disais un peu plus sur ce "filtre élaboré" dont j'entend parler pour l première fois!!!

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×