Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

PaTaToR

Prob clavier sous débian

Messages recommandés

Salut à tous.

 

Je viens de reinstaller debian et j'ai qques probs avec mon clavier.

Je ne peux pas utiliser les deuxiemes fonctions des touches accessibles normalement en appuyant sur la touche maj.

 

Ca veut dire plus de points, et plus de slash, et bon, c'est quand meme des choses qui peuvent servir....

Ca doit etre un prob avec la touche maj parce que qunad je veux ecrire une majuscule, je suis obligé d'utiliser la touche "verr maj", sinon ca marche pas.

 

Je precise que ma touche n'est pas cassée vu qu'elle marche tres bien sous windows et que ça merde aussi quand je branche un clavier usb (ma debian est installée sur mon ordi portable).

 

J'ai debian avec un noyau 2.6 et xorg. (impossible de faire fonctionner ma carte graphique avec xfree86)

 

Impossible non plus d'écrire le signe euro.

 

Si qqun a une idée; :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

le problème apparait autant en mdoe graphique que dans un terminal?

 

à quoi ressemble la section qui définit ton clavier dans xorg.conf?

 

pour le terminal => dpkg-reconfigure console-data

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait, le probleme n'est la qu'en mode graphique (navigateur internet, nom de fichier, terminal....). Qunad mon server x ne fonctionnait pas, j'avis droit à un clavier normal (sans euro).

 

Petite parenthese : comment je fais à partir d"une interface graphique pour tout fermer et repasser en mode consiole uniquement (point d'interogation)

 

Pour le xorg.conf, ca donne ça :

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver		"keyboard"
Option		"CoreKeyboard"
Option		"XkbRules"	"xorg"
Option		"XkbModel"	"pc105"
Option		"XkbLayout"	"fr"
EndSection

Partager ce message


Lien à poster
Partager sur d’autres sites

étrange... le xorg.conf me semble correct pour un clavier azerty normal :P

 

pour basculer vers un autre tty que le 7 (qui est attribué au serveur graphique par défaut):

Ctrl + Alt + la touche de fonction Fx

(où x est un numéro compris entre 1 et 12 selon le nombre de tty que tu as configuré dans /etc/inittab; 6 par défaut)

 

ton window manager ou ton environnement de bureau c'est ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'utilise gnome, mais avec kde, ya le meme probleme

 

Sinon, le ctrl alt plus F1, ca ne fonctionne pas et j'ai ça dans le fichier dont tu parles :

 

1:2345:respawn:/sbin/getty 38400 tty1

2:23:respawn:/sbin/getty 38400 tty2

3:23:respawn:/sbin/getty 38400 tty3

4:23:respawn:/sbin/getty 38400 tty4

5:23:respawn:/sbin/getty 38400 tty5

6:23:respawn:/sbin/getty 38400 tty6

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×