Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

microdog

[Résolu] PXE - MOF Exiting PXE - ROM

Messages recommandés

Bonjour à tous,

 

Je vous expose mon problème (je vais essayer de résumer ça en quelques lignes) :

 

Il y a environ 1 an et demi, j'avais installé sur mon ordinateur portable (Medion CAD 2000) la distribution Linux Fedora Core 4.

 

Ayant voulu enlever Linux, j'ai supprimé toues les partitions, puis avec un le CD de Windows 98 (Le portable n'a pas de lecteur disquette), j'ai exécuté un fdisk /mbr pour virer le Boot Loader de Linux, Grub.

 

Au redémarrage, j'ai eu droit à ce message :

 

--------------------------------------------------------------

 

Intel UNDI, PXE - 2.0 (build 0.82 Copyright © 1997 - 2000 Intel Corporation

 

For Realtek RTL8110S / 81 695 Gigabit Ethernet Controller v 1.01 (030820)

 

PXE - E61 : Media Test Failure, Check Cable

 

PXE - MOF Exiting PXE - ROM

 

Invalid Partition Table

 

--------------------------------------------------------------

 

Dans le message apparaît ceci :

 

For Realtek RTL8110S / 81 695 Gigabit Ethernet Controller v 1.01 (030820)

 

Alors pour voir j'ai essayé de relier le routeur à la carte Ethernet, puis redémarrer, j'ai droit à ça :

 

-------------------------------------------------------------

 

Intel UNDI, PXE - 2.0 (build 0.82 Copyright © 1997 - 2000 Intel Corporation

 

For Realtek RTL8110S / 81 695 Gigabit Ethernet Controller v 1.01 (030820)

 

Client Mac Addr : <ici adresse mac>

 

DHPC ... / (avec le " / " qui tourne)

 

PXE - E53 : Not Boot Filename Recevied

 

PXE - MOF Exiting PXE - ROM

 

Invalid Partition Table

 

--------------------------------------------------------------

 

Dans les deux cas ce message revient :

 

Invalid Partition Table

 

Je peux installer un système d'exploitation sans problème, mais dès qu'il n'y a plus rien sur le DD, le message revient.

 

J'ai essayé Killdisk, Fdisk, FixMBR, FixBoot, enfin tout ce que j'ai pu trouver.

 

Par contre je n'ai pas essayé l'utilitaire du formatage du DD, je ne l'ai pas trouvé.

 

Quelqu'un pourrait-il éclairer ma lanterne ? :P

 

Merci

 

Bon après-midi.

 

microdog.

Partager ce message


Lien à poster
Partager sur d’autres sites

Et ?

Il essaie de booter comme il peut (cdrom, réseau, disque dur) et il ne trouve rien.

C'est normal, non ?

 

Quand tu formateras et que tu déclareras une partition comme "active" (ou "bootable"), il se plaindra qu'il ne trouve pas d'OS sur cette partition. Normal, quoi...

Une fois que tu auras réinstallé un OS, tout ira mieux, ne t'inquiète pas ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour KewlCat,

 

Ce qui m'inquiète en particulier, c'est le "Invalid partition table"... Au lieu du traditionnel "Operating system not found".

 

Ceci est-il normal ? Peux-tu m'en dire plus ?

 

Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Il me semble que ce soit normal (bien que je n'aie jamais eu de portable Medion).

 

Je crois qu'il cherche des infos qui se trouvaient sur une partition cachée (ou pas), mais toujours est-il que tu as du la supprimer, donc, il la cherche au démarrage (comme tu as fait un fdisk /mbr il ne la trouve pas et te renvoie un message "invalid partition table")

 

Par contre, quand un OS est installé, il trouve les renseignements dont il a besoin, et ne proteste plus...

Partager ce message


Lien à poster
Partager sur d’autres sites

Ce qui me surprend, c'est l'échec du fixmbr. Il doit y avoir un mélange là-dedans...je ne voudrais pas y habiter.

 

Un gros peu de doc, pour ceux qui aiment se muscler les boyaux de la tête.

http://forum.pcastuces.com/sujet.asp?f=01&s=108547

 

A+

 

Bonjour Titus, je rédigeai.

Notes, essai à faire, effectivement.

Modifié par mirware

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu aurais "Operating system not found" si tu avais une partition "active", à mon avis...

Avant de déterminer s'il y a un OS ou pas, le BIOS essaie d'abord de chercher la partition active et d'exécuter ce qui se trouve dans son secteur de boot.... S'il n'y en a pas, ce n'est pas le même message d'erreur.

Ta table de partitions est dans quel état actuellement ?

 

vu la corruption de fat
Comment la FAT peut-elle être corrompue puisqu'il n'y a pas de système de fichiers FAT, et encore moins de partitions ?!?
Ce qui me surprend, c'est l'échec du fixmbr
Où avez-vous lu que le fdisk /mbr avait renvoyé une erreur ??

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Titus,

 

D'accord, tout s'éclaire. Effectivement la partition cachée n'est plus... Tout est logique à présent. :P

 

Merci à vous tous.

 

Je passerai mon problème en résolu dans la soirée, au cas où d'autres réponses viendront. :P

 

Bonne fin d'après-midi à vous et encore merci.

 

EDIT pour Kewlcat : J'ai actuellement une partition principale de 40 Go, une partition étendue prenant le reste du disque dur et un lecteur logique de 30 Go.

 

8f33de55.jpg

Modifié par microdog

Partager ce message


Lien à poster
Partager sur d’autres sites

 

Comment la FAT peut-elle être corrompue puisqu'il n'y a pas de système de fichiers FAT, et encore moins de partitions ?!?

Où avez-vous lu que le fdisk /mbr avait renvoyé une erreur ??

Oui, effectivement Kewlcat. J'ai vu table et je suis parti sur la fat. En réalité, c'est dans le boot que ça doit coincer.

Par contre, l'installation d'un système d'exploitation qui permettrait de refaire ce boot (même s'il le modifie), ça, ça m'intéresserait assez de savoir si ça marche.

 

A+

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×