Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Problème avec Import fichier CSV dans Windows Mail


Invité Notpa
 Share

Messages recommandés

Invité Notpa

Bonjour à tous,

 

Un sujet pas nouveau et largement discuté dans Zeb ou ailleurs : Export des adresses Outlook (Office ou Express) dans Windows Mail. Mais je n'ai pas trouvé de solution. Je galère depuis une semaine sans trouver de solution.

 

J'ai une machine sous XP avec Outlook (Office et Express), une autre avec Windows Mail sous Vista. Je veux récupérer dans Windows Mail mon carnet d'adresses d'Outlook. J'ai fait des exports au format CSV (avec OO ou OE, le fichier CSV est le même).

 

Format du fichier CSV :

 

090122095935264538.jpg

 

Dans Windows Mail, je sélectionne la fenêtre Contacts et je fait in Import à partir de fichier CSV. Il me demande de choisir un champ (je sélectione "Nom" et lance l'import. Mais les contacts ne sont pas corrects. Le séparateur ; ne semble pas marcher. Image de la liste (partielle) des Contacts :

 

090122100249326510.jpg

 

Pour le contact Martine, voici les Propriétés :

 

090122100340741291.jpg

 

Il semblerait que le séparateur ; (point-virgule) ne remplit pas son rôle. J'ai modifié dans Démarrer --> Panneau de configuration --> Options Régionales --> Séparateur : mis , (virgule) au lieu de ; (point-virgule). Pareil : import inccorect.

 

J'ai fait les tests suivants :

 

Options Régionales --> ; séparateur dans le fichier CSV --> ; Pas bon

Options Régionales --> , séparateur dans le fichier CSV --> ; Pas bon

Options Régionales --> ; séparateur dans le fichier CSV --> , Pas bon

Options Régionales --> , séparateur dans le fichier CSV --> , Pas bon

 

Bref, dans tous les cas, le résultat est comme le montrent les images ci-dessus.

 

Quelqu'un à une idée pour mettre à jour correctement les Contacts Windows Mail à partir d'un fichier CSV ?

 

Merci d'avance

 

Notpa01

Lien vers le commentaire
Partager sur d’autres sites

Bonjour Notpa01,

 

Ce n'est pas dans Options Régionales que tu trouveras ton bonheur.

 

Si il faut que les champs soient séparés par des ; à la place des , il faut avec word ou autre, ouvrir ton fichier et faire un

rechercher "," ("virgule")

par ";" ("point virgule")

et remplacer tout.

Sinon, faire le contraire rechercher les points virgules et les remplacer par des virgules.

 

Autre solution (que j'utilise) j'ouvre mon fichier dans Excel je supprime les champs non désirés et je sauve.

Lien vers le commentaire
Partager sur d’autres sites

Invité Notpa

Merci Leminou de te pencher sur mon cas...

 

Mais ce que tu suggères, c'est ce que j'ai fait dans les tests :

 

J'ai fait les tests suivants :

 

Options Régionales --> ; séparateur dans le fichier CSV --> ; Pas bon

Options Régionales --> , séparateur dans le fichier CSV --> ; Pas bon

Options Régionales --> ; séparateur dans le fichier CSV --> , Pas bon

Options Régionales --> , séparateur dans le fichier CSV --> , Pas bon

 

Le fichier CSV s'ouvre automatiquement par Excel. Voir ma première image. Par contre, tu me dis que tu supprimes les champs non désirés. Mais mon CSV n'a qu'un seul champ : colonne A. Le problème viendrait de là ?

 

Notpa01

Lien vers le commentaire
Partager sur d’autres sites

Invité Notpa

Re,

 

Je viens de faire un test avec Windows Mail. J'ai fait un export des contacts. J'ai choisi "Format CSV" et n'ai sélectionné que 3 champs : Prénom, Nom et Adresse de messagerie. Le fichier CSV contient tous les champs dans une seule cellule !

 

,","Martine","","xxxxx","","","","",,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,"[email protected]","[email protected]",,,,,"0/0/00","0/0/00",,,,,"",,"Normale",,"",,,"M.x.",,"","",,,,,,"Normale","Faux",,,,,"Non sp�cifi�"",

 

et non comme je le voudrais :

 

"Martine","xxxxx","[email protected]"

 

Pas très au point (virgule) !

 

Notpa01

Modifié par Notpa
Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...