Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[Résolu] Neuf MediaCenter OpenSuSe


HeAdLeSs
 Share

Messages recommandés

Bonjour à tous,

 

 

L'un d'entre vous utilise-t-il l'appli neuf mediacenter sur une OpenSuSe (11.1 en l'occurence) ?

 

Mon problème est que lorsque je veux démarrer les partages il ne trouve pas le module apache qui bien sur est installé (installation par défaut lors de l'installation de la distro). Je n'ai jamais rencontré ce problème avec debian/ubuntu. J'ai trouvé des méthodes pour modifier apache et faire un répertoire virtuel mais je préfère éviter pour le moment.

 

 

D'avance merci pour toute suggestion !

Modifié par HeAdLeSs
Lien vers le commentaire
Partager sur d’autres sites

Bon j'ai finalement trouvé :

 

Il faut éditer le fichier mediacenter et à la ligne LIBEXEC="NONE" mettre le chemin vers apache2 soit : LIBEXEC="/usr/lib/apache2".

 

Voilà !

 

 

- edit -

 

En fait après il est impossible d'accéder aux partages. La solution est d'éditer les fichiers php et de remplacer les occurences "<?=" par "<?php echo" : source.

 

 

Je vous mets à dispo les fichiers que j'ai modifié moi-même corrigeant ainsi le problème de détection du module apache et le problème de navigation dans l'arborescence des partages : mediacenter_opensuse_edition.

Modifié par HeAdLeSs
Lien vers le commentaire
Partager sur d’autres sites

  • 2 months later...
Invité Invité

Bonjour, je fais remonter le sujet.

Le fichier a l'air de marcher jusqu'à ce que j'essaie de démarrer le Media Center, il écrit

Module PHP 4 ou 5 non trouve !

 

J'ai pourtant installer PHP5. Il y aurait-il un module précis ?

 

Merci !

Lien vers le commentaire
Partager sur d’autres sites

Tu as installé PHP5, certes, mais as-tu installé le module d'Apache qui lui permet d'exécuter du code PHP ?

Lien vers le commentaire
Partager sur d’autres sites

Invité Invité

Oui j'ai bien installé apache2-mod_php5.

C'est vraiment étrange, je me demande si c'est pas un problème dans la configuration du fichier.

Lien vers le commentaire
Partager sur d’autres sites

La solution est d'éditer les fichiers php et de remplacer les occurences "<?=" par "<?php echo" :

 

ou tu actives la directive short_open_tag dans php.ini, non?

Lien vers le commentaire
Partager sur d’autres sites

je me demande si c'est pas un problème dans la configuration du fichier.
Tu as fait en sorte d'activer les bonnes options dans httpd.conf (ou le fichier de config d'Apache2, peu importe son nom) et indiqué à ton module le bon chemin pour le fichier php.ini, n'est-ce pas ? (au passage, tu es bien sous OpenSuse 11.1 ?)
Lien vers le commentaire
Partager sur d’autres sites

Invité Invité

Je savais pas qu'il fallait éditer les fichiers de configuration... alors là je suis complètement perdu. Sinon je suis bien sur Opensuse 11.1.

Lien vers le commentaire
Partager sur d’autres sites

J'ai évoqué le fichier de configuration parce que c'est le seul moyen qui marche à coup sûr quelle que soit la distribution, et surtout parce que je ne connais pas les outils graphiques dont dispose OpenSuse pour paramétrer Apache et PHP :-P

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...