Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Problème firefox javascript


RicoLS
 Share

Messages recommandés

Bonjour,

depuis 1 mois environ, j'ai un problème avec firefox. J'ai tenté de le résoudre via le forum Geckozone, mais pour le moment pas de solution.

Voici le descriptif du problème, suivi de la liste des opérations de tentative de résolution déjà menées.

 

Le problème :

D’une part les clics sur certains liens qui activent un javascript restent inopérants.

D’autre part, lorsque je quitte Firefox, la fenêtre disparaît mais je ne peux le relancer et, si je fais alt+ctrl+supp, je vois qu’il est toujours actif.

2 précisions : j’utilise l’extension noscript, mais le problème persiste lorsque je le désactive.

Le problème a commencé alors que j’utilisais Firefox 3.0.6. Je pensais qu’il se résoudrait avec la maj 3.0.7, mais il n’en a rien été.

Enfin, j'ai fait une tentative avec IE8 sur les sites où je rencontre les problèmes et là tout se passe bien. Le problème est donc, d'une façon ou d'une autre, lié à Firefox.

 

Les tentatives de résolution, qui n'ont rien donné (à chaque fois, le problème persiste)

redémarrage Firefox en mode sans échec

réinstallation de firefox sans les profils (version vierge)

Scan complet avec spybot S&D et avec Avira antivir, que j'utilise toujours configurés au niveau de plus élevé de sécurité : résultat négatif, aucun spyware/virus etc.

Changement de parefeu : auparavant zone alarm, qui pose un pb, mais en fait c'est avec vista (je suis sous xp) ; j'ai maintenant installé pctools

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

Quand tu lances Firefox en mode sans échec (après un reboot ou la première fois), s'arrête-t-il ? et se relance-t-il ?

 

Je ne sais pas si tu as remarqué, il y a une barre en haut qui apparaît quand une page est redirigée, il y a un bouton à droite.

 

Laisse tomber S&D et remplace le par Spyware Terminator.

Lien vers le commentaire
Partager sur d’autres sites

  • 4 weeks later...
Invité STRIKER

Salut Ricols,

 

as tu finalement trouver la solution à ton problème?

je suis actuellement dans le même cas.

Lien vers le commentaire
Partager sur d’autres sites

Salut Striker, eh bien non toujours pas de solution. Ça fait un moment que j'ai laissé tomber car la recherche n'avançait pas (sur le forum geckozone de mozilla, pas de solution non plus et la seule personne qui m'y a aidé tournait sous linux, dons ses capacités d'intervention étaient limitées).

En fait, j'ai remarqué que c'est quand un lien commande l'ouverture d'une nouvelle fenêtre que le problème se produit. J'ai eu l'occasion d'aller sur un site ou un javascript commandait le déroulement d'un menu et là ça fonctionnait sans problème.Si tu veux, je peux te donner une liste de sites où il y a des liens avec lesquels je rencontre le problème. De plus, dans certains cas, je ne suis pas sût qu'il y ait un javascript derrière le lien, mais l'ouverture de la fenêtre ne se produit quand même pas.

Je ne pense pas que ça vienne de mes options de contrôle de l'ouverture des fenêtres car sinon, il n'y a pas de raison que firefox continue de tourner en caché lorsque j'ai quitté.

Précision importante : c'est uniquement une fois que j'ai rencontré un problème d'ouverture de fenêtre que je ne peux plus quitter firefox. Tant que je n'ai pas cliqué sur un lien qui plante, si je quitte firefox, tout se passe normalement.

Modifié par RicoLS
Lien vers le commentaire
Partager sur d’autres sites

Bon alors surprise : pour répondre à la question de leminou, j'ai rebooté et lancé firefox en mode sans échec. Et là, plus de problème : les fenêtres s'ouvrent normalement. Ce qui est curieux, c'est que, à la demande de quelqu'un qui cherchait à m'aider sur le forum geckozone, j'avais déjà fait un test en mode sans échec voici plus d'un mois, sans résultat. Depuis, le seul changement à ma connaissance, c'est les nouvelles versions 3.0.8, puis 3.0.9.

Donc, voici ce que je viens de constater à présent : après que ça ait marché en mode sans échec, j'ai redémarré en mode normal et le problème se pose à nouveau. Toutefois, j'ai peut-être une indication utile : pour faire mes tests, je suis allé sur le site où j'ai rencontré le problème pour la première fois, à l'adresse : http://www.leonoramiano.com/index.php?opti...0&Itemid=22. Là, je rencontre le problème quand je clique sur une des photos puisque c'est censé faire ouvrir une nouvelle fenêtre. Et quand j'ai fait le test avec Firefox en mode normal, après avoir constaté que ça marchait bien en mode sans échec, il m'a ouvert une fenêtre avec le message suivant : Warning: strpos() [function.strpos]: Empty delimiter. in /homez.10/leonoram/www/components/com_jce/jce.php on line 89

Image

Peut-être que ça aidera à trouver la solution ...

Merci à toutes les bonnes volontés

Modifié par RicoLS
Lien vers le commentaire
Partager sur d’autres sites

OK le problème est réglé : c'était l'extension de Skype pour Firefox qui causait le problème. J'ai mis à jour Skype et le problème a disparu.

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...
Invité Invité

Je viens de rencontrer le même type de problème sous Firefox sous Vista : java et javacript étaient activés, j'arrivais à charger ma page hotmail mais impossible de lire mes emails ; quand je cliquais sur un email, il était écrit dans la barre d'état à gauche "java script:;" ou sinon ça affichait "read gfx6.hotmail.com"

La solution est toute simple: il suffit de nettoyer le cache du navigateur!! Détails de la solution ici:

https://support.mozilla.com/tiki-view_forum...8&forumId=1

Lien vers le commentaire
Partager sur d’autres sites

  • 9 months later...
Invité fredo_du_91

Bonjour,

 

J'ai exactement ce problème sous xp avec firefox mais pas IE

C'est arrivé après un bug général du Pc (je n'sais plus pourquoi)

Lorsque je tombe sur un lien javascript sur le site de ma banque par exemple, il suffit que je clique pour que firefox se mette à bugger et reste ouvert même après la fermeture . En plus il n'affiche pas la page!

Il faut que j aille dans gestionnaire de taches puis processus pour fermer firefox réellement

J'ai désinstallé firefox les mises a jour tout tout tout j ai essayé de rétrograder de version mais rien à faire

Les add on que j ai réinstallé genre flagfox fonctionnent de temps en temps

Si vous avez une solution... Ca me ferait plaisir!

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

Je me rappel un ami qui avait eu aussi un soucis dans ces genre la,

Vous parliez de la version 3.0 de firefox qui n'était pas tip top et c'est vrai, je vous conseille la version 3.5.8 (que j'utilise et aucun soucis à noté sous vista ou xp pour ma part) ou encore la bête 3.6 :P

 

 

Cordialement,

 

 

Victorien

Lien vers le commentaire
Partager sur d’autres sites

Invité fredo_du_91

Bonjour!

 

En trouvant ton message j ai essayé de passer en 3.5.8 mais le soucis reste toujours le même: je ne peux pas ouvrir les pop up de type javascript (pour lire mes messages dans certains sites)

Et firefox reste ouvert même après sa fermeture

Obligé d'aller dans processus et de l arrêter salement .

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...