Aller au contenu
NoxAdmin78

[Résolu] Problème installation Ruby - dépendances

Messages recommandés

Bonjour,

 

Je suis sur RedHat 6.0 / 6.1.

Je veux installer Ruby.

Mon problème est que dès le lancement de l'install de Ruby, Linux me sort telle dependance requise.

Lorsque je veux installer la dépendance en question, il me dit autre dependance requise.donc, je lance l'install de la dependance, et là, il me dit qu'il a besoin de la premiere dependance.

Donc, je tourne en rond avec une dependance A qui requiert une dependance B qui requiert la dependance A ..............

Si quelqu'un a une idée, je suis preneur.Merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

J'ai résolu mon problème !

En fait, j'essayais de l'installer via des sources rpm,le serveur en question n'étant pas enregistré pour les depots officiels redhat.

Au final, j'ai trouvé la solution suivante : mon serveur étant sous VMWare, j'ai connecté le dvd d'install de redhat, l'ai monté, et ensuite l'ai configuré comme depot.

A partir de là, effectivement, un simple yum install ruby, et plus de probleme de dependance, tout est dans le dvd, yum gere ça tout seul.

 

En tout cas, merci pour t'être penché sur mon probleme, et si l'astuce de monter le dvd d'install en tant que depot peut servir à quelqu'un, c'est cool.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le problème semble avoir trouvé sa solution.

Ainsi, afin de signaler clairement à ceux qui ont un problème similaire qu'ils ont peut-être une solution toute trouvée (s'ils pensent à utiliser la fonction Recherche en indiquant le mot-clé "résolu" auparavant), et afin de signaler aux autres contributeurs qu'il est inutile de continuer à se creuser la tête sur le problème (à moins d'avoir des suppléments d'informations à apporter pour mieux comprendre ce qui posait problème), un modérateur a préfixé le titre du topic avec la mention [résolu].

Merci, à l'avenir, de bien vouloir prendre à votre charge cette mise à jour quand vous estimez que votre problème a été résolu de manière satisfaisante (et parallèlement, si le problème a disparu "mystérieusement", inutile d'induire les gens en erreur ;-)) Pour cela, modifier.gif votre premier message :-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×