Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Configuration Wamp/Apache sur une VM pour accès lecteur réseau


xerel
 Share

Messages recommandés

Bonjour,

 

Je suis sous window 7 edition familiale x64

J'ai installé une machine virtuelle sur mon pc, cette machine virtuelle sert notamment a pouvoir accéder a des navigateurs web plus anciens pour le développement de site web.

J'ai sur ma machine hote un wamp dont le fichier /www regroupe tous mes travaux. J'ai partagé ce fichier /www avec la machine virtuelle. Celui-ci apparait sur la machine virtuelle comme un lecteur réseau E:/.

J'ai installé sur cette machine virtuelle un nouveau wamp, donc ce nouveau wamp pointe par default surle fichier www dont le chemin est C:/wamp/www/.

Cependant ayant fait le partage de mon fichier /www de ma machine hote avec la machine virtuelle, j'aimerais faire pointer le wamp de la machine virtuelle sur le lecteur réseau, ainsi pas besoin de dupliquer mes travaux.

J'ai lu beaucoup de chose à ce sujet.

 

Les lignes qui me concernent sont dans le httpd.conf concerne le DocumentRoot

DocumentRoot "C:\wamp\www" 
<Directory "C:\wamp\www"> 

 

Le chemin d'accès au lectur réseau est

E:\

Il semblerait que l'on ne puisse pas mettre la lettre d'un lecteur réseau et qu'il faille utiliser l'UNC il s'agit pour ce lecteur de "\\vboxsrv" Cependant même en mettant ça suivit du nom du fichier partagé soit \\vboxsrv\www (avec slashs ou anti-slashs) ça ne fonctionne pas.

 

Dans le cas de //vboxsrv seul, wamp block au demarage, l'icone est orange.

Dans le cas de //vboxsrv/www/ j'arrive sur la page d'accueil mais aucun de mes projets ne s'affiche sur l'accueil de wamp.

 

J'ai lu qu'il y avait aussi des droits délivrés à wamp. J'ai été changé les droits de wampapache et wampmysqld dans services.msc, pour démarrer wamp en tant qu'utilisateur et donc avoir accès au lecteur réseau, et en "network service" mais rien n'y fait a ce moment la, wamp ne démarre même plus. Il y a seulement en "localsystem" que wamp demarre.

 

J'ai lu également que l'on pouvait utilisé l'ip de la machine hote dans le chemin d'accès mais je n'est pas reussi à mettre ça en place.

 

Pensez vous qu'il est possible de faire pointer wamp/apache d'une machine virtuelle vers lecteur réseau dont le fichier partagé est sur la machine hôte ?

 

Je pense ne pas être trop loin de la solution mais un petit coup de main ne serait pas de refus !

 

Merci par avance !

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...