Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Manudegand

prob envoi de donnee avec adsl reseau local

Messages recommandés

Voila j'ai remarqué que quand on met des ordis en reseau avec partage de l'adsl et bien on ne sait pas tout le temps envoyer des fichiers genre sous msn messenger. Et des copains a moi ont le meme prob ... y a t il un soluce?

Partager ce message


Lien à poster
Partager sur d’autres sites

:P

ouais j'ai le même PB je pensais que c'était à cause de mon firewall,

mais maintenant que tu me dit ça je pense qu'effectivement tout cela est

du au partage de connection internet, Mon pote qui est admin m'a dit

que c'est à cause de la translation d'adresse car internet ne voit qu'un adresse IP sur ton LAN, pour l'instant je n'ai pas de soluce à te donner,

En espèrant que quelqu'un nous aidera

 

TCHAO

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut :P ,

 

ça ressemble à un problème de MTU ( Max Transmission Unit) trop élevée sur les postes clients.

Il faut baisser la valeur de la clé MaxMTU dans le registre jusqu'à ce que ça passe.

 

Pour déterminer la valeur de MTU, sous DOS:

ping -f -l [taille du paquet <=1500] [www.tonfai.com]

 

et tu décrémentes la taille du paquet jusqu'à ce qu'il n'y ait plus besoin de fragmenter.

 

Pour régler la valeur dans le registre des clients:

sous Win9x, ME

HKEY_LOCAL_MACHINE

SystemCurrentControlSetServicesClassNetTrans00n (où 000n correspond au protocole TCP/IP associé au périphérique servant à te connecter =>carte réseau)

créer la chaine de caractères MaxMTU et lui donner la valeur définie ci-dessus (<=1500)

 

sous 2K (et XP :-P )

HKLMSYSTEMCurrentControlSetServices

TcpipParametersInterfaces<interface>

valeur DWORD MTU + valeur <=1500

 

+ d'infos sur www.speedguide.net (et oui en anglais :-( )

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon c'est vrai qu'il faut vérifier dans un premier temps que ton NAT fonctionne correctement (d'ailleurs comment tu fais ton réseau local :P NAT, proxy sur PC serveur ou routeur hard ?)

 

Est ce qu'à partir d'un poste de ton LAN, tu arrives à lancer un chat ou des messages avec MSN Messenger vers le WAN?

Normalement, ton routeur ou ton log de partage empaquete les données qu'il reçoit avec une surcouche (une sorte de tag) pour savoir de quel et à quel PC les données sont destinées.

Si c'est véritablement un problème de MTU sur les postes clients, tu devrais avoir des difficultés à accéder à des sites comme voila.fr ou yahoo.fr à partir de ceux ci. Commence déjà par tester ça.

 

Si c'est pas un problème de MTU, comme a dit laubean le WAN ne voit que ton IP publique et non les IP privées de tes PC clients et là ça devient plus coton (quoique j'ai déjà réussi à faire du RogerWilco entre 2 LAN distantes sans souci). Il faudrait vérifier quels ports sont utilisés par ton log de messagerie et comment ton routeur/logiciel gère l'empaquetage des données.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon c'est pas un problème de MTU... en cherchant un peu sur http://messenger.msn.com/support/knownissues.asp

tu peux trouver ça:

Internet Connection Sharing using ICS/NAT

 

Currently, certain extended features of MSN Messenger, such as voice conversations and file transfer, might not work behind Internet Connection Sharing applications and hardware (often called NATs). Basic functionality such as signing in, instant messaging, and checking e-mail should not be affected at all.  

 

La seule solution serait alors de faire via un proxy comme proposé ici

(Corporate Users) If you are behind a firewall or within a company local area network (LAN), MSN Messenger and other instant messaging programs could be blocked by the firewall or your company's security restrictions. Please contact your Network Administrator for assistance. For more information on what ports a Network Administrator should open for MSN Messenger to work, please see "Guide for Network Administrators" found in Help (Help | Help Topics | All Topics). Make sure that in MSN Messenger under Tools | Options, the I use a proxy server check box is clear on the Connection tab. Only certain proxy servers require this, so unless you have been told to select this by your network administrator, do not do so.  

 

l'aide en ligne propose donc

For instant messaging

 

To allow your network users to have a direct connection to instant messaging services, you will need to:

 

Open outgoing TCP connections to Port 1863 on your proxy servers.  

Let your network users know which kind of proxy server your network uses (HTTP, SOCKS4, or SOCKS5) and provide them with the corresponding details (server name, port number, and so forth) so they can enter that information on the Connection tab of the Options dialog box (Tools, Options).  

Make sure the internal local area network has access to the Domain Name System (DNS) servers to resolve the names of external hosts such as messenger.msn.com.

 

For file transfer

 

Both incoming and outgoing TCP connections use this range of ports: 6891 to 6900. This allows up to 10 simultaneous file transfers per sender. If you open only Port 6891, users will be able to do only one file transfer at a time.

 

The TCP ports need to be configured so that sockets on a port remain open for extended periods of time.

 

Note

 

File transfer may not work if you are behind a network address translation (NAT) device.

 

 

 

ça ira comme ça? :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut greywolf !

Moi, j'ai le meme problème, je "partage" ma connexion adsl via un routeur hard : routeur --> hub -->pc1

-->pc2

 

J'ai utiliser la redirection de port nat pour les soft de P2P comme Edonkey ( port 4662 TCP pour l'info ;o) et ca marche impec, j'ai plus de low id, maintenant, je m'attacque à msn messager, sauf que là, le redirection de marche pas... logique :P

Je chercher un peu et je tombe sur ca :

 

http://support.microsoft.com/default.aspx?...d=kb;FR;q278887

 

je suis pas un monstre en anglais, mais j'ai compris qu'il faut passer par un proxy... est ce que tu pourrais m'expliquer ?

Partager ce message


Lien à poster
Partager sur d’autres sites

y'a MSN Messenger 5.0 qui est sorti et dont le protocole de connexion semble avoir été amélioré pour un meilleur fonctionnement derrière des routeurs:

http://www.clubic.com/n/gen/n6948.html

 

Avec les versions précédentes, le routage NAT n'était pas possible car le protocole utilisé par MSN ne permettait pas un dépaquetage correct des informations d'en-tête (qui contiennent les informations IP source et destination ainsi que les ports utilisés).

La solution préconisée avec les anciennes versions est donc de faire un relai par un serveur proxy...

 

 

Là où je sais pas si ça peut fonctionner, c'est l'installation d'un serveur proxy socks derrière ton routeur sur une des machines du LAN. L'application MSN des autres postes se connecterait sur le proxy de la machine (sur un port de ton choix) et le proxy serait autorisé sur le routeur à établir des connexions sortantes sur 1863 et entrantes/sortantes sur une plage de ports (6891-6900 comme expliqué plus haut par exemple).

Toutes les requetes MSN passeraient par un seul poste du LAN dont le proxy relaieraient les infos via le routeur sur internet....:P:-?

 

Ca me parait un peu scabreux comme solution et ça se trouve c'est pas possible (un admin réseau pourrait me prévenir si je dis des c*** plus grosses que moi ? :-( )

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×