Aller au contenu
Galyad

Refus d'accès aux fichiers en local sous Wamp

Messages recommandés

Bonjour,

 

Lorsque je lance la page d'accueil de Wamp en local dans mon navigateur, mes dossiers et fichiers s'affichent correctement (dossiers et fichiers visibles). Mais quand je clique sur l'un des liens pointant vers les fichiers dans l'arborescence, l'accès aux fichiers est refusé.

 

Ces 2 messages s'affichent systématiquement:

 

Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

 

Fatal error: Unknown: Failed opening required 'C:/wamp/www/TP1_PHP_objet/TP1/Personne.php' (include_path='.;C:\php\pear') in Unknown on line 0

 

J'ai fait des essais et des tests:

- en modifiant les droits dans le httpd.conf (les params du <Directory "c:/wamp/www/"> sont ceux par défaut) ;

- en ajoutant le path en question dans les variables d'environnement;

- en partageant le dossier www de wamp...

 

Je n'ai rien modifié concernant le .htaccess non plus.

 

J'ai aussi parcouru de nombreuses réponses à des messages similaires sur d'autres forums avant de poster ce message, ainsi que le site d'Apache et le manuel php en ligne.

 

Je ne parviens pas à identifier la cause du blocage...(peut-être ai-je loupé ou mal fait quelque chose), et ne sais plus par où prendre ce problème d'autorisation.

 

Mes versions:

Apache 2.2.22

PHP 5.3.13

 

Quelqu'un saurait-il me dépanner ?

 

Merci d'avance pour votre aide.

 

PS: j'avais le même pb avec xampp

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut


Fatal error: Unknown: Failed opening required 'C:/wamp/www/TP1_PHP_objet/TP1/Personne.php' (include_path='.;C:\php\pear') in Unknown on line 0

La solution doit sans doutre être de virer le .; ...vue sur le web...

Modifié par Bob49

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Bob,

 

Merci pour ton retour.

 

J'ai décommenté la ligne du paragraphe "Paths and Directories" du PHP.ini en retirant le ";" de début de ligne, et aussi essayé avec et sans le ".;" du chemin. Et bien ajouté le C:\php\pear dans le path.

 

Malheureusement c'est sans effet.

  • Upvote 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×