Aller au contenu
Zizou255

WinDev 18 - le combo dans la table n'afiche pas les données

Messages recommandés

Bjr
J'ai un problème avec mon combo dans ma table qu'il n'à fiche pas les données. Voilà :* ma BD contient un fichier client
1- j'ai créer une fenêtre ajouté elle contient les champs année nom prénom ...
2- ensuite j'ai créer une 2ème fenêtre qui contient un champs combo année et une table
3- requête ajout + requête sélection
4- le pb est quand je sélectionné l'année toutes affiche bien sauf combo il n'affiche pas les données ==》CHAMP VIDÉO OU DES NUMÉROS AU LIEU DES DONNES
Mon code source est comme suite :
1- code dans bouton ajouter de la fenêtre ifu ajout:


SI SAI_Date_naissance_commune="" OU COMBO_Code_inspection_activité ="" OU SAI_Adresse_domicile="" OU SAI_nom="" OU SAI_prénom="" ALORS
Ouvre(FEN_erreur)
SI SAI_Date_naissance_commune ="" ALORS
SAI_Date_naissance_commune..CouleurFond = RGB(180,180,180)
FIN


SI COMBO_Code_inspection_activité ="" ALORS
COMBO_Code_inspection_activité..CouleurFond = RGB(180,180,180)
FIN
SI SAI_Adresse_domicile ="" ALORS
SAI_Adresse_domicile..CouleurFond = RGB(180,180,180)
FIN
SI SAI_nom ="" ALORS
SAI_nom..CouleurFond = RGB(180,180,180)
FIN
SI SAI_prénom ="" ALORS
SAI_prénom..CouleurFond = RGB(180,180,180)
FIN
SINON
REQ_client_ajouter.Param1 = SAI_nom
REQ_client_ajouter.Param2 = SAI_prénom
REQ_client_ajouter.Param3= SAI_Date_naissance_commune
REQ_client_ajouter.Param4 = SAI_Date_jugement
REQ_client_ajouter.Param5 = COMBO_Code_commune_naissance
REQ_client_ajouter.Param6 = COMBO_Code_wilaya_naissance
REQ_client_ajouter.Param7 = COMBO_Libellé_commune_naissance
REQ_client_ajouter.Param8 = COMBO_Libellé_wilaya_naissance
REQ_client_ajouter.Param9 = COMBO_Code_sexe
REQ_client_ajouter.Param10 =SAI_N_acte_naissance
REQ_client_ajouter.Param11 = SAI_N_acte_naissance_portant_la_mention_BIS
REQ_client_ajouter.Param12 =SAI_N_serie_acte_de_naissance
REQ_client_ajouter.Param13= SAI_Nis
REQ_client_ajouter.Param14=SAI_Nationalité
REQ_client_ajouter.Param15= COMBO_Code_rc_ca_agrement
REQ_client_ajouter.Param16= SAI_N_registre_commerce
REQ_client_ajouter.Param17= SAI_Libellé_activité
REQ_client_ajouter.Param18=COMBO_Code_inspection_activité
REQ_client_ajouter.Param19=SAI_Article_activité
REQ_client_ajouter.Param20= SAI_Adresse_activité
REQ_client_ajouter.Param21= SAI_Adresse_domicile
REQ_client_ajouter.Param22=COMBO_Code_diw
REQ_client_ajouter.Param23= SAI_Code_inspection_gestion
REQ_client_ajouter.Param24= COMBO_Libellé_inspection_gestionCode_inspection_domicile
REQ_client_ajouter.Param25= COMBO_Code_inspection_domicile
REQ_client_ajouter.Param26= COMBO_Libellé_inspection_domicile
REQ_client_ajouter.Param27=SAI_Article_domicile
REQ_client_ajouter.Param28= SAI_Code_recette_act
REQ_client_ajouter.Param29= SAI_Regime_fiscal
REQ_client_ajouter.Param30= SAI_Nbr_salariés
REQ_client_ajouter.Param31= SAI_N_cnas
REQ_client_ajouter.Param32= SAI_Nature_origine_locaux
REQ_client_ajouter.Param33= SAI_Avantage_fiscal
REQ_client_ajouter.Param34=COMBO_année
HExécuteRequête(REQ_client_ajouter)
RAZ()

FIN

2- code dans la fenêtre ifu qui contient le tableau et combo année dans prise de focus de Fen_ifu:

t est un entier

TableSupprimeTout(TABLE_Ifu)
REQ_client_selection.Param4=FEN_ifu.COMBO_année
HExécuteRequête(REQ_client_selection)
HLitPremier(REQ_client_selection)
TANTQUE PAS HEnDehors(REQ_client_selection)
TableAjouteLigne(TABLE_Ifu)


t = t+1
COL_Nom[t] = REQ_client_selection.Nom
COL_Prénom[t] =REQ_client_selection.Prénom
COL_Article_activité[t] = REQ_client_selection.Article_activité
COL_Adresse_activité[t] = REQ_client_selection.Adresse_activité
COL_Adresse_domicile[t] = REQ_client_selection.Adresse_domicile
COL_Article_domicile[t]=REQ_client_selection.Article_domicile
COL_Avantage_fiscal[t]=REQ_client_selection.Avantage_fiscal
COL_Code_commune_naissance[t] = REQ_client_selection.Code_commune_naissance
COL_Code_diw[t] = REQ_client_selection.Code_diw
COL_Code_inspection_activité[t] = REQ_client_selection.Code_inspection_activité
COL_Code_inspection_domicile[t] = REQ_client_selection.Code_inspection_domicile
COL_Code_inspection_gestion[t] = REQ_client_selection.Code_inspection_gestion
COL_Code_rc_ca_agrement[t] = REQ_client_selection.Code_rc_ca_agrement
COL_Code_recette_act[t] = REQ_client_selection.Code_recette_act
COL_Code_sexe[t] = REQ_client_selection.Code_sexe
COL_Code_wilaya_naissance[t] = REQ_client_selection.Code_wilaya_naissance
COL_Date_jugement[t] = REQ_client_selection.Date_jugement
COL_Date_naissance_commune[t] = REQ_client_selection.Date_naissance_commune
COL_Libellé_activité[t] = REQ_client_selection.Libellé_activité
COL_Libellé_commune_naissance[t] = REQ_client_selection.Libellé_commune_naissance
COL_Libellé_inspection_domicile[t] = REQ_client_selection.Libellé_inspection_domicile
COL_Libellé_inspection_gestionCode_inspection_domicile[t] = REQ_client_selection.Libellé_inspection_gestionCode_inspection_domicile
COL_Libellé_wilaya_naissance[t] = REQ_client_selection.Libellé_wilaya_naissance
COL_N_acte_naissance[t] = REQ_client_selection.N_acte_naissance
COL_N_acte_naissance_portant_la_mention_BIS[t] = REQ_client_selection.N_acte_naissance_portant_la_mention_BIS
COL_N_cnas[t] = REQ_client_selection.N_cnas
COL_N_registre_commerce[t] = REQ_client_selection.N_registre_commerce
COL_Nationalité[t] = REQ_client_selection.Nationalité
COL_Nature_origine_locaux[t] = REQ_client_selection.Nature_origine_locaux
COL_Nbr_salariés[t] = REQ_client_selection.Nbr_salariés
COL_Nis[t] = REQ_client_selection.Nis
COL_Regime_fiscal[t] = REQ_client_selection.Regime_fiscal



HLitSuivant(REQ_client_selection)
FIN

3- code dans le combo année, je mis ce code dans sélection d'une ligne de combo_année :

COL_Adresse_activité=""
COL_Adresse_domicile=""
COL_Article_activité=""
COL_Article_domicile=""
COL_Avantage_fiscal=""
COL_Code_commune_naissance=""
COL_Code_diw=""
COL_Code_inspection_activité=""
COL_Code_inspection_domicile=""
COL_Code_inspection_gestion=""
COL_Code_rc_ca_agrement=""
COL_Code_recette_act=""
COL_Code_sexe=""
COL_Code_wilaya_naissance=""
COL_Date_jugement=""
COL_Date_naissance_commune=""
COL_Libellé_activité=""
COL_Libellé_commune_naissance=""
COL_Libellé_inspection_domicile=""
COL_Libellé_inspection_gestionCode_inspection_domicile=""
COL_Libellé_wilaya_naissance=""
COL_N_acte_naissance=""
COL_N_acte_naissance_portant_la_mention_BIS=""
COL_N_cnas=""
COL_N_registre_commerce=""
COL_N_serie_acte_de_naissance=""
COL_Nationalité=""
COL_Nature_origine_locaux=""
COL_Nbr_salariés=""
COL_Nis=""
COL_Nom=""
COL_Prénom=""
COL_Regime_fiscal=""
i est un entier

TableSupprimeTout(TABLE_Ifu)
REQ_client_selection.Param4=FEN_ifu.COMBO_année
HExécuteRequête(REQ_client_selection)

HLitPremier(REQ_client_selection)
TANTQUE PAS HEnDehors(REQ_client_selection)

TableAjouteLigne(TABLE_Ifu)
i=i+1

COL_Nom = REQ_client_selection.Nom
COL_Prénom =REQ_client_selection.Prénom
COL_Article_activité = REQ_client_selection.Article_activité
COL_Adresse_activité = REQ_client_selection.Adresse_activité
COL_Adresse_domicile = REQ_client_selection.Adresse_domicile
COL_Article_domicile=REQ_client_selection.Article_domicile
COL_Avantage_fiscal=REQ_client_selection.Avantage_fiscal
COL_Code_commune_naissance = REQ_client_selection.Code_commune_naissance
COL_Code_diw = REQ_client_selection.Code_diw
COL_Code_inspection_activité = REQ_client_selection.Code_inspection_activité
COL_Code_inspection_domicile = REQ_client_selection.Code_inspection_domicile
COL_Code_inspection_gestion = REQ_client_selection.Code_inspection_gestion
COL_Code_rc_ca_agrement = REQ_client_selection.Code_rc_ca_agrement
COL_Code_recette_act = REQ_client_selection.Code_recette_act
COL_Code_sexe = REQ_client_selection.Code_sexe
COL_Code_wilaya_naissance = REQ_client_selection.Code_wilaya_naissance
COL_Date_jugement = REQ_client_selection.Date_jugement
COL_Date_naissance_commune = REQ_client_selection.Date_naissance_commune
COL_Libellé_activité = REQ_client_selection.Libellé_activité
COL_Libellé_commune_naissance = REQ_client_selection.Libellé_commune_naissance
COL_Libellé_inspection_domicile = REQ_client_selection.Libellé_inspection_domicile
COL_Libellé_inspection_gestionCode_inspection_domicile = REQ_client_selection.Libellé_inspection_gestionCode_inspection_domicile
COL_Libellé_wilaya_naissance = REQ_client_selection.Libellé_wilaya_naissance
COL_N_acte_naissance = REQ_client_selection.N_acte_naissance
COL_N_acte_naissance_portant_la_mention_BIS = REQ_client_selection.N_acte_naissance_portant_la_mention_BIS
COL_N_cnas = REQ_client_selection.N_cnas
COL_N_registre_commerce = REQ_client_selection.N_registre_commerce
COL_Nationalité = REQ_client_selection.Nationalité
COL_Nature_origine_locaux = REQ_client_selection.Nature_origine_locaux
COL_Nbr_salariés = REQ_client_selection.Nbr_salariés
COL_Nis = REQ_client_selection.Nis
COL_Regime_fiscal = REQ_client_selection.Regime_fiscal



HLitSuivant(REQ_client_selection)

FIN


Aider moi presque j'ai fini le projet. Quand je sélectionné combo_année les champs texte affiche correctement dans le tableau sauf combo n'affiche pas les données malgré j'ai rempli le champ Combo avec les même donné

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×