Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Greywolf

un LAN Linux/Win98

Messages recommandés

Sous KDE, lorsque j'essaie d'accéder au réseau local via les dossiers personnels de l'utilisateur loggé, j'obtiens : "Unable to contact localhost"

 

Dans les paramètres réseau, j'ai bien renseigné IP/masque, groupe de travail pour partage Windows (d'ailleurs le partage de connexion internet marche impec)

 

Les Démons LISa et ResLISa sont en config automatique et le pingouin me dit que c'est bon.

 

Faut faire kekchose de particulier pour avoir un voisinage réseau (parce que passer par le FTP du PC sous Win98, c'est un peu lourd :-P ):

 

Ah oui, il me parle de client Samba à un moment, faut le lancer? si oui, comment?? :-(

 

PS: au cas où vous ne l'auriez pas remarqué, je suis totalement :P dans pingouinland :-P

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, j'ai installé Samba, le serveur tourne ......

 

mais y'a nulle part de fichier smb.conf :-(:-P:-P

 

même en faisant which smb.conf dans le terminal, il me dit qu'il trouve pas :P

 

:-P j'fais comment moi maintenant :-P

Partager ce message


Lien à poster
Partager sur d’autres sites

Normalement le smb.conf se trouve dans /etc mais il me semble que chaque user peut creer le sien et le mettre dans son home : ~/smb.conf

 

Tu as essayé "man smb" et cie ....

 

Automne

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Automne de t'intéresser à mon cas :-P

 

le "man smb" me retourne "il n'existe pas de page du manuel pour smb". Bon, ben je vais faire sans alors :-P

 

En farfouillant dans le Mandrake Control Center, je suis tombé sur un item "point de montage samba" => ça m'a l'air intéressant ça : iclick :-P

 

Linux: "Le client Samba n'est pas installé"

Moi: ah? ça s'installe pas en même temps que le serveur ça :-P

 

Linux: "Voulez vous l'installer?"

Moi: un peu que je veux ! :-P

 

2 minutes plus tard, je peux voir dans cet item les répertoires partagés sur le poste Windows. Victoire, me dis-je :P

 

Retour via répertoire utilisateur=> réseau local : impossible d'atteindre localhost :-P:-P

 

Bon qu'à cela ne tienne, je lance le demon LISa via le terminal =>OK ça tourne, écoute sur port xxx.

Et là dans réseau local, je vois le nom du PC qui doit avoir linux.

 

(d'ailleurs à ce propos, j'ai du merder dans l'attribution des noms des ordinateurs parce que lorsque j'ai configuré l'accès internet via la passerelle, je lui ai mis le nom d'ordi de la passerelle et j'ai la désagréable impression que Linux a également attribué ce nom au PC qui tourne sous Linux => ça se corrige où ça??)

 

je ferai d'autres essais ce soir :-(

Partager ce message


Lien à poster
Partager sur d’autres sites

A mon avis, si la mandrake t'a installé des choses, tu dois avoir un smb.conf qui doit trainer kkpart maintenant. Genre dans ton home ou dans /etc

Pour corriger le nom de machine, je pense que tu dois pouvoir trouver ca facilement dans ce smb.conf.

 

Mais c'est vrai qu'avec les outils de la mandrake, je ne suis pas sur. D'habitude, je fais ca à la mano et ca fonctionne plutot bien.

 

Sinon pour "man smb" ben j'ai plus de linux sous la main alors essaye "man smb.conf", "man samba", "man smbd" ... etc .... Et tu regardes les "related topics"

 

Automne

Partager ce message


Lien à poster
Partager sur d’autres sites

ça y est j'ai trouvé un smb.conf dans etc/samba/ :-P (je l'ai trouvé en faisant testparm parce que la commande which smb.conf ne retournait rien :-P )

 

Je l'ai édité en root et vu l'ampleur du fichier, j'ai uniquement modifié le groupe de travail pour qu'il coïncide avec celui de windows.

 

 

Ce fichier smb.conf, il faut que je le mette dans usr/local/samba/lib ? comme indiqué ici ? (auquel cas il faut que je crée un rep samba/lib)

 

dans le Mdk control center, je vois les ressources partagées sur le PC Windows, je peux définir un point de montage pour chaque periph et lorque je fais "monter" => message d'erreur : le montage a échoué :-P

 

 

Je pense que mon problème de nom d'hôte identique sur les 2 PC doit foutre le souk, il n'y a aucune mention du nom d'hôte dans smb.conf, donc comment c'est y qu'on fait pour modifier ce nom d'hôte (celui qui apparait au prompt : user@nom_d'hote)

 

un grand merci aux Linuxiens dévoués :P:-(

Partager ce message


Lien à poster
Partager sur d’autres sites

bon je sais pas comment j'ai fait mais j'arrive à avoir un réseau

(pas encore bien optimisé certes mais au moins ça marche dans le sens Linux=>Windows en tant que root) :-P

 

J'ai du installé les packages NFS pour pouvoir monter les partitions dans /mnt/nom_du_rep....

pouvait pas le faire tout seul le pingouin? :-P

 

y'a que comme ça qu'on peut faire ou y-a-t-il moyen via le lien réseau local (lan://localhost => impossible de trouver le parent de l'élément. Problème interne :-P )

 

J'ai partagé des rep Linux, je vois bien le nom Netbios du serveur Samba dans le voisinage réseau de Win mais il me demande un mot de passe pour y accéder alors que je n'ai défini nulle part de mot de passe (ou alors à l'insu de mon plein gré) dans smb.conf :-P

 

et depuis au boot,il me met des messages d'erreur modprobe

et lorsque j'arrête il n'arrive pas à démonter les répertoires de windows :P => crash du shutdown de Linux :-(

 

Je sais pas pourquoi j'ai l'impression que c'est le bordel dans mon Mandrake :-P:-P

c'est possible qu'il fasse un check up du système et qu'il répare comme un grand ? (ptet que j'en demande trop là :-P )

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai l'impression que je fais un monologue :-P , mais si une âme charitable me lit et peut me donner quelques pistes, parce qu'à défaut de maîtriser le pingouin je sens que je vais devenir chèvre :P .

 

Suite à mes soucis ci-dessus, j'ai refait une install propre (formatage des partitions) et reinstall de la mdk 8.2 avec samba et nfs.

Jusque là OK, ça va.

J'arrive à monter dans /mnt/ les répertoires partagés de windows, y accéder, tout ça tout ça mais là ou ça colle plus, c'est que je ne peux plus démarrer Linux si je n'enlève pas le câble qui relie les 2 PCs:

 

il s'arrête au "montage des fichiers SAMBA" lors du boot :-(

(et puis j'ai toujours cette foutue ligne: modprobe: insmod uhci failed)

 

 

c'est grave docteur? :-P

Partager ce message


Lien à poster
Partager sur d’autres sites

Excuse-moi, je ne suis pas un pro de SAMBA. Tout ce que je sais c'est que j'ai jamais installé NFS pour pouvoir partager des ressources.

Tu as le serveur pour partager tes ressources et le client pour acceder aux ressources des autres machines.

 

Automne

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×