Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

ipl_001

Comment arrêter un service W2K Serveur ?

Messages recommandés

Bonsoir à tous,

 

(Windows 2000 Advanced Server)

Cet après-midi, j'ai eu à arrêter des services puis tuer des processus qui me prenaient trop de CPU...

... plus précisément, il s'agit de 5 services ARCserve que j'ai arrêtés de manière habituelle

... les processus étaient 4 ou 5 processus asrunjob.exe c'est à dire ARCserve également (des copies de fichiers faites par ARCserve -pas des sauv., des copies-)

 

Mon problème est que je ne parviens plus à démarer l'un des services, "Moteur de base de données ARCserve" qui est resté dans l'état "Stopping" !

Quelqu'un pourrait-il me dire comment démarrer voire arrêter correctement ce service ?

Merci !

Partager ce message


Lien à poster
Partager sur d’autres sites

Normalement il y a un gestionnaire de service arcserve, regarde ce qui se passe en le lancant depuis lui

 

Sinon t'as fait un reboot du serveur ?

 

lances le gestionnaire arcserve (celui des sauvegardes) normalement il met en route le service de database.

 

Si ca bug toujours je crois qu'un tour dans le gestionnaire d'évênement s'impose des fois qu'un composant laisse des erreurs...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir tesgaz, bonsoir à tous,

Salut ipl_001

 

avec la commande net

 

dans une invtite cmd

 

net stop nom_du_service

net start nom_du_service

Merci pour ton post ! c'est sympa !

Je n'ai pas essayé en mode commande !

J'aurais voulu essayer dans les services mais tout est grisé (le service a été stoppé -par moi- mais l'arrêt ne s'est pas bien déroulé !) car le service n'est ni démarré ni stoppé !

J'ai aussi essayé dans ARCserve mais j'ai reçu un message -après beaucoup de temps correspondant à de multiples essais du système- affichant que le moteur n'avait pas pu être démarré/stoppé !

 

Dans un net stop/start, n'y a t'il pas un ID possible ? :P le nom du service est, de tête, "Moteur de base de données ARCserve"... pas de problème pour le "é" en mode commande ?

Modifié par ipl_001

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Florent, bonsoir à tous,

 

Je te remercie pour ton message ! :P

Normalement il y a un gestionnaire de service arcserve, regarde ce qui se passe en le lancant depuis lui
Dans le gestionnaire ARCserve (il y a un autre gestionnaire dont je ne me souviens plus du nom mais çà revient au même pour mes 3 moteurs), il y a un 3 "voyants" montrant l'état des 3 moteurs Job, Bande et Base de données (correspondant à 3 services - il y en a encore 2 autres "ARCserve Discovery Service" et "Moteur de messages") ; le voyant relatif au moteur de Base de données est gris alors que normalement, il est rouge ou vert !

Oui, j'ai essayé "Démarrer tous les services" (fait automatiquement lorsqu'on lance le programme) mais rien à faire pour modifier l'état de ce moteur de BDD alors que les 2 autres répondent bien ! j'ai aussi essayé "Arrêter tous les moteurs" mais, pas mieux !

Sinon t'as fait un reboot du serveur ?
Non, je n'ai pas fait de reboot du serveur en pleine journée car ce serveur est un serveur de fichiers et beaucoup d'utilisateurs accédaient au serveur... je relancerai ce serveur ce soir à 23 h !
lances le gestionnaire arcserve (celui des sauvegardes) normalement il met en route le service de database.
Oui, j'ai essayé de stopper, de démarrer... ce moteur de base de données reste gris ! ni démarré, ni stoppé et je reçois un message disant que l'opération n'a pas été effectuée !
Si ca bug toujours je crois qu'un tour dans le gestionnaire d'évênement s'impose des fois qu'un composant laisse des erreurs...
Je n'ai pas eu le temps d'étudier le gestionnaire d'événements car j'ai été particulièrement gâté aujourd'hui (bousculé à droite et à gauche par 2 ou 3 gros trucs !).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir à tous,

 

Merci tesgaz, merci Florent... merci pour votre message ! :P

 

Je n'ai pas donné beaucoup de détails dans mon message d'origine :

Normalement, j'ai des sauvegardes la nuit mais là, je ne sais pas encore pourquoi, mon débit a été mauvais et çà s'est prolongé dans la matinée... dans la journée, j'ai des copies (copies des disques durs de portables vers le disque dur du serveur).

 

Normalement, çà se passe bien... aujourd'hui, tout a foiré ! LOL des jours comme çà, mais c'est ce qui fait l'intérêt du métier !

 

Dans l'après midi, une utilisatrice m'appelle pour me dire que le disque de ce serveur est inaccessible !

Je jette un oeil sur le serveur ! tu parles que c'est inaccessible : une sauvegarde en cours (il ne peut y en avoir qu'une à la fois) et 5 copies !!!!! 5 ou 6 processus asrunjob.exe qui prennent toute la CPU et accès disque et bande passante.

Je n'ai pas pris le temps d'analyser le truc, j'ai stoppé ARCserve au plus vite :

- j'ai stoppé les moteurs d'ARCserve -c'est là qu'un n'a pas été correctement arrêté !-

- j'ai stoppé le job de sauvegarde

- j'ai killé 5 processus qui restaient !

 

J'ai récupéré la disponibilité CPU !

 

Problème pour redémarrer ARCserve à cause de ce satané moteur de base de données mal fichu !

 

Je rebooterai le serveur vers 23 h ! j'espère que tout rentrera dans l'ordre ! en attendant, je vais visiter quelques forums ARCserve !

 

Merci pour votre message ! :-(

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité tesgaz
Dans un net stop/start, n'y a t'il pas un ID possible ?  le nom du service est, de tête, "Moteur de base de données ARCserve"... pas de problème pour le "é" en mode commande ?

 

Bonsoir ipl_001,

 

les noms de service employés, sont ceux que l'on nomme "nom interne", dans les services on les retrouve

sur l'onglet de propriété du service

 

quand à l'ID, une fois que le service tourne, tu peux les connaitre avec activeport que tu peux trouver ici :

http://clement.reinier.free.fr/modules.php...op=getit&lid=37

Partager ce message


Lien à poster
Partager sur d’autres sites

Rebonsoir tesgaz,

 

Merci pour ton message et ton lien ! :-(

 

quand à l'ID, une fois que le service tourne, tu peux les connaitre avec activeport que tu peux trouver ici :

http://clement.reinier.free.fr/modules.php...op=getit&lid=37

Ah c'était toi !?!?

LOL

Je fais toujours plusieurs trucs en même temps...

Après avoir lu ton post, je lance l'ouverture de ton lien avec un Mouse Gesture de MyIE2 :-P puis je clique sur un raccourci qui m'ouvre 4 autres fenêtres d'un coup !

Voilà que s'ouvre une fenêtre de téléchargement de aports.zip sur un site www.smartline.ru... j'avais oublié ton lien... quoi ? les Russes qui m'attaquent ? j'ai zappé le truc ! :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir tesgaz, Florent, bonsoir à tous,

 

Je n'ai pas pu donner de nouvelles dans la journée... mon boss ne comprendrait pas que je poste sur Zebulon ! :P pourtant çà devrait être obligatoire pour tous dans l'entreprise ! le soir, avec cette discussion en particulier, je bosse bien pour ma boîte !

 

Bref !

 

Je n'ai donc pas trouvé de commande pour remettre de l'ordre dans un service ni Stopped ni Started mais "Stopping"... tout est néanmoins rentré dans l'ordre en rebootant le serveur (mais je ne pouvais pas faire çà en journée !).

Merci à ceux qui ont suivi mon histoire et qui m'ont encouragé silencieusement !

Bonne soirée à tous !

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×