Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

bloodyxdeath

REcuperation de mdp !

Messages recommandés

Bonjour tout le monde !!

 

Voila j'ai un probleme, je suis etudiant en informatique et j'ai installe Red Hat 9.0 sur mon PC, je ne l'avais pas encore utilisé ds le cadre de mes cours... d'habitude j'utilise toujours le mm mot de passe et login et la je crois que lorsque je l'ai installe j'avais du faire un login et passe "plus complique" mais le probleme c'est que depuis le tps... oui c'est bien ce que vous pensez... j'ai oublié :'(

Je ne suis ni sur de mon login, ni de mon mot de passe, donc j'aimerais savoir si je peux faire quelque chose, ou si je dois reinstaller Red Hat... :/

 

Merci d'avance :P

Partager ce message


Lien à poster
Partager sur d’autres sites

linux single

 

 

Ca se choisit immédiatement dans grub ou lilo, tu passes direct dansdese options pour le kernel puis le reste de la machine.

linux: c'est le nom de l'image que tu veux. TAB pour listing

single: c'est une option

 

Sinon:

Démarre le pc avec une version de knoppix.

Ouvre un shell en root.

Monte la partition du disque dur, (exemple /dev/sda3 )

Edite le fichier etc/passwd, et enlever le "x" juste après le premier ":"

 

Sauve le fichier et redémarre sans la knoppix.

Connecte toi avec un utilisateur classique et puis "su -"

et tu retrouves root.

 

Sinon:

http://lmsoft.free.fr/linux/indexconf.php3?page=cata#ss4.2

Partager ce message


Lien à poster
Partager sur d’autres sites

Le "x" qui figure dans le fichier /etc/passwd signale que le "vrai" mot de passe n'est pas stocké dans le fichier password... Je ne sais pas s'il est suffisant de supprimer juste ce "x" lorsque l'on utilise un outil comme shadow-password (qui stocke les mots de passe avec accès exclusif en lecture pour root dans /etc/shadow (ça évite de laisser les versions cryptées à la vue de n'importe qui, puisque /etc/password est lisible par, justement, n'importe qui))

 

En clair : si tu utilises shadow-password il faut virer le second champ de la ligne "root: etc." de /etc/shadow...

 

Pour plus d'infos : man 5 shadow

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×