Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Y@kuz@

[résolu]problème de ld : -lwx_gtk-2.4

Messages recommandés

Bonsoir à tous et à toutes, une semaine que je galère avec une lib pas trouvée.

 

quand j'essaye de compiler certaines app ,ca me sort souvent ld a pas trouvé -lwx_gtk-2.4

 

donc je suppose qu'il me manque quelque chose mais quoi.

 

en faisant rpm -qa | grep wx

 

wxBase-devel-2.4.2-1

wxGTK-xrc-2.4.2-3.fr

wxPythonGTK-py2.2-2.4.2.4-1

wxGTK-2.4.2-3

wxGTK-devel-2.4.2-3.fr

wxBase-static-2.4.2-1

wxGTK-gl-2.4.2-3.fr

wxGTK-stc-2.4.2-3.fr

wxBase-2.4.2-1

wxPythonGTK-devel-2.4.2.4-1

 

"ma reconnaissance" a celui qui m'indique quel paquetage où tarball contient -lwx_gtk-2.4

 

toutes les recherches google me ménent à des topics similaires au mien, mais ne trouve pas de réponses claires.

 

je rechercherai peut être des libwxGTK.. pour redhat, mais une semaine sans rien trouver :P

 

EDIT [RESOLU] : en vérifaint wx-config avec wx-config --libs, j'obtiens -pthread -lwx_gtk-2.4

 

je configure en rentrant le paramètre : ./configure --with-wx-config=/usr/bin/wx-config

 

() faudra que je me penche sur /etc/ld.so.conf et ces path .

 

redit : c'est wx-config le coupable.

Modifié par Y@kuz@

Partager ce message


Lien à poster
Partager sur d’autres sites

Si une compilation plante sur -ltoto il faut chercher dans quel package tu trouves libtoto.so (ou un libtoto.1.2.3.so ou autre organisation de numéro de version, qui va de toute façon te générer un lien symbolique lors du prochain lancement de ldconfig), ou voir (si tu as installé le package concerné) si le chemin indiqué dans les -L contient bien le répertoire où se trouve cette fameuse librairie libtoto.so ...

 

Apparemment il te manque les librairies des wxWidgets (ex-wxWindows puisque Microsoft a encore mis son nez là-dedans et a fait pression pour changer le nom) version "compilés pour Gnome"...

Partager ce message


Lien à poster
Partager sur d’autres sites

Je te remercie KewlCat d'avoir relancé le topic où j'avais abandonné en ne trouvant aucune solution pour moi,

j'ai donc recherché libwx_gtk-2.4.so.0 sur google et je retombe sur un paquetage que j'ai installé => wxGTK-2.4.2-3 :-(

 

énervé , j'ai réinstallé en forcant wxGTK-2.4.2-3, un petit /sbin/ldconfig et hop j'ai pu compilé :P

 

mauvais paquetage , lien dans le vent, dépendance broken, je sais pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×