Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

naitsirhc

[résolu]Paramétrer un affichage double écran

Messages recommandés

Bonjour à tous,

 

Après deux longues soirées à essayer de résoudre le problème, mais sans succès, je me tourne vers vous.

Je voudrais paramétrer une carte graphique AGP GEForce FX 5200 sous Linux Red Hat 9 de façon à obtenir un affichage Twin View avec 2 écran TFT. J'ai téléchargé et installé le pilote Linux Nvidia.Voici la partie du XF86Config concernée :

 

TwinView

SecondMonitorHorizSync 30-50

SecondMonitorVertRefresh 50-70

Metamodes 1024x768,1024x768;1280x1024,1280x1024

TwinViewOrientation LeftOf

ConnectedMonitor dfp,dfp

 

J'ai ensuite essayé de modifier la section "Screen" en suivant les indication du readme et de l'exemple de XF86Config Nvidia mais là j'ai planté le serveur X .

Tous ce que j'obtiens c'est soit un mode clone 800x600 ou uniquement l'écran principal en 1280x1024. Dans ce dernier cas l'écran secondaire ne se met pas en veille mais reste noir.

Tous les Howto que j'ai pu trouver ne m'aident pas plus.

Comment paramétrer le XF86Config :-(

 

Si quelqu'un a le début d'une idée à me soumettre je l'en remercie par avance :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Je te remercie le "Chat frais", un des liens des topics indiqués m'a mis sur la voie. Ce n'est pas encore complètement solutionné car l'affichage 1280x1024 s'étale sur les 2 écrans, au lieu de 2 fois 1280x1024, mais après tant d'heures de recherches c'est un début de résultat : Mes prochaines soirées vont être occupées... :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Kewlcat, bien vu, "Virtual 2560 1024" fonctionne. Dernier problème à régler : J'ai bien maintenant un bureau virtuel de (1280*1024) x2 mais les deux écrans refusent obstinément d'afficher au dela du 1024*768 (alors que ça marche sous Windows). Résultat j'ai une vue partielle du bureau que je peux déplacer avec la souris. Quelle que soient les modifs apportées au XF86Config, soit ça ne change rien, soit l'xserver ne démarre pas...

Le week-end s'annonce studieux :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca y est, c'est bon : Il fallait augmenter la fréquence horizontale, je l'avais bloquée à 50 Khz au pif car je n'avais pas le manuel et je ne connaissais pas le maxi admissible. :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Volontier, le voici :

 

Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "B17AAH/S"

DisplaySize 340 270

HorizSync 30.0 - 70.0

VertRefresh 50.0 - 70.0

Option "dpms"

EndSection

 

Section "Device"

Identifier "Videocard0"

Driver "nvidia"

VendorName "Videocard vendor"

BoardName "nVidia GeForce 2 Go"

Option "TwinView" "on"

Option "SecondMonitorHorizSync" "30-70"

Option "SecondMonitorVertRefresh" "50-70"

Option "MetaModes" "1280x1024,1280x1024;1024x768,1024x768"

Option "TwinViewOrientation" "LeftOf"

EndSection

 

Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 16

SubSection "Display"

Virtual 2560 1024

Depth 16

Modes "1024x768" "800x600" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1024x768" "800x600" "640x480"

EndSubSection

EndSection

Partager ce message


Lien à poster
Partager sur d’autres sites

Tiens, tu n'es pas en 24/32 bits ? (je vois "DefaultDepth 16" et aucune Subsection "Display" pour "Depth 24" ...)

Tu n'as pas assez de mémoire sur ta carte graphique ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Si j'ai 128 MO, ça devrait aller. C'est une vielle habitude que j'ai gardée de rester en 65 000 couleurs du temps où le 24/32 bits pouvait poser problème. Tu as raison, il serait peut-être temps que je me mette au goût du jour. :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×