Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

bonel

[résolu]xmms sous sid

Messages recommandés

Salut

 

J'ai installé xmms sous debian sid & lorsque je le lance (sous fluxbox) il me met ca

 

18:12 bonel@calvin ~% libesd.so.0: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_modid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

[2]  + exit 127   xmms

 

je ne sais pas encore interpréter les messages d'erreur donc pardonnez mon ignorance!

 

merci

Partager ce message


Lien à poster
Partager sur d’autres sites

fais tu partie du groupe audio?

 

ouep

 

le plugin de sortie de xmms est-il convenablement réglé sur alsa (ou OSS)?

 

j'ai juste installé xmms

& j'ai suivi la formation d'alexis pour ma carte son donc je pense que c'est correct....

Partager ce message


Lien à poster
Partager sur d’autres sites

je n'ai pas modifier le premier paramètre de configuration pour que la compatibilité avec OSS soit effective dès le démarrage d'ALSA :P

 

en woody, je sais que ce fichier est "etc/alsa/alsa-base.conf " mais en sid ce n'est pas le même.... savez vous où il se trouve ?

 

merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites
libesd.so.0: Ne peut ouvrir le fichier d'objet partagé

(...)

libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé

Je parie que ldd `which xmms` te renvoie une belle liste de librairies absentes de ton système...

C'est pas un problème de config audio, c'est un problème de "dépendances"' ...

Un petit coup de ldconfig ?

Partager ce message


Lien à poster
Partager sur d’autres sites
libesd.so.0: Ne peut ouvrir le fichier d'objet partagé

(...)

libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé

Je parie que ldd `which xmms` te renvoie une belle liste de librairies absentes de ton système...

C'est pas un problème de config audio, c'est un problème de "dépendances"' ...

Un petit coup de ldconfig ?

1:17 bonel@calvin ~%  ldd `which xmms`
               libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x4001e000)
       libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40027000)
       libxmms.so.1 => /usr/lib/libxmms.so.1 (0x4003f000)
       libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x4004c000)
       libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x40194000)
       libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x401cc000)
       libgthread-1.2.so.0 => /usr/lib/libgthread-1.2.so.0 (0x401cf000)
       libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x401d2000)
       libpthread.so.0 => /lib/tls/libpthread.so.0 (0x401f4000)
       libdl.so.2 => /lib/tls/libdl.so.2 (0x40203000)
       libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x40206000)
       libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4020e000)
       libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4021c000)
       libm.so.6 => /lib/tls/libm.so.6 (0x402e3000)
       libc.so.6 => /lib/tls/libc.so.6 (0x40307000)
       /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

 

voila ce que m'a donné un " ldd 'which xmms' "

& apres un "ldconfig" j'ai eu ca :

 

1:21 bonel@calvin ~% xmms &
[1] 1695
1:21 bonel@calvin ~% libesd.so.0: Ne peut ouvrir le fichier d'objet partagé: Auc
un fichier ou répertoire de ce type
libmikmod.so.2: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répe
rtoire de ce type
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 72: _dl_next_tls_m
odid: Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

 

:P:-(

 

mais j'ai vraiment oublié de modifier le paramètre de configuration pour que la compatibilité avec OSS soit effective dès le démarrage d'ALSA !! Ca j'en suis sür :-P Et je ne sais pas où se trouve le fichier à configurer dans la Sid..... (/etc/alsa/alsa-base.conf pour la woody !)

 

Merci à vous

Partager ce message


Lien à poster
Partager sur d’autres sites

Quelle horreur... C'est un loader dynamique qui plante quand il ne trouve pas les libraries !! C'te honte ! (alors que c'est justement pour ça qu'on le fait en dynamique, c'est pour le cas où elles seraient absentes...)

 

Passons...

 

Il faudrait que tu situes libmikmod et libesd, que tu ajoutes leur path à la variable d'environnement LD_LIBRARY_PATH et que tu relances le tout (ldconfig éventuellement, et xmms).

Peut-être qu'en utilisant la manière forte il va réussir à les retrouver, ces librairies !

Partager ce message


Lien à poster
Partager sur d’autres sites

bah en fait un ptit coup de google m'a dit que le "/etc/alsa/alsa-base.conf" de la woody était le "/etc/default/alsa" de la sid mais ca ne change rien en y mettant "startosslayer=true" :P

Partager ce message


Lien à poster
Partager sur d’autres sites
Quelle horreur... C'est un loader dynamique qui plante quand il ne trouve pas les libraries !! C'te honte !

waowwaw je sais vraiment pas comment j'ai fait :-(

 

Il faudrait que tu situes libmikmod et libesd, que tu ajoutes leur path à la variable d'environnement LD_LIBRARY_PATH et que tu relances le tout (ldconfig éventuellement, et xmms).

 

je teste direct :-P

Merci pour la rapidité de la réponse :P

Partager ce message


Lien à poster
Partager sur d’autres sites
Quelle horreur... C'est un loader dynamique qui plante quand il ne trouve pas les libraries !! C'te honte !

waowwaw je sais vraiment pas comment j'ai fait :(

Je parlais pas pour toi, mais pour les développeurs de xmms ;-P

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×