Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Zooolooo

Impossible de lancer Activex sous XP

Messages recommandés

Bonjour,

 

Je travaille sur un portable sous XP Ed. Familliale avec tous les correctifs appliqués. Je dispose des droits Administrateur.

J'ai un antivirus à jour ainsi qu'un Firewall (Norton et ZoneAlarm).

 

Depuis qqs jours, plusieurs programmes qui fonctionnaient jusque là sans soucis, ne fonctionnent plus correctement, dont Hoststoggle et le client grenouille. D'autres pourraient suivre... :-P

 

Pour ce qui concerne hoststoggle, il ne se charge plus, générant 2 erreurs pendant le lancement :

- lancé au boot XP, une 1e erreur signale qu'un activex na pu être lancé. Il n'y a pas de code d'erreur et le message disparaît rapidement, effacé par le célèbre message : hoststoggle a rencontré un pb et ne peut démarrer. L'icône apparaît dans le systray et diparaît logiquement dès qu'on la pointe avec la souris :-(

Hoststoggle ne s'installe pas. J'en ai téléchargé une nlle copie (depuis ce site) mais le bug persiste.

 

Grenouille se lance, mais boucle indéfiniment avec des messages comme celui-ci :

Une erreur est survenue dans l'application (Erreur function CalculInterval) Erreur 13 renvoyée : Type incompatible. :-P

J'ai réinstallé le client Grenouille mais ça ne change rien non plus (ici, dans la rubrique ma grenouille).

 

- Ces 2 pgms semblent être écrit en VB.

- D'autre part, j'ai désinstallé la semaine dernière qqs pgms que je ne souhaitais pas conserver après les avoir testé. Je n'en ai malheurusement pas gardé la liste exhaustive. J'ai réinstallé ceux dont je me souvenais : ça y en a rien changer.

 

Pour les 2 raisons ci-dessus, j'ai installé le runtime VB (SP6) quoiqu'il ne soit pas nécessaire de le faire sous XP. J'intuitais qu'un pgm aurait pu se désinstaller comme un malpropre et détruire des modules du runtime VB.

 

Aucun effet constaté, les même bugs se reproduisent de la même façon :P

 

 

J'espère avoir été clair et je remercie par avance ceux et celles qui voudront bien m'aider à résoudre ce #ù@!§ bug. Je suis ien sûr prêt à fournir d'autres infos à la demande à l'exclusion toutefois de mon n° de carte bleue... :-P

 

@++

Partager ce message


Lien à poster
Partager sur d’autres sites

Hoststoggle :

Il ne donne pas le nom de l'activex. On a bien accès à une sorte de dump que Windows voudrait envoyer à Microsoft, mais je n'ai rien (su) trouver d'exploitable dedans.

 

Grenouille :

Sur ce site : Le piaf, j'ai trouvé une info concernant plus particulièrement vsflex7l.ocx

Je l'ai téléchargé depuis DllDump.com mais ça n'a rien changé. J'ai vérifié dans la base des registres s'il était bien enregistré, il semble que oui. Je l'ai d'ailleurs désinscrit et réinscrit, sans que ça change quoi que ce soit. Soyons positifs, ça n'est pas pire... :P

Modifié par Zooolooo

Partager ce message


Lien à poster
Partager sur d’autres sites

Rien d'exploitable selon moi.

Dans "application", on trouve ceci :

Application error

Application défaillante hoststoggle.exe, version 2.1.0.0, module défaillant kernel32.dll, version 5.1.2600.1106, adresse de défaillance 0x00013887.

 

Pour plus d'informations, consultez le centre Aide et support à l'adresse http://go.microsoft.com/fwlink/events.asp.

 

Ca ne nous aide pas vraiment. Ce que je ne sais pas, c comment trouver le nom de l'activex défaillant : càd qui n'est pas trouvé, car je penche pour cette hypothèse.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca y est ! Ca refonctionne ! :P

 

J'ai replacé le "vsflex7l.ocx" que j'avais sauvegardé tout à l'heure avant d'en télécharger un nouveau. Je l'ai "désinscrit" puis "réinscrit" dans la base des reg (Regsvr32).

That's it.

 

Je n'ai pas retesté immédiatement car le tél a sonné, et puis de retour, j'ai lu ton post et consulté le gestionnaire d'évènements. Je ne me souviens pas avoir fais autre chose... Je pense donc que c'est cette opération qui a résolu le pb. Si tu as une autre idée, dis-moi, car j'avais déjà "joué" avec cet ocx, alors ça me paraît tout de même curieux :-(

 

Enfin, je suis rassuré sur la santé de mon PC.

 

Dans tous les cas, je t'adresse un grand merci pour ton aide :-P

 

@+

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×