Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

nick667

[résolu]Java un problème

Messages recommandés

Bonjour,

 

J'ai un petit problème avec java sous ma Sid, j'ai installé le j2re en le téléchargeant depuis le site de sun puis je l'ai installé, mais impossible de m'en servir, quand je clique sur le lien de test, ça me ferme firefox

Et si je lance java à partir de son emplacement :

9:40 nico@Radamanthe ~% /usr/java/j2re1.4.2_04/bin/java
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object
zsh: exit 1     /usr/java/j2re1.4.2_04/bin/java
9:40 nico@Radamanthe ~% 

 

Merci d'avance

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

 

faut mettre ton fichier .class en parametre pour le lancer

 

9:40 nico@Radamanthe ~% /usr/java/j2re1.4.2_04/bin/java ton_fichier.class (sans le ".class")

(c est la reponse no clas defounder qui te le precise)

 

si c est un fichier .jar je crois qu il faut le lancer par

...% /usr/java/j2re1.4.2_04/bin/java -jar ton_fichier.jar

 

 

Pour éviter de taper le chemin du fichier "java"

 

rajoute dans /etc/profile ces 2 lignes avant le umask 022

export PATH=$PATH:/usr/java/j2re1.4.2_04/bin

export JAVA_HOME=/usr/java/j2re1.4.2_04

 

relogue toi et t as plus qu à taper java ton_fichier(.class) ou java -jar ton_fichier.jar

Partager ce message


Lien à poster
Partager sur d’autres sites

si ca peut t'aider, un copier coller d'un de mes topics sur le sujet ...

 

Seul hic au tableau , le java & la FAQ de sun dit des conneries :

 

=> si vous avez gcc 3.2 et > mozilla 1.2x

 

faites des liens symboliques pointant vers vos différents répertoires de plugins avec /usr/java/j2re1.4.2_04/plugin/i386/ns610-gcc32/libjavaplugin_oji.so /!\

 

/usr/lib/netscape/plugins

/usr/lib/mozilla/plugins

/usr/lib/firefox/plugins

/usr/lib/mozilla-1.4.2/plugins

 

bon, su, password ( root)

 

rpm -qa | grep gcc

=>

compat-gcc-c++-7.3-2.96.118

gcc-c++-3.2.2-5

gcc-java-3.2.2-5

compat-gcc-7.3-2.96.118

gcc-gnat-3.2.2-5

gcc-3.2.2-5

libgcc-3.2.2-5

gcc-g77-3.2.2-5

 

oki je fais donc des liens en me placant dans les différents rep citès plus haut :

 

ln -s /usr/java/j2re1.4.2_04/plugin/i386/ns610-gcc32/libjavaplugin_oji.so libjavaplugin_oji.so

 

******************************************************************************

 

je test firefox, oki java marche, mais pas chez mozilla pourtant les conditions requises : gcc 3.2 et moz > 1.2X !!

 

je vires les liens symboliques dans :

 

/usr/lib/netscape/plugins

/usr/lib/mozilla/plugins

/usr/lib/mozilla-1.4.2/plugins

 

et tente du "freestyle" ...

 

ln -s /usr/java/j2re1.4.2_04/plugin/i386/ns610/libjavaplugin_oji.so libjavaplugin_oji.so

Partager ce message


Lien à poster
Partager sur d’autres sites

the tourist>bon j'ai mis java dans mon path mais quand j'essaie de lancer mon appli, même message, failed to initialise VM, j'ai tenté de lancer le .jar comme tu me l'as dit, sans succès.

 

Ykz>J'essaie ça de suite

Partager ce message


Lien à poster
Partager sur d’autres sites

Jette un oeil là : http://plugindoc.mozdev.org/faqs/java.html

 

Est-ce que le plugin que tu utilises est le bon ? (regarde dans about:buildconfig pour savoir avec quel compilo ta version de Firefox a été compilée !)

 

Moi aussi j'avais des fermetures inopinées de Mozilla quand JAVA_HOME était vide ou que le plugin utilisé n'était pas le bon...

 

Et un truc bizarre... quand je lance "java" tout court, j'ai le message d'usage... pas un message d'erreur :

Usage: java [-options] class [args...]
          (to execute a class)
  or  java [-options] -jar jarfile [args...]
          (to execute a jar file
(...)

Est-ce que $JAVA_HOME/bin est dans ton PATH ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×