Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Nyk_o

ClarkConnect

Messages recommandés

Salut,

 

Je viens de monter un firewall avec la dernière version de Clarkconnect.

 

Pour faire fonctionner le serveur ftp "PROFTPD", je dois accèder au shell....

Linux je commence juste, autant dire que je m'y connais quasiment pas, et j'ai l'erreur suivante :

 

SSH SERVER/ALIAS : 192.168.0.254

connected to server running SSH-1.99-OpenSSH_3.5pl

 

192.168.0.254 login : root

Found preinstalled 'known_hosts' file

 

Error connecting to 192.168.0.254, reason:

=> Corrupt public keys file: <ressource>/defaults/know_hosts.txt

 

si quelqu'un peux me guider un peu.. sur les raisons de ce mesage d'erreur !

 

merci

 

++

Nyko

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est assez étrange comme message... Tu utilises quel client ssh ? Tu as bien vérifié ton fichier de clés de "known hosts" ? Tu as vérifié que tu as le droit de te loguer root par ssh sur la machine distante (l'accès root par ssh est parfois désactivé par défaut) ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Tu utilises quel client ssh ? 

D'après ce qui est affiché à l'écran : SSH-1.99-OpenSSH_3.5pl

 

Tu as bien vérifié ton fichier de clés de "known hosts" ?

J'arrive à accéder aux répertoires du firewall en passant par WINCSP, mais je n'ai pas encore trouvé ce fichier

 

Tu as vérifié que tu as le droit de te loguer root par ssh sur la machine distante

J'essaierai de créer un autre utilisateur et de me loguer avec, je sais pas si le root à le droit par defaut d'accéder au ssh

 

merci

 

++

Nyko

Partager ce message


Lien à poster
Partager sur d’autres sites
SSH-1.99-OpenSSH_3.5pl

 

ça c'est la bannière du serveur. Tu te connectes à partir de quel poste (Win, linux?) avec quel client SSH (putty?)

 

le fichier known hosts devrait se trouver côté client.

Quand on se connecte la première fois sur un serveur SSH, on peut rajouter sa clé publique RSA dans le fichier known hosts afin de pouvoir profiter de l'authentification par clés publiques/clés privées. Cela se fait interactivement sous forme de question o/n.

 

WinSCP n'est pas un client SSH en tant que tel puisqu'il ne permet de faire que du SFTP (SecureFTP) et du SCP (SecureCopy) dans un tunnel SSH => on n'a pas accès au shell.

 

Essaie avec putty ou via cygwin (putty est plus simple si tu ne veux qu'un client SSH)

Partager ce message


Lien à poster
Partager sur d’autres sites
ça c'est la bannière du serveur. Tu te connectes à partir de quel poste (Win, linux?) avec quel client SSH (putty?)

En fait j'attaque mon firewall à partir du naviguateur sur un poste W2k, et de la j'ai une option "ligne de commande" mais je sais pas du tout quel client y est intégré.

 

 

G installé PUTTY, j'arrive à me connecter avec... c déjà un début :-(

J'ai toujours pas trouver dans quel repertoire se trouve ce fichier known_hosts mias je vais fouiller...

 

merci ca m'aide déjà pour commencer... mias c pas franchement évident ce système :P

 

++

Nyko

Partager ce message


Lien à poster
Partager sur d’autres sites

Perso, la seule fois où j'ai une invite de ce type, c'est quand j'essaie de me connecter avec un client telnet...

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
SSH-1.99-OpenSSH_3.7.1p2

Tu es sûr que l'option "ligne de commande" te donne un accès SSH et pas un bête telnet ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Tu es sûr que l'option "ligne de commande" te donne un accès SSH et pas un bête telnet ?

 

Ca fait que quelque jours que je me suis lancé la dedans, j'peux difficilement répondre, , mais près de l'option "ligne de commande " c'est marqué SSH, donc je pense que OUI :P

 

Etant donné qu'avec PUTTY ca fonctionne, je vais utiliser ca pour le moment et attendant de mieux comprendre.....

 

 

++

Nyko

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon... C'est bizarre en tout cas... (ou alors c'est du SSH1 et tu forces l'utilisation du SSH2 sur le serveur...)

 

A propos des options dont j'ai parlé, bloquer l'accès root se fait en mettant "PermitRootLogin no" dans /etc/ssh/sshd_config, et le paramétrage de la version du protocole passe par le paramètre "Protocol 2,1" (qui permet, ici, de se loguer par SSH2 ou par SSH1) dans le même fichier...

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...