Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Firewall et antivirus


Messages recommandés

Comme le titre l'indique, j'aimerais savoir quels soft utiliser pour sécuriser un mandrake.

(ouais je sais, j'aurais pu faire une recherche avant de poster mais pour tout vous dire, j'ai eu la flème) :P

Merci d'avance pour vos réponses.

+++

Lien à poster
Partager sur d’autres sites

Salut NIKOSIX

 

pour sécuriser un mandrake

Comme Linux est déjà bien plus sécuritaire que Windows, moins de trucs doivent être réglés pour s'assurer que tout fonctionne. Cependant, comme sous toute bonne distribution, on retrouve un firewall (celui de la Mandrake étant performant en plus!).

 

Tout ce que tu as à faire pour le paramétrer, c'est te rendre dans le menu dans Système > Configuration > Configurez votre ordinateur, entrer le mot de passe du super-utilisateur à l'invite qui s'affiche ensuite, cliquer sur Sécurité, Pare-feu puis cocher ce que tu désires bloquer. En cliquant sur le bouton Avancé, tu pourras également ajouter seulement les ports de ton choix ce qui est bien pratique pour bloquer exactement ce que tu veux :-(.

 

Par la suite, comme sur tous les systèmes, tu peux gérer les services qui se lancent au démarrage de l'ordinateur (dont certains peuvent t'être inutiles et, qui sait, dangereux). Pour cela, c'est dans l'onglet Système au tout début, puis dans Services. Là, tu peux afficher des informations sur chaque service si tu n'es pas certain de l'utilité de chacun.

 

Après, de retour dans l'onglet Sécurité, tu peux jeter un oeil dans Niveau et vérifications pour voir avec quel niveau de sécurité tu es protégé, voir les options du réseau, du système et les vérifications quotidiennes qui sont faites. Par défaut, tu devrais être sur le niveau Standard, mais rien ne t'empêche d'augmenter celui-ci si tu veux faire du partage FTP ou encore un Serveur Web par exemple.

 

Une autre façon de sécuriser davantage, c'est de regarder ce que tes utilisateurs ont le droit de faire dans Système au début et sur Utilisateurs et groupes. En double-cliquant sur le nom de l'utilisateur souhaité, tu peux changer ses propriétés et modifier son appartenance à certains groupes (pour lui restreindre des commandes, entre autres).

 

Par après, si tu te sens courageux, tu peux éditer les règles de sécurité (dans l'interface graphique quand même!) sans passer par IPTABLES en ligne de commandes toujours dans le centre de contrôle dans Sécurité > Permissions.

 

En ce qui concerne les antivirus, je n'en vois pas encore l'utilité, mais certains les utilisent pour tester et n'arrivent toujours pas à attraper de salopperies :P.

 

Pourquoi?

 

Linux est bien pensé :-P. Seul l'utilisateur root peut réellement causer des dommages à l'ensemble de l'ordinateur (bien que ce soit encore difficile...). En gros, si tu restes simple utilisateur avec des droits beaucoup plus sévères que root, il ne t'arrivera rien. Si vraiment tu crains le pire, sauvegarde tes données quand tu le veux et tu seras épargné de tous dangers. La pire chose qui aurait pu t'arriver (vraiment la pire), c'est de perdre les docs et infos de ton répertoire personnel (mais il faut être drôlement futé). Donc, si tu veux, tu enregistres tes trucs avec K3B par exemple et tu es libre!

 

Si jamais tu as d'autres questions sur quoi que ce soit, n'hésite pas! Je ne suis pas expert, loin de là, mais d'autres sauront aussi t'aider :-P.

 

Bonne journée et à bientôt!

Modifié par ssssseb
Lien à poster
Partager sur d’autres sites

Bonjour

 

TA REPONSE

Tout ce que tu as à faire pour le paramétrer, c'est te rendre dans le menu dans Système > Configuration > Configurez votre ordinateur, entrer le mot de passe du super-utilisateur à l'invite qui s'affiche ensuite, cliquer sur Sécurité, Pare-feu puis cocher ce que tu désires bloquer. En cliquant sur le bouton Avancé, tu pourras également ajouter seulement les ports de ton choix ce qui est bien pratique pour bloquer exactement ce que tu veux :P.

Si jamais tu as d'autres questions sur quoi que ce soit, n'hésite pas! Je ne suis pas expert, loin de là, mais d'autres sauront aussi t'aider :-(.

 

MA QUESTION

Suite au message j'ai aussi pb réglage firewall linux

 

tes indications indiquent que il faut cocher ce que l'on désire bloquer alors que je vois pour ma part affiché "quels services désirez vous laisser accessible depuis internet ," donc ne pas bloquer. enfin pour moi je suis obligé de laisser cocher tout (pas de firewall) sinon rien ne marche !

 

Pour Drakfirewall: C'est ok pour internet et mail si je coche "tout pas de firewall". J'arrive a me connecter par modem usrobotics sur port /dev/ttysO (port série) et fai free-telecom bas débit free j'ai 1 seul micro de bureau pas de partage avec autres micros.

par contre je n'arrive pas a configurer le firewall de mandrake que faut-il cocher déccocher car j'ai essaye de déccocher "tout pas de firewall" mais plus rien ne marche ?

 

Faut'il faire autre chose dans autre menu de Système > Configuration > Configurez votre ordinateur ?

 

N'ayant pas trouvé de doc à ce sujet dans les forums

merci

Lien à poster
Partager sur d’autres sites

Resalut sub13

 

par contre je n'arrive pas a configurer le firewall de mandrake que faut-il cocher déccocher car j'ai essaye de déccocher "tout pas de firewall" mais plus rien ne marche ?

En fait, ça dépend des services que tu utilises, mais c'est sûr que si tu bloques Serveur Web par exemple, tu risques d'avoir des difficultés à te connecter sur le Web :P. Le mieux c'est de bloquer exactement ce qu'il faut (ou approximativement). Pour cela, je te laisse le soin de jeter un regard --> ici <--.

 

Tu y trouveras une bonne liste de ports à autoriser pour telle ou telle application, à toi de voir. Personnellement, je ne perds plus de temps pour la configuration en ce moment étant donné que la version 10.1 Official sortira certainement ce mois-ci en version téléchargeable, mais, pour te laisser savoir, J'ai décoché la première case et coché toutes les suivantes pour pouvoir ajouter en temps et lieu des ports qui seraient importants (par exemple, TCP 6891 - 6900... TCP 1863... UDP 1863... UDP 5190... UDP 6901 et TCP 6901 pour le transfert de fichiers sur MSN Messenger ou, dans ce cas-ci, aMSN).

 

Je ne suis bien sûr pas très doué (je débute sur Mandrake), mais je crois que ceci peut aussi t'aider. Il s'agit en fait d'une liste de ports à interdire car ce sont ceux utilisés pour les trojans. Évidemment, si tu souhaites conserver ta connexion Internet active pour naviguer, il serait mieux de ne pas tout enlever (le port 80 entre autres :-().

 

Néanmoins, si tu veux aller encore plus loin, des générateurs de codes pour IPTABLES existent et, bien qu'ils soient complexes et plutôt longs à mettre en oeuvre, tu pourras grâce à eux gérer absolument tous tes ports! En voici un exemple.

 

Comme dit précédemment, rien n'est encore alarmant si tu ne bloques pas complètement tout, l'important étant que tu aies au minimum coché les cases du bas (donc toutes sauf celle intitulée Tout (pas de firewall)) et fait les mises à jour via RPMDrake (après avoir mises à jour les sources elles-mêmes avec l'utilitaire intégré!).

 

Voilà! J'ai mis un peu de temps à répondre (décalage horaire) et ai dû raccourcir les justifications car de nombreux travaux scolaires m'attendent malheureusement...

 

Bonne journée à toi et reposte d'autres questions si je n'ai pu être assez explicite!

Modifié par ssssseb
Lien à poster
Partager sur d’autres sites

Pour le mail et le web (en tant que client) pas besoin d'accepter le 80 en entrée.

 

Pour ma part, l'interface graphique de config du firewall est, je trouve, mal fichue.

 

un script simple reviendrait à celui-ci:

#initialisation des règles
iptables -F
iptable -X

#Définition des politiques par défaut
iptables -P INPUT DROP
iptables -P OUTPUT ACCEPT
iptables -P FORWARD DROP

#On accepte la boucle locale
iptables -A INPUT -i lo -j ACCEPT

#On accepte les connexions établies sur l'interface ppp0 (à modifier au besoin)
iptables -A INPUT -i ppp0 -m state --state RELATED,ESTABLISHED -j ACCEPT

 

avec ça tout fonctionne, tout tes ports sont masqués.

 

Il est toujours possible de raffiner OUTPUT en plaçant la politique par défaut à DROP et en autorisant explicitement ce que l'on souhaite laisser sortir.

 

FORWARD est à DROP, ceci implique que le code n'est pas fait pour une passerelle internet.

Lien à poster
Partager sur d’autres sites

Resalut!

 

Merci Greywolf pour le script :-(. Étant donné que je suis à mes tous débuts, ça me sera très utile puisque je suis loin d'avoir tout pigé (y compris comme vous le voyez en matière de sécurité).

 

Seulement, est-ce possible qu'il y est une petite faute de frappe?

 

#initialisation des règles

iptables -F

iptable -X

Enfin bon ce n'est rien :P.

 

Merci encore!

Lien à poster
Partager sur d’autres sites

Comme dit précédemment, rien n'est encore alarmant si tu ne bloques pas complètement tout, l'important étant que tu aies au minimum coché les cases du bas (donc toutes sauf celle intitulée Tout (pas de firewall)) et fait les mises à jour via RPMDrake (après avoir mises à jour les sources elles-mêmes avec l'utilitaire intégré!).

 

Voilà! J'ai mis un peu de temps à répondre (décalage horaire) et ai dû raccourcir les justifications car de nombreux travaux scolaires m'attendent malheureusement...

 

Bonne journée à toi et reposte d'autres questions si je n'ai pu être assez explicite!

419408[/snapback]

 

Merci pour vos réponses mais,

 

J'ai essayé mais je ne comprend pas

1/ en cochant toutes les cases sauf Tout (pas de firewall)

 

2/ en décochant que Tout (pas de firewall) et les autres cases.

 

mais dans les deux cas plus rien ne marche , j'arrive en fait à me connecter que quand Tout (pas de firewall) est coché !

 

Aurais-je oublié quelque chose port dans options avancées ou services ?

 

Pour info ma connexion web est lancée par KPPP sur port MODEM /dev/ttyS0 (port série 1)

 

merci

Lien à poster
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...