Aller au contenu
N|e|o

DD Maxtor 160 GO en PIO au lieu de DMA

Messages recommandés

Bonjour à tous,

 

Je viens d'acheter un disque Maxtor 160 Go ATA.

 

Je l'ai installé en maître (ancien DD en esclave), j'ai formaté et installé WINWOS XP PRO.

 

Le PC est super lent. (NB: Celeron 1Ghz, carte mère M754+ chipset GFXPRO)

 

J'ai vérifié dans le canal IDE principal le DD et mis en PIO mode (nb: le mode DMA si disponible est activé) tandis que le disque en slave est en UDMA-4

 

Après quelque recherche sur le net ...

 

Je désinstalle le driver du canal IDE principal, je reboote, rien de changer

 

Je change de nappe, rien de changer

 

J'ai mis l'ancien disque en maitre et le nouveau en esclave, j'ai reformaté, rien de changer

 

L'ancien est tjs en UDMA-4 et le nouveau en PIO

 

J'ai testé le disque dur sur un autre PC et il est bien reconnu en UDMA

 

Je l'ai réinstallé sur la bécane tjs en escalve.

 

J'ai vérifié au lancement le BIOS m'indique que les 2 disques sont bien UDMA

 

NB: les drivers fournis avec la carte ne sont pas compatible XP et ce sont les drivers de xp qui sont installé.

 

J'ai donc décidé d'aller modifier la base de registre.

 

dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

{4D36E96A-E325-11CE-BFC1- 08002BE10318}\0002

J'ai supprimer simplement les clés MasterIdDataCheckSum et SlaveIdDataCheckSum

du canal IDE correspondant, puis redémarrez le PC. (astuce trouvée sur ne net)

 

Le pc redémarre, aucun changement, le dd est tjs en pio, je vérifie la base de registre est les 2 clés que j'ai effacées sont réapparue comme par miracle.

 

J'ai ensuite esssayer les modifications suivantes tjs dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

{4D36E96A-E325-11CE-BFC1- 08002BE10318}\0002

 

J'ai changé la clé "SlaveDeviceTimingModeAllowed" en "ffffffff" en hexa

et le "SlaveDeviceTimingMode" en "8010" en hexa.

 

En fait j'ai simplement donné les memes valeurs que le disque maitre qui lui est détecté en UDM-4.

 

Après ces modifications, je vérifie dans le gestionnaire de périphérique.

 

Le disque en bien passé en UDM-4.

 

Je reboote, le pc redémarre et le disque revient en PIo :P((

 

Vérification dans la base de registre, les valeurs de "SlaveDeviceTimingModeAllowed" et de "SlaveDeviceTimingMode" n'ont pas été conservée.

 

Voilà c un peu long, mais au moins vous savez ce que j'ai déja essayer.

 

Si quelqu'un peut me dépanner

 

Merci d'avance.

Partager ce message


Lien à poster
Partager sur d’autres sites

bonjour dans le registre tu as ensuite esssayer les modifications suivantes tjs dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

{4D36E96A-E325-11CE-BFC1- 08002BE10318}\0002

 

tu as changé la clé "SlaveDeviceTimingModeAllowed" en "ffffffff" en hexa

et le "SlaveDeviceTimingMode" en "8010" en hexa. donc tu dis que cette modif a fonctionnée donc avant de sortir du registre juste après avoir effectué l'astuce ci dessus,tu vas dans l'onglet affichage et tu fais actualiser et tu reboot. cela devrai fonctionner je pense.tiens nous au courant.

Partager ce message


Lien à poster
Partager sur d’autres sites

salut

euh je crois qu'il y a possibilité sur certaines carte mere, dans le bios, de switcher les disque dur en mode Pio comme UDMA, donc a verifier dans le bios si il n'est pas sur Pio au lieu de DMA

Modifié par PyReX

Partager ce message


Lien à poster
Partager sur d’autres sites

La nappe est bien une 80 fils

 

Au niveau du bios, les 2 disques durs sont configurés de la meme facon.

Au lancement, le bios me signale qu'il sont bien des Ultra-DMA 4, c'est uniquement au niveau de windows qu'un des DD est en PIO

 

 

Pour la base de registre le bouton actualiser ca ne fonctinne pas

 

Apparement les valeurs

 

"SlaveDeviceTimingModeAllowed" et "SlaveDeviceTimingMode"

 

sont réinitialiser a chaque boot du PC.

 

Dans les gestinnaires de périphériques, les canaux IDE sont mis en "auto-detection" et il n'y a pas moyen de les changer.

 

Si quelqu'un connait la méthode pour empécher cette mise a jour, je suis preneur

 

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

même s"ils sont mis ne auto-détection la ligne du dessous est modifiable et comporte "PIO seulement" ou "DMA si applicable" ces options sont ne quoi chez toi ?

 

Sinon connais tu ton chipset de carte mère, peut être qu'il existe une MAJ dans un coin qui réglerai ça..

Partager ce message


Lien à poster
Partager sur d’autres sites
même s"ils sont mis ne auto-détection la ligne du dessous est modifiable et comporte "PIO seulement" ou "DMA si applicable" ces options sont ne quoi chez toi ?

 

Sinon connais tu ton chipset de carte mère, peut être qu'il existe une MAJ dans un coin qui réglerai ça..

439691[/snapback]

 

 

Le canal IDE est bien configuré en IDE si applicable

 

Le chipset c'est un GFPRO M754+ de chez ALI

 

Je n'ai malheureusement pas trouvé de mise à jour des driver.

 

Le plus bizarre c'est que l'autre disque dur est bien configuré ainsi que les graveurs sur l'ide secondaire

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×