Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[résolu]Comment installer une sound blaster 16 ?


256JMAN
 Share

Messages recommandés

Salut !

 

J'arrive pas a installer ma SB16 avec FC4 :-P

Et j'avoue que je suis un peu perdu dans FC4, pas de sndconfig, pas de alsaconf ... pas de gestionnaire de péripherique :-(

J'ai trouvé la commande pour voire les peripherique ( lspci ) mais je ne voie pas ma carte son

J'ai installé sndconfig et voici le message d'erreur que j'obtient :

ERREUR : modules son non trouvés

 

Vous ne semblez pas utiliser un noyau avec prise en charge des sons modulaires (soundcore.o n'a pas été trouvé dans le chemin de recherche des modules). Pour pouvoir utiliser sndconfig, vous devez utiliser un noyau avec prise en charge des sons modulaires par exemple, le noyau fourni avec Red Hat Linux ou un noyau 2.2 (ou une version supérieure).

 

j'ai essayé de trouvé un paquet qui contenait soundcore.o) sans sucset (petite precision : le rpm de sndconfig est pour red hat, mais je pense pas que ca doit gener)

 

hum je sais plus trop ou chercher :P

 

HELP ME !!!!! :P

Lien vers le commentaire
Partager sur d’autres sites

soundcore.o est un module kernel (v 2.4 plus précisément)

si la gestion du son est compilé en dur dans le système, tu n'auras pas de modules (vu qu'il est en dur)

 

Linux possède deux systèmes de sons OSS et Alsa; que l'on peut choisir en compilant son noyau (les noyaux récents privilégient plutôt alsa)

 

regarde les différents modules sons que tu possèdes:

find /lib/modules/`uname -r`/ -name "snd*"

 

c'est une carte PCI ou ISA ta SB16?

car le module SND_SB16 existe mais pour une carte isa

 

le cas échéant as tu installé les isapnptools?

Lien vers le commentaire
Partager sur d’autres sites

regarde les différents modules sons que tu possèdes:

find /lib/modules/`uname -r`/ -name "snd*"

536845[/snapback]

 

bon, voila ce que je trouve mais je sais pas trop quoi en faire :P

 

c'est une carte PCI ou ISA ta SB16?

C'est une pci, j'ai oublié de preciser :P

Lien vers le commentaire
Partager sur d’autres sites

bon après qq recherches la SB16 PCI serait gérée par le module alsa snd-ens1371.ko qui est compilé dans ton noyau.

 

peux-tu nous donner les sorties de

lspci -v

lsmod

 

tu as installé alsa-utils?

Lien vers le commentaire
Partager sur d’autres sites

00:09.0 Multimedia audio controller: Ariel Corporation: Unknown device 5880 (rev

02)

        !!! Invalid class 0401 for header type 01

        Flags: bus master, fast devsel, latency 0

        Memory at 58801230 (32-bit, non-prefetchable) [disabled]

        Memory at <invalid-64bit-slot> (64-bit, non-prefetchable) [disabled]

        Bus: primary=12, secondary=00, subordinate=01, sec-latency=4

        !!! Unknown I/O range types 16/0

        Memory behind bridge: 00000000-000fffff

        !!! Unknown prefetchable memory range types 4/0

        Expansion ROM at <unassigned> [disabled]

 

le problème semble en effet venir de là... le système reconnait mal ta carte :P

 

tu as essayé de mettre à jour ta base de PCI ID? (update-pciids)

la carte est bien enfichée?

tu as la possibilité d'essayer sur un autre port PCI?

Lien vers le commentaire
Partager sur d’autres sites

j'ai essayé "update-pciids" mais il ne connait pas la commande

j'essai de changer la cazrte de port demain, je te tient au courant ....

Lien vers le commentaire
Partager sur d’autres sites

tu as la possibilité d'essayer sur un autre port PCI?

537493[/snapback]

00:0d.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)

        Subsystem: Ensoniq Sound Blaster 16PCI 4.1ch

        Flags: bus master, slow devsel, latency 64, IRQ 4

        I/O ports at b000

        Capabilities: [dc] Power Management version 1

 

:-P

 

ca marche !!!

je me demande si ce n'etait pas un conflit entre la carte tv et la carte son :P de toute facon je ne pense pas remettre la tv sur ce pc (trop peu puissant)

 

merci Greywolf :P

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
×
×
  • Créer...