Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Chris256

[résolu]Probleme noyau avec l'heure systeme

Messages recommandés

Bonjour a tous ,

 

Je rencontre un problème un peu particulier , J'ai installé il y a quelques jours un nouveau noyau pour ma distribution ( une mandriva cooker 64 ) , c'est le 2.6.12-8 , j'utilisai jusqu'a present un 2.6.11-10 .

 

Lorsque je boote sur le nouveau noyaux , voila ce qui m'arrive :

 

Imaginons que je demarre l'ordinateur aujourd'hui a 14h .

 

Une fois arrivé sous ma distribution , je vais avoir 16h d'afficher sur le bureau ( c'est toujours 2 heure pile en + de l'heure normale ) .

 

"date" en console me donnera 16 heure egalement , par contre "hwclock --show" me donnera bien 14 heures .

 

Si je reboote l'ordinateur sans rien toucher entre temps ça continu , je vais avoir 18 heure sur le bureau et l'heure du bios( hwclock --show ) va avoir 2 heure de moins soit 16 heure ; et ainsi de suite de 2 heure en 2 heure .

 

 

Si je modifie l'heure une fois demarré , hwclock et le bureau me donne la meme heure et une fois redemarré ça recommence .

 

Si je boote sur l'ancien noyau , je n'ai pas le problème ...

 

Si vous avez une idée sur la cause , je suis preneur :P

Pourrais je au moins interdire au systeme de modifier l'heure du bios ? ( vu que ça me detraque egalement l'heure sur ma version stable )

 

Note : Sur la mailing list cooker , je suis apparement le seul a avoir ce problème d'heure avec ce noyau .

 

Note 2 : c'est un noyau precompilé fait pour ma distribution

Partager ce message


Lien à poster
Partager sur d’autres sites

Je crois que Tourangeaux a eu exactement le même problème.

 

Ton nouveau noyau doit certainement être compilé avec l'option CONFIG_APM_RTC_IS_GMT ("RTC stores time in GMT"), alors que l'ancien ne l'était pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir kewlcat ,

 

Je viens de regarder dans mon fichier '.config' qui se trouve dans le paquetage source de mon nouveau noyau ( je l'avais egalement installé pour le driver nvidia ) et je ne trouve pas trace de l'option : CONFIG_APM_RTC_IS_GMT , idem pour '/boot/config-2.6.12-8mdk' qui est une copie de '.config' .Dans le fichier config de l'ancien noyau pareil .

 

merci pour ton aide :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Euh... J'ai regardé dans les sources d'un noyau 2.4 donc peut-être que le nom de l'option a changé (bon, ok, peut-être pas...)

As-tu envoyé un MP à Tourangeaux pour lui poser la question ?

Partager ce message


Lien à poster
Partager sur d’autres sites

l'option existe dans les noyaux 2.6 mais uniquement si l'APM est activé (avec l'ACPI ce genre d'options n'existe apparemment pas)

 

tu as un lien /etc/localtime ? vers quoi pointe-t-il?

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour greywolf ,

 

tu as un lien /etc/localtime ? vers quoi pointe-t-il?

 

J'ai un fichier '/etc/localtime' mais ce n'est pas un lien , j'ai fait un 'cat' dessus il n'y a que la derniere ligne qui soit compréhensible :

 

PMTWESTWETCETCESTWEMT

 

Voici d'autres fichiers de config que j'ai trouvé en rapport avec l'heure :

 

[chris@localhost ~]$ cat /etc/sysconfig/clock

UTC=false

ARC=false

ZONE=Europe/Paris

[chris@localhost ~]$

 

----------------------------------------------------------------------

 

chris@localhost ~]$ cat /etc/adjtime

4.616967 1123196223 0.000000

1123196223

LOCAL

[chris@localhost ~]$

 

D'apres ce que j'ai trouvé ce fichier sert a noté le decalage de temps entre l'horloge materielle et celle système

------------------------------------------------------

 

J'éditerai peut etre mon message si je trouves autre chose .

 

--------------------------------------------------------

edit 7/8/05 12 h

 

Pour l'instant j'ai pu bloquer le dereglement de l'heure du bios , ce n'est pas une resolution du probleme , juste un reglage d'attente .

 

Voici la nouvelle config d'un des fichiers que j'ai precité plus haut :

 

[chris@localhost ~]$ cat /etc/sysconfig/clock

UTC=true

ARC=false

ZONE=UTC

[chris@localhost ~]$

 

Adieux le fuseaux horaire :P

 

--------------------------------------------------------------------

Si je trouve la solution je la rajouteraie ( l'espoir fait vivre )

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut, j' ai eu ce blem sous Ubuntu 5.04

 

ça doit être UTC le blem

 

j' avais trouvé la solution grace au guide ici:

http://fr.ubuntuguide.org/#disablesystemtimedateutc

 

Sous Debian sarge il demande si je me souvient bien, et recommande de ne pas l' activer si ont a plusieur system ( si je me rappelle bien )

 

vi /etc/default/rcS

# Chercher cette ligne

...
UTC=yes
...

# Remplacer avec la ligne suivante

UTC=no

 

Chris256  Écrit le jeudi 04 août 2005 à 23h57

 

Non , je pensais qu'il remarquerai peut etre le post , je vais le faire

 

J' ai moins de temps a disposer maintenant que je suis Papa.....

mais les biberons s' espace de plus en plus

c' est un garçon

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut ,

 

Sous Debian sarge il demande si je me souvient bien, et recommande de ne pas l' activer si ont a plusieur system ( si je me rappelle bien )

 

Je n'ai que mandriva sur mon pc , ma cooker + une stable

 

 

/etc/default/rcS

 

Ce fichier n'existe pas sur ma distri , ils ne doivent pas placer les fichiers de configuration au meme endroit . ( a moins que ça corresponde a mon "/etc/sysconfig/clock" cité + haut ... et si c'est le cas ce n'est pas ça vu que j'ai essayé un peu toutes les options sans succés )

Quoiqu'il soit je vais continuer de chercher .

 

Merci de m'avoir consacrer un peu de ton temps et félicitation pour ton petit garçon :P

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×