Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Chris256

Problème réseaux

Messages recommandés

Bonjour a tous ,

 

Voici le problème , je joue de temps en temps a un jeu en reseaux ( enemy territory )

 

Lorsque je lance le jeux , la liste des serveurs dispo défile , jusque la normal :P .

Depuis que j'ai changé de modem ( DSL-300T dlink a la place d'un sagem fast 800 ) l'affichage de la liste " sature " , ça s' affiche beaucoup moins rapidement .

 

Si je sors du jeu à ce moment et que je lance un ping ou tout simplement le navigateur , je n'ai pas de connexion , si j'attends un moment tout reviens dans l'ordre . J'ai cherché dans les "logs" des messages d'erreurs voici ce que j'ai trouvé .

 

 

Tout d'abord ce que me dis le jeu lorsque je le lance a partir d'un console :

 

NET_SendPacket ERROR: No buffer space available to 217.172.177.236:25000

NET_SendPacket ERROR: No buffer space available to 65.75.157.150:27960

NET_SendPacket ERROR: No buffer space available to 85.131.138.40:27960

NET_SendPacket ERROR: No buffer space available to 193.222.62.135:27852

NET_SendPacket ERROR: No buffer space available to 84.254.69.69:28980

NET_SendPacket ERROR: No buffer space available to 85.92.133.145:27970

NET_SendPacket ERROR: No buffer space available to 217.172.184.103:27962

NET_SendPacket ERROR: No buffer space available to 155.92.103.31:27960

*****************

 

 

ce que me donne un ping :

 

[chris@localhost ~]$ ping -c 5 www.zebulon.fr

connect: No buffer space available

[chris@localhost ~]$

 

ce que me donne un "dmesg" :

 

OS=0x00 PREC=0x00 TTL=56 ID=63478 DF PROTO=UDP SPT=27960 DPT=27960 LEN=290

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=80.69.73.16 DST=80.170.63.7 LEN=310 T

OS=0x00 PREC=0x00 TTL=56 ID=10373 DF PROTO=UDP SPT=27963 DPT=27960 LEN=290

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=80.69.73.16 DST=80.170.63.7 LEN=309 T

OS=0x00 PREC=0x00 TTL=56 ID=41230 DF PROTO=UDP SPT=27966 DPT=27960 LEN=289

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=80.69.73.16 DST=80.170.63.7 LEN=307 T

OS=0x00 PREC=0x00 TTL=56 ID=27446 DF PROTO=UDP SPT=27962 DPT=27960 LEN=287

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Neighbour table overflow.

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=80.69.73.16 DST=80.170.63.7 LEN=309 T

OS=0x00 PREC=0x00 TTL=56 ID=15008 DF PROTO=UDP SPT=27969 DPT=27960 LEN=289

printk: 84 messages suppressed.

Neighbour table overflow.

printk: 91 messages suppressed.

Neighbour table overflow.

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=195.132.190.10 DST=80.170.63.7 LEN=48

TOS=0x00 PREC=0x00 TTL=115 ID=48651 DF PROTO=TCP SPT=3202 DPT=6346 WINDOW=65535 RES=0x00 SYN URGP=0

Shorewall:net2all:DROP:IN=eth1 OUT= MAC=00:0f:ea:85:75:91:00:11:95:de:b5:da:08:00 SRC=59.190.11.160 DST=80.170.63.7 LEN=351

TOS=0x00 PREC=0x00 TTL=44 ID=0 DF PROTO=UDP SPT=27962 DPT=27960 LEN=331

printk: 92 messages suppressed.

Neighbour table overflow.

 

 

un

cat /proc/net/arp

me donne une liste impressionante d'adresse ip

 

 

Ma configuration :

 

O.S: Mandriva 2006

modem : DSL-300T D-link en RJ45

Mon ordi est tout seul , je n'ai pas de reseaux .il est configurer en client DHCP

Si je ne lance pas le jeu , je n'ai aucun problème de connexion.

 

Ce n'est pas en soit un problème tres genant , mais j'aimerai tout de meme comprendre ce qu'il se passe :P

 

Edit :

 

je rajoute ceci :

 

[chris@localhost ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1

BOOTPROTO=dhcp

IPADDR=213.103.193.91

NETMASK=255.255.255.255

NETWORK=213.103.193.91

BROADCAST=213.103.193.91

ONBOOT=no

MII_NOT_SUPPORTED=no

USERCTL=yes

IPV6INIT=no

IPV6TO4INIT=no

PEERDNS=yes

NETMASK=255.255.255.255

IPADDR=213.103.193.91

DHCP_CLIENT=dhclient

NEEDHOSTNAME=no

PEERDNS=yes

PEERYP=no

PEERNTPD=no

[chris@localhost ~]$

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai regardé rapidement la cause de ce message et ce serait lié à une saturation du cache arp.

Normalement arp n'est utilisé que dans les les sous-réseaux et dans le cas du WAN, cela ne devrait pas être utilisé (ou très peu, juste pour retrouver l'adresse IP de ta passerelle). J'ai l'impression que ton PC essaie de contacter le monde entier via des requêtes ARP (alors que ce n'est pas son rôle)

 

problème de configuration réseau?

quelle est cette adresse 213.103.193.91 donnée à eth1?

Cette interface est configurée en DHCP mais avec une adresse IP fixe avec un masque /32 :P

ton fichier ifcfg-eth1 est bizarre mais ne connaissant pas mandriva, je laisse à d'autres le soin de l'analyser

 

problème lié à iptables? si tu flushes les règles iptables, cela donne quoi?

iptables -F; iptables -X

 

peux tu nous poster le résultat de

ifconfig
route -n

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour greywolf ,

 

Tout d'abord je te remercie de te pencher sur mon problème :P

 

Je ne suis pas pour l'instant connecté a la machine ayant le problème , je posterai ce que tu me demandes dans la soirée .

Partager ce message


Lien à poster
Partager sur d’autres sites
quelle est cette adresse 213.103.193.91 donnée à eth1?

 

je ne sais pas :P , mais je vais essayer de trouver

 

problème lié à iptables? si tu flushes les règles iptables, cela donne quoi?

CODE

iptables -F; iptables -X

 

Si je passe ces 2 commandes , je ne peux plus me connecter a rien ( que shorewall soit actif ou pas )

J'ai essayé de desactiver shorewall et de lancer le jeu ( le problème reste identique )

 

Je vais essayer de trouver d'ou me vient cette ip 213.103.193.91 :P

 

 

peux tu nous poster le résultat de

CODE

ifconfig

route -n

 

 

[root@localhost chris]# route -n

Table de routage IP du noyau

Destination Passerelle Genmask Indic Metric Ref Use Iface

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

0.0.0.0 83.177.228.77 0.0.0.0 UG 0 0 0 eth1

 

[root@localhost chris]# ifconfig

eth1 Link encap:Ethernet HWaddr 00:0F:EA:85:75:91

inet adr:83.177.228.77 Bcast:83.177.228.77 Masque:255.255.255.255

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:228 errors:0 dropped:0 overruns:0 frame:0

TX packets:11 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:1000

RX bytes:39783 (38.8 KiB) TX bytes:2114 (2.0 KiB)

Interruption:11 Mémoire:fb000000-0

 

lo Link encap:Boucle locale

inet adr:127.0.0.1 Masque:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:8 errors:0 dropped:0 overruns:0 frame:0

TX packets:8 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:0

RX bytes:428 (428.0 b) TX bytes:428 (428.0 b)

 

[root@localhost chris]#

 

 

Edit 22h32

 

Me revoila , j'ai supprimer ma connection sur eth1 , je suis allé verifier et le fichier '/etc/sysconfig/network-scripts/ifcfg-eth1' a bien été supprimer par la maneuvre .

 

Puis j'ai recréé un connection toute fraiche , voici le nouveau fichier créé :

 

[chris@localhost ~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1

BOOTPROTO=dhcp

NETMASK=255.255.255.0

ONBOOT=no

MII_NOT_SUPPORTED=no

USERCTL=yes

IPV6INIT=no

IPV6TO4INIT=no

PEERDNS=yes

NETMASK=255.255.255.0

DHCP_CLIENT=dhclient

NEEDHOSTNAME=no

PEERDNS=yes

PEERYP=no

PEERNTPD=no

[chris@localhost ~]$

 

 

:-P , j'ai choisi les memes options de configuration :-(

 

Quoi qu'il en soit ça ne resoud pas le problème :P

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens d'essayer de repasser ma freebox en bridge DHCP pour revenir à une configuration similaire à la tienne et 2 choses me chiffonnent:

 

l'adresse IP qui t'es attribuée possède un masque /32 et tu es ta propre passerelle (Cf sortie de ifconfig et route)

 

avec la FBox, j'obtiens une adresse en /24 et surtout une adresse de passerelle pour la route par défaut différente de mon adresse IP. De cette manière, mon PC se contente d'interroger la passerelle de Free pour aller sur le net.

 

Comment la connexion ppp est-elle gérée par ton modem?

(je pense qu'il faut plus se pencher là dessus étant donné que c'est le seul élément ayant changé comme remplacement au sagem)

Partager ce message


Lien à poster
Partager sur d’autres sites
je viens d'essayer de repasser ma freebox en bridge DHCP pour revenir à une configuration similaire à la tienne et 2 choses me chiffonnent:

 

l'adresse IP qui t'es attribuée possède un masque /32 et tu es ta propre passerelle (Cf sortie de ifconfig et route)

 

avec la FBox, j'obtiens une adresse en /24 et surtout une adresse de passerelle pour la route par défaut différente de mon adresse IP. De cette manière, mon PC se contente d'interroger la passerelle de Free pour aller sur le net.

 

C'est tres sympa de ta part d'etre aller modifier ta configuration actuelle pour pouvoir m'aider :P

 

Comment la connexion ppp est-elle gérée par ton modem?

(je pense qu'il faut plus se pencher là dessus étant donné que c'est le seul élément ayant changé comme remplacement au sagem)

 

J'avais essayé de plusieurs façon pour 2 raisons , la 1ère voir si cela resolvait mon problème actuel , la 2ème : optimiser ma connection ( ping et download )

 

J'avais essayé en pppoe avec different MTU et MRU et en pppoa en jouant egalement sur la MTU , MRU , l'encapsulation LLc et VC .

Pour le problème present , ça n'a jamais rien changer , au niveau "optimisation" j'obtient mes meilleurs resultat en : pppoa , MTU et MRU à 1460 , encapsulation VC

 

J'accede a mon modem via mon navigateur , je vais faire des screenshots des differents

onglet de configuration pour que tu puisses y jeter un coup d'oeil :P

 

Je poste ça au plus tôt .

 

Edit 21h22

 

J'ai regroupé les screenshots de ma config dans une archive bzipé :

voici le lien

 

edit 21h30 : je viens d'essayer de les telecharger , il faut pas etre pressé :-P , je vais essayé de trouver autres choses .

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai jeté un rapide coup d'oeil à tes screenshots, j'ai 2-3 questions:

 

-ton modem fait-il routeur :P parce que le DHCP qui attribue des adresses privées, ça y ressemble. Si oui, pourquoi ton PC obtient-il l'adresse publique :P

 

-sur le dernier screenshot (systeme-log.png),

un pont MAC est créé entre eth0 et ? (ppp0 peut-être)

on remarque qu'il a un problème sur le defaultroute :-P et surtout l'adresse de la passerelle (83.177.192.1)

si tu modifies ta route par défaut en spécifiant cette passerelle, je suis quasi certain que le problème sera réglé

route add default gateway 83.177.192.1

après reste à savoir pourquoi cette information n'est pas transmise au PC pour que sa table de routage se mette à jour.

 

=> si tu décoches la case Set route dans l'onglet setup, le log se plaint-il toujours?

Partager ce message


Lien à poster
Partager sur d’autres sites
-ton modem fait-il routeur icon_confused.gif parce que le DHCP qui attribue des adresses privées, ça y ressemble. Si oui, pourquoi ton PC obtient-il l'adresse publique icon_confused.gif

 

Il est vendu pour un simple modem adsl

mais en faisant une recherche via google , j'ai vu que certains disaient effectivement qu'il fonctionnait comme un routeur :-P .Mes connaissance en reseaux etant tres limité je ne pourrai t'en dire plus .

 

si tu modifies ta route par défaut en spécifiant cette passerelle, je suis quasi certain que le problème sera réglé

CODE

route add default gateway 83.177.192.1

 

Tres bien vu , oui ça marche :P , je n'ai jamais eu autant de serveurs :-(

 

=> si tu décoches la case Set route dans l'onglet setup, le log se plaint-il toujours?

 

Non ,il ne se plaint plus en decochant "set route" .

 

 

edit 23h11

 

je viens de couper ma connexion et de la relancer , un "route -n" ne me donne pas la bonne ip :

 

[root@localhost chris]# route -n

Table de routage IP du noyau

Destination Passerelle Genmask Indic Metric Ref Use Iface

127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

0.0.0.0 83.177.196.209 0.0.0.0 UG 0 0 0 eth1

[root@localhost chris]#

 

Voici le log du modem :

an 2 02:44:19> pppd 2.4.1 started by root, uid 0

Jan 2 02:44:19> Connect: ppp0 {--}

Jan 2 02:44:24> WAN IP address 83.177.196.209

Jan 2 02:44:24> PPPoA Connect with IP Address 83.177.196.209

Jan 2 02:44:24> WAN gateway 83.177.192.1

Jan 2 02:44:24> PPPoA Connection Successfully Established

Jan 2 02:44:24> PPPoA Connect with Gateway IP Address: 83.177.192.1

Jan 2 02:44:24> primary DNS address 212.151.137.170

Jan 2 02:44:24> secondary DNS address 212.247.156.66

 

 

Un route -n devrait donc me trouver l'ip 83.177.192.1et ce n'est pas le cas . Je vais plancher la dessus , je te remercie enormément pour ton aide . :P

Modifié par Chris256

Partager ce message


Lien à poster
Partager sur d’autres sites

Suite de mes élécubrations :

 

J'ai essayé tant bien que mal de modifier mes paramètres de connexion , sans succés jusque la .

 

Ce soir j'ai decider de booter sur un live-cd ( Kaella-knoppix ) pour voir la difference de resultat .

 

1er demarrage : impossible de créé la connexion ( message d'erreur hardware ) , un "lsmod" m'indiquait pourtant que le driver de ma carte etait lancé : ( sk98lin ) .

 

2ème essai : je connecte mon cable rj45 a un autre port ( eth0 au lieu de eth1 , pilote forcedeth ) , reboot sur la kaella et la nickel , je suis connecté automatiquement en arrivant sur le bureau :-P , febrilement j'ouvre une console et tapes "ifconfig" suivi d'un "route -n"

 

En voici le resultat :

knoppix@1[knoppix]$ su

root@1[knoppix]# ifconfig

eth0      Lien encap:Ethernet  HWaddr 00:0F:EA:85:75:A5

          inet adr:213.103.44.26  Bcast:213.103.44.26  Masque:255.255.255.255

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:1342 errors:0 dropped:0 overruns:0 frame:0

          TX packets:1462 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 lg file transmission:1000

          RX bytes:977022 (954.1 KiB)  TX bytes:305310 (298.1 KiB)

          Interruption:10 Adresse de base:0x4000

 

lo        Lien encap:Boucle locale

          inet adr:127.0.0.1  Masque:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:10 errors:0 dropped:0 overruns:0 frame:0

          TX packets:10 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 lg file transmission:0

          RX bytes:500 (500.0 b)  TX bytes:500 (500.0 b)

 

root@1[knoppix]# route -n

Table de routage IP du noyau

Destination    Passerelle      Genmask        Indic Metric Ref    Use Iface

0.0.0.0        213.103.44.26  0.0.0.0        UG    0      0        0 eth0

root@1[knoppix]#                   

 

J'ai exactement le même probleme sous un autre os :P

je vais dorenavant arreter de torturer les paramêtres de connexion de ma mandriva :-( et me concentré sur mon modem ( et pour l'instant je ne vois pas du tout quoi modifier :P )

 

Voici mon log ( de la mandriva ) du dhcp client ( qui se trouve dans /var/lib/dhcp ) :

 

}

lease {

  interface "eth1";

  fixed-address 213.103.44.26;

  option subnet-mask 255.255.255.255;

  option routers 213.103.44.26;

  option dhcp-lease-time 60;

  option dhcp-message-type 5;

  option domain-name-servers 212.151.137.170;

  option dhcp-server-identifier 192.168.1.1;

  renew 3 2005/10/12 21:13:27;

  rebind 3 2005/10/12 21:13:51;

  expire 3 2005/10/12 21:13:59;

}

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×