Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Donald

.bat de sauvegarde de répertoire sous XP

Messages recommandés

Hello...

j'ai fait ce .bat, mais il ne se lance pas ! :P

@echo off

xcopy C:\Documents and Settings\Me\Application Data\Thunderbird\*.* E:\BUs\SynchroTB\ /E /H /R /Y /I /D

 

C'est où que je merde ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu ne peux pas utiliser les noms longs avec une commande DOS.

 

Tu dois utiliser un format du type "nomrep~1", conforme à l'ancien format 8+3 (8 lettres pour le nom, 3 lettres pour l'extension) où :

 

- "nomrep" représente les six premières lettres du nom du sous-répertoire,

 

- le "~" sert à signifier que le nom du répertoire dépasse 8 caractères,

 

- le "1" (ou "2", ou "3", etc.), est un numéro d'ordre du répertoire dans l'ordre alphabétique.

 

Exemple : si, dans un même sous-répertoire, tu avais un répertoire "Program Files" et un répertoire "Program Field", "Program Field" serait le premier dans l'ordre alphabétique (donc "Progra~1" en abrégé 8+3), et "Program Files" serait le second dans l'ordre alphabétique (donc "Progra~2" en abrégé), et ainsi de suite.

 

Tu devrais donc essayer :

 

@echo off

xcopy C:\Docume~1\Me\Applic~1\Thunde~1\*.* E:\BUs\SynchroTB\ /E /H /R /Y /I /D

 

Pour le même prix, tu peux remplacer "*.*" par son équivalent en abrégé qui est un point ("."), ce qui donne :

 

@echo off

xcopy C:\Docume~1\Me\Applic~1\Thunde~1\. E:\BUs\SynchroTB\ /E /H /R /Y /I /D

Modifié par emailbox

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello...

j'ai fait ce .bat, mais il ne se lance pas ! :P

@echo off

xcopy C:\Documents and Settings\Me\Application Data\Thunderbird\*.* E:\BUs\SynchroTB\ /E /H /R /Y /I /D

 

C'est où que je merde ?

 

 

Tu mets les noms longs entre guillemets et ça marche ... je le fais couramment

 

Exemple :

xcopy "C:\Documents and Settings\Me\Application Data\Thunderbird\*.*" E:\BUs\SynchroTB\ /E /H /R /Y /I /D

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×