Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

poch

[résolu]installation drivers ATI

Messages recommandés

Salut a tous.

J'ai telechargé les drivers de ma catre graphique (ATI radeon 9600) sur le site d'ati mais je n'arrive pas l'installer.

Voila ce qu'il me met pendant l'installation

[julien@localhost ati]$ ./ati-driver-installer-8.18.6-i386.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.18.6..................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: unable to detect
Removing temporary directory: fglrx-install

Quelqun pourrait m'aider svp

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est ce qui va autour du driver et qui va te permettre d'exécuter des applications "graphiques"...

En l'occurrence, si tu n'as pas installé de serveur X, le logiciel d'installation des drivers d'ATI va avoir du mal à déterminer comment il va faire pour s'installer (il va modifier les fichiers de configuration du serveur X)

Partager ce message


Lien à poster
Partager sur d’autres sites

Au fait en tapant X -version ca me donne

julien@localhost julien]$ X -version

Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7
Build Operating System: Linux 2.6.8.1-2mdkenterprise i686 [ELF]
Current Operating System: Linux localhost 2.6.8.1-12mdk #1 Fri Oct 1 12:53:41 CEST 2004 i686
Build Date: 23 September 2004
	Before reporting problems, check http://wiki.X.Org
	to make sure that you have the latest version.
Module Loader present

Ca veut dire qu'en fait j'en ai installé un?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ah oui, si ça te donne ça c'est que tu as Xorg 6.7 d'installé (donc un serveur X)...

Dans le gestionnaire de packages de Mandrake tu n'as pas les drivers officiels ATI, par hasard ?

Parce que si l'installeur fourni par ATI n'arrive pas à détecter ton serveur X, j'ignore ce qu'il faut que tu fasses (je n'ai jamais eu à installer les drivers ATI)...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, ca a bien avancé mais ca ne marche pas encore:

Suite au conseil de Greywolf j'ai telecharge le rpm pour Xorg 6.8.

L'installation ne marche pas a cause d'un conflit entre Xorg, je me dit que c'est parce que j'ai Xorg 6.7. J'installe donc Xorg 6.8. Le rpm ne veut toujour pas s'installer pour les mêmes raison mais j'essais le premier installeur que j'avais telecharge et la ... il marche!

Je reboot je tape fglrxinfo pour verifier que l'installation c'est bien deroulée mais il m'affiche

[julien@localhost julien]$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

 

Les drivers ATI ne sont donc pas installés.

J'ai vus sur d'autre sites qu'il fallait aller dans l'utilitaire de configuration en tapant fglrxconfig.J'y suis allé mais ca ne marche toujour pas.

Peut etre que j'ais mal configuré dans fglrxconfig?

J'ai aussi vu qu'en tapant fgl_glxgears ca donne des infos, je vous le donne donc au cas ou.

 

[julien@localhost julien]$ fgl_glxgears
Using GLX_SGIX_pbuffer
X Error of failed request:  BadMatch (invalid parameter attributes)
 Major opcode of failed request:  143 (GLX)
 Minor opcode of failed request:  5 (X_GLXMakeCurrent)
 Serial number of failed request:  32
 Current serial number in output stream:  32

Une idée pour m'aider?

Merci d'avance. :P

Modifié par poch

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai peut etre trouve pourquoi ca ne marche pas.

Sur le site Lea-linux il y a un tutoriel d'installation pour ces drivers(ici) et pour la partie Installation des sources du noyau ca ne vas deja pas. Il y'a écrit que les versions doivent impérativement concorder et chez moi ca ne concorde pas.

[julien@localhost julien]$ uname -r
2.6.8.1-12mdk
[julien@localhost julien]$ ls -l /usr/src
total 12
drwxr-xr-x   2 root root 4096 nov  2 14:01 ATI/
lrwxrwxrwx   1 root root   17 nov  1 16:15 linux -> linux-2.6.11-6mdk/
drwxr-xr-x  21 root root 4096 nov  1 16:15 linux-2.6.11-6mdk/
drwxr-xr-x   3 root root 4096 oct 30 02:19 RPM/

Est ce que vous pensez que ca peut venir de la?

Et si oui pouvez vous me dire comment faire pour qu'elle concorde? (J'ai deja fait ce qu'ils disent sur leur site)

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité tesgaz

salut,

[julien@localhost ati]$ ./ati-driver-installer-8.18.6-i386.run

 

faudrait peut être l'installer en root ? non ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×