Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

problème d'affichage


earhin
 Partager

Messages recommandés

Salut tout le monde...

 

voila j'ai installé mandriva 2006 sur mon pc déjà équipé de windows. histoire de tester linux, et a vrai dire même si les reflexes windowsiens me mène la vie dure, dansl'ensemble je suis plutot content... mais voila ya un hic... tellement habitué à travailler dans une résolution de 1024*768 en 32bit sous windows (avec rafraichissement à 75MHz), j'ai voulu avoir la meme résolution sous linux... or là problème. mon écran indique "lower resolution or see user guide", puis il se met en veille. impossible de faire quoique ce soit.

Bon je sais l'idéal aurait été de regarder le guide l'utilisateur, mais je l'ai pas (écran HT d'occas)

 

Alors j'aurais aimé savoir si je pouvait je pouvais modifier les paramètres d'affichages lors du boot de linux. et à l'avenant comprendre pourquoi cette résolution passe sous windows et aps sous linux...

 

merci par avancce...

Lien vers le commentaire
Partager sur d’autres sites

pourrais tu donner un peu de renseignemenet sur cette ecran ?

- CRT ou TFT

- marque

- modele (logiquement tu peu retrouver son noms sur l'etiquette derriere l'ecran)

- taille

 

Alors j'aurais aimé savoir si je pouvait je pouvais modifier les paramètres d'affichages lors du boot de linux.

logiquement tu peu acceder aux tty en faisant ctrl+alt+F1 (de F1 à F6) de la tu peu relancer la configuration de l'affichage avec la commande XFdrake

Lien vers le commentaire
Partager sur d’autres sites

Merci de vous interesser à mon petit soucis.

Alors concernant l'écran, il s'agit d'un CRT Compaq 7500 de 17 pouces

 

concernant le fichier xorg voila le script

 

# File generated by XFdrake.

 

# **********************************************************************

# Refer to the XF86Config man page for details about the format of

# this file.

# **********************************************************************

 

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Mandrake 6.0 and later now use a font server independent of

# the X server to render fonts.

FontPath "unix/:-1"

EndSection

 

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse does not work

#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection

 

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

EndSection

 

Section "InputDevice"

Identifier "Keyboard1"

Driver "keyboard"

Option "XkbModel" "pc105"

Option "XkbLayout" "fr"

Option "XkbOptions" "compose:rwin"

EndSection

 

Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"

Option "ZAxisMapping" "6 7"

EndSection

 

Section "Monitor"

Identifier "monitor1"

VendorName "Compaq"

ModelName "Compaq 7500 Color Monitor"

HorizSync 30.0-70.0

VertRefresh 50.0-140.0

 

# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

 

# 768x576 @ 100 Hz, 61.6 kHz hsync

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

EndSection

 

Section "Device"

Identifier "device1"

VendorName "nVidia Corp."

BoardName "NVIDIA GeForce2 DDR (generic)"

Driver "nv"

Option "DPMS"

EndSection

 

Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24

 

Subsection "Display"

Depth 8

Virtual 832 624

EndSubsection

 

Subsection "Display"

Depth 15

Virtual 832 624

EndSubsection

 

Subsection "Display"

Depth 16

Virtual 832 624

EndSubsection

 

Subsection "Display"

Depth 24

Virtual 832 624

EndSubsection

EndSection

 

Section "ServerLayout"

Identifier "layout1"

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"

Screen "screen1"

EndSection

 

 

Vu que je pouvais rien faire, j'ai réinstallé linux et je tourne maintenant avec une résolution de 832*624... mais je trouve cette résolution vraiment pas très pratique. d'autant que de retour sur windows je tourne en 1024*768...

 

merci par avance

Lien vers le commentaire
Partager sur d’autres sites

Il y a en effet un probleme avec ton fichier :

D'une part les Modeline : ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616 .

Il y a normalement un modeline par resolution possible . Or la resolution corespondante est ce qui apparait en premier dans le Modeline soit ici "768x576" . Donc tes ModeLines ne gere pas un resolution superieur a 768x576 .

D'autre part tes subsections display sont tres supectes aussi .

Ce que je te conseille de faire :

Tout d'abord une copie de ton fichier au cas où avec la commande :

cp /etc/X11/xorg.conf /etc/X11/xorg.backup

Ta sauvegarde s'appelle xorg.backup .

 

Ensuite tu mets tes ModeLine en commentaire en mettant # devant .

Ce qui donne :

# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

#ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

 

# 768x576 @ 100 Hz, 61.6 kHz hsync

#ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

 

Ensuite pour chaque subsection "Display" tu mets Virtual 832 624 en commentaire et tu rajoutes en dessous

Modes "1024x768" .

Par exemple ça donnera pour le premier:

 

Subsection "Display"

Depth 8

#Virtual 832 624

Modes "1024x768"

EndSubsection

 

Il faut que tu sois en root pour faire tout ça .

Tu enregistre et tu redemares ton PC . Si quand tu redemare tu rencontre un probleme, tu remplace ton /etc/X11/xorg.conf par la sauvegarde.

Modifié par mat2546
Lien vers le commentaire
Partager sur d’autres sites

bon bah g essayé, et je me retrouve toujours avec le meme message d'erreur "set lower resolution or see yser guide". et puis plus rien. l'écran de mets en veille, linux termine son démarrage normalement mais l'écran ne veut rien savoir...

 

Le gros soucis que je vais avoir là vais etrede remettre en place le fichier que j'ai sauvegardé sachant que j'ai plus accés à l'interface graphique... eh oui... désolé si je vous semble lamentable... mais je suis un touèt nouveau linuxien... meri par avance

Lien vers le commentaire
Partager sur d’autres sites

Le module nv fonctionne très bien avec les Geforce2MX, pas de souci ;-)

(et le module propriétaire nvidia également, juste au cas où tu voudrais le savoir)

 

Maintenant qu'on a le contenu de ton fichier de config, est-ce que tu peux nous donner le contenu du log de démarrage de Xorg ? C'est le fichier /var/log/Xorg.0.log

Ce sont les lignes qui commencent par (EE) qui nous interessent le plus....

Lien vers le commentaire
Partager sur d’autres sites

bonjour,

ne serait pas plus simple de mettre le cd1 de mandriva de refaire une install en choisissant mise a jour, et au dernier ecran de configuration tester les divers config pour l'ecran jusqu'a trouver la bonne.

sur la 10.1 j'ai eu ce souci avec mon ecran plat je m'obstinai a vouloir mettre un ecran plat conrespondant et vlan du coup j'ai coller un ecran qui ne foirait pas et plus d'ennui. Il ne suffit pas de modifie la resolution il faut y mettre un bon taux de rafraichissement commence par 60 mhz et monte doucement .

 

a+

Modifié par jeanbi
Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous publiez en tant qu’invité. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.
Remarque : votre message nécessitera l’approbation d’un modérateur avant de pouvoir être visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Partager

  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
×
×
  • Créer...