Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

ricou33

réseau et connexion internet partagée

Messages recommandés

Salut,

 

donc sur mon pc de bureau j'ai windows relié à internet par un modem ethernet. La connexion internet est partagée sur une autre carte réseau sur laquelle est branché mon portable. sur le portable j'ai windows et la suse.

Sous windows cette configuration fonctionne sans problème, les 2 pc communiquent et j'ai internet sur le portable.

Sous linux, j'arrive à explorer le pc de bureau par contre je n'ai pas internet. J'ai fouillé partout, j'ai bien vu comment installer une connexion internet direct mais nulle part pour recevoir internet via le réseau. Quant aux réglages réseaux ça devient un peu trop compliqué pour moi. Voici une saisie des réglages des services réseau, si ça peut aider : http://perso.orange.fr/ricou33/images/reseaulinux.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Si tu as accès à l'autre poste mais pas au Net, c'est sans doute à cause d'un oubli de déclaration de la gateway / "passerelle" (il faut y indiquer l'adresse IP du PC qui fait le partage de connexion)...

Tu trouveras ce réglage au même endroit que ceux de ta connexion réseau, normalement...

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vois ce que tu veux dire, je l'ai fait sous windows, mais je ne sais pas où c'est. Il y a la "configuration du routage" qui y ressemble mais je ne sais pas si c'est ça, j'ai mis :

destination : 10.0.0.138 (addresse du modem)

passerelle : 192.168.0.1 (addresse du pc bureau)

masque : 255.255.255.0

Mais ça ne fonctionne pas. Est-ce que c'est bien ça que je dois modifier ? Est-ce que je mets les addresses correctement ?

Partager ce message


Lien à poster
Partager sur d’autres sites

l'adresse de destination est celle de tous les réseaux soit 0.0.0.0/0

 

on peut l'ajouter en ligne de commande via

route add default gw 192.168.0.1

 

sinon renseigner correctement le fichier de déclaration de tes interfaces réseaux (que je ne connais pas sous Suse)

 

vérifie tes adresses de DNS dans /etc/resolv.conf également

 

//edit: /etc/sysconfig/network apparemment pour la déclaration de la passerelle (GATEWAY)

sinon le reste est dans /etc/sysconfig/network-scripts/ifcfg-ethX (où X est le n° de ton interface)

Partager ce message


Lien à poster
Partager sur d’autres sites

l'adresse de destination est celle de tous les réseaux soit 0.0.0.0/0

ok c'est mis

on peut l'ajouter en ligne de commande via

route add default gw 192.168.0.1

j'ai pas réussi

 

//edit: /etc/sysconfig/network apparemment pour la déclaration de la passerelle (GATEWAY)

sinon le reste est dans /etc/sysconfig/network-scripts/ifcfg-ethX (où X est le n° de ton interface)

quand j'ouvre ces fichiers ils sont en lecture seule, je dois démarrer en mode sans échec pour pouvoir les modifier ?

 

En tout cas voici les fichiers de configurations, si vous voulez bien jeter un oeil : ifcfg-eth ; config

 

Dans la suse, pour tout les réglages matériel il y a "yast" qui est une interface graphique un peu à la manière du panneau de configuration windows, c'est pratique pour les débutants.

donc voici ce que j'ai configuré dans le routage : http://perso.orange.fr/ricou33/images/routage.png

Et il y a aussi cette fenêtre que je ne connais pas, je n'y ai pas touché, et les 2 premières cases doivent obligatoirement être remplie, que faut-il mettre dedans ? http://perso.orange.fr/ricou33/images/nom%20hote.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Y'a pas comme un souci ?

La machine est sur le réseau 10.0.0.x et la passerelle est en 192.168.x.y ? Comment se fait le routage entre la machine et la passerelle s'il manque déjà les infos de routage pour passer du réseau 10.0.0.x au réseau 192.168.x.y ?

Partager ce message


Lien à poster
Partager sur d’autres sites

modem (10.0.0.138)---(10.0.0.x ou @IP publique)PC_windows (192.168.0.1/24 partagée)---(192.168.0.2/24 PC Linux)

 

Je connais peu ces modems mais 10.0.0.138 est l'adresse par laquelle on peut les administrer (hors connection internet il me semble) et sauf configuration expresse, ils doivent agir en tant que relais DHCP.

 

PC linux pinge-t-il PC windows?

les DNS de ton FAI sont correctement renseignés dans /etc/resolv.conf? (manifestement non au vu de la dernière capture d'écran, tu peux ne pas renseigner la recherche de domaine)

BOOTPROTO='static'
BROADCAST='192.168.0.255'
IPADDR='192.168.0.2'
MTU=''
NAME='Sony RTL-8139/8139C/8139C+'
NETMASK='255.255.255.0'
NETWORK='192.168.0.0'
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='rBUF.dS41GNOPmGE'
USERCONTROL='no'
_nm_name='bus-pci-0000:00:10.0'
PREFIXLEN=''

Partager ce message


Lien à poster
Partager sur d’autres sites

Déjà merci de vous pencher sur mon problème, il y a des progrès.

 

Je connais peu ces modems mais 10.0.0.138 est l'adresse par laquelle on peut les administrer (hors connection internet il me semble) et sauf configuration expresse, ils doivent agir en tant que relais DHCP.

Oui l'addresse sert à le configurer, par contre je n'utilise pas le dhcp, sur aucune des 2 machines, tout est configuré en manuel, c'est pas bien compliqué sous windows.

 

PC linux pinge-t-il PC windows?

oui pas de souci, je peux même explorer les disques partagés

 

les DNS de ton FAI sont correctement renseignés dans /etc/resolv.conf? (manifestement non au vu de la dernière capture d'écran, tu peux ne pas renseigner la recherche de domaine)

le fichier contient juste : "search site" et je ne sais pas comment le modifier.

 

Par contre j'ai trouvé comment modifier le fichier /etc/sysconfig/network/ifcfg-eth, cela se fait aussi avec yast. J'ai mis les paramètres que tu as indiqué. J'ai aussi réussi à configuré le serveur DNS et ça fonctionne à peu près.

J'ai internet sous linux, par contre outpost intercepte en permanence des "détections de demande dns mal formulée", ce qui fait que le temps d'accès aux sites est assez long (4-5 seconde avant d'afficher la page). Si je désactive l'option dans outpost je n'ai plus de problème.

Est-ce normal que outpost détecte ça ou c'est moi qui est mal configuré quelque chose ?

Partager ce message


Lien à poster
Partager sur d’autres sites

le problème de la routine de détection des requêtes DNS mal formées du plugin DNS cache (paquet trop grand, les 3 premiers bits du dernier mot de 7 bits non nuls,...) a l'air d'être documenté:

 

# DNS Cache - this may give multiple "Malformed DNS request detected" messages. If these are from your ISP DNS server then consider disabling this plugin as a workaround.

http://outpostfirewall.com/forum/showthread.php?t=14000

 

on peut trouver des discussions intéressantes sur le web mais pas de réelle solution autre que de désactiver le plugin ou que l'administrateur s'assure que les alertes levées sont des faux positifs (dans l'immense majorité des cas, sauf dernier lien où l'on s'aperçoit que la fonction ICS de windows n'est pas si sûre que ça)

http://outpostfirewall.com/forum/showthread.php?t=13605

http://forums.treewalkdns.com/readmessage?....config.discuss

http://marc2.theaimsgroup.com/?l=dragonids...4431369&w=2

http://www.enterprisenetworkingplanet.com/...cle.php/3641396

Partager ce message


Lien à poster
Partager sur d’autres sites

merci pour les liens, dommage que ce soit tout en anglais, j'essaie de comprendre mais c'est pas toujours facile.

J'aurais encore quelques questions. J'ai mis dans linux 2 dns, les meme que j'utilise pour windows : 80.10.246.2 et 80.10.246.129, alors pourquoi dans les dns mal formulée interceptée par outpost il y a celles là mais il y en a aussi d'autres ? En plus outpost normallement ne laisse passer que ces 2 dns, à moins que je ne me sois trompé dans les réglages.

Et sinon n'y aurait-il pas un moyen de laisser la vérification pour windows et l'enlever pour linux ? parce que meme si ca peut servir à exploiter une faille windows ça ne pose pas de problème pour linux.

De toute façon, si les requêtes ne se font bien que sur les 2 bonnes dns du fai je n'ai pas trop de souçi à me faire, non ? Il faut juste que je m'assure qu'il n'y ait pas des requêtes qui partent n'importe où.

Pour terminer, la suse possède un pare-feu, je ne l'ai jamais activé pour simplifier, mais vu ma configuration, est-ce que j'en ai besoin ou je peux m'en passer ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×