Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[résolu]serveur http crée un dossier "caché"/"protégé&q


diabolikiss
 Partager

Messages recommandés

Salut à tous,

 

j'ai crée un serveur http, il fonctionne avec un "index of" et des dossier ou fichier accéssible avec http://***.no-ip.org

cependant j'aimerais crée :

 

soit des dossier à accé restrint (mot de passe)

soit un repetoire unique accésible en rentrant l'adresse http://***.no-ip.org\dossierperso

 

le tout en conservant l'accé anonyme au site ( sans avoir à entrer un nom d'utilisateur: anonyme et pass: anonyme )

 

 

merci pour votre aide !!!

Modifié par diabolikiss
Lien vers le commentaire
Partager sur d’autres sites

ok

j'ai essayer mais je n'arive pas à faire fonctionner cela, ma page pointant sur mon dossier est toujours en libre accé et contient le .htaccess et .htpasswd j'ai nommer ces deux points avec un meme nom qui est aussi celui du dossier.

 

htaccess

AuthUserFile /ET/.htpasswd
AuthGroupFile /ET/
AuthName Authentification 
AuthType Basic 

<Limit GET POST> 
require valid-user

</Limit>

 

 

htpasswd

 

pseudo:mot de passe crypté

 

 

merci pour votre aide

Lien vers le commentaire
Partager sur d’autres sites

j'ai nommer ces deux points avec un meme nom qui est aussi celui du dossier.

 

euh ... :P pas compris là.

 

Pourquoi as tu indiqué un répertoire pour la directive AuthGroupFile ?

 

le répertoire /ET existe-t-il bien à la racine du serveur web?

 

tu n'as pas de directive AllowOverride None pour l'arborescence à protéger dans httpd.conf ?

 

un peu de lecture supplémentaire:

http://www.commentcamarche.net/apache/apacht.php3

Lien vers le commentaire
Partager sur d’autres sites

alors j'ai lut ton lien

 

j'ai donc :

 

AuthName  "Dossier securisé"
AuthType Basic
AuthUserFile "\monsite\securit7002 .htpasswd"	   /* ici j'ai un doute, faut'il metre l'adresse jusqu'au disque ?  (c:/....)
<Limit GET POST>

Require valid-user
{instruction d'accès à satisfaire }
</Limit>

 

oui le repértoire existe

 

 

 

dans httpd.conf j'ai

 

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

 

pour l'arborescence
il faut que j'entre l'adresse du dossier protéger dans httpd.conf?? de quel maniére?

 

 

 

merci pour ton aide !!!!!!!

Lien vers le commentaire
Partager sur d’autres sites

Change

AllowOverride None

en

AllowOverride AuthConfig

 

cette directive, réglée à None, fait ignorer les fichiers .htaccess à Apache.

 

dans ton .htaccess

AuthUserFile "\monsite\securit7002 .htpasswd"

 

essaie de garder une arborescence type Unix

AuthUserFile /monsite/securit7002/.htpasswd

Lien vers le commentaire
Partager sur d’autres sites

ok j'ai effectuer les changement précedent, maintenant lorsque je clique sur le lien de la page menant à mon dossier securit7002 j'obtient:

(si je retire le .htaccess j'accéde normalement au dossier)

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator,****@hotmail.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

 

aprés dans httpd.conf j'ai modidfier none en AuthConfig

 

ici:

 

# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
AllowOverride AuthConfig

 

dans httpd.conf ne faudrais t'il pas un code du genre:

 

 

<Directory>
"L:/serveur http/monsite"
AllowOverride AuthConfig
</Directory>

 

 

?

 

 

 

merci pour ton aide !!!

Modifié par diabolikiss
Lien vers le commentaire
Partager sur d’autres sites

J'ai réussi a faire qu'il demande un pass ( l'écriture type unix ne fonctionne pas ->internal error)

cependant il ne reconnet pas le pass ou bien j'ai fait une erreur dans le AuthUserFile.

voici le chemin complet du dossier:

 

L:/serveur http/mon site/securit7002 .htpasswd

 

pour AuthUserFile dois mettre :

 

AuthUserFile"/mon site/securit7002 .htpasswd" ?

Lien vers le commentaire
Partager sur d’autres sites

comment as-tu généré ton fichier .htpasswd? avec l'exécutable htpasswd fournir avec Apache?

 

Pour le chemin, il faut privilégier le chemin relatif à la racine ServerRoot

Lien vers le commentaire
Partager sur d’autres sites

le chemin relatif??? avec le disuqe c:// ?

 

avec des crypteurs en ligne comme celui-ci (j'en est essayé plusieur)

 

lorsque je lance htpasswd.exe une fenetre dos s'ouvre puis se referme et c'est tout...

 

 

merci

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous publiez en tant qu’invité. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.
Remarque : votre message nécessitera l’approbation d’un modérateur avant de pouvoir être visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Partager

  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
×
×
  • Créer...