Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[resolu]modifier un document .csv


Emm'
 Partager

Messages recommandés

Bonjour,

J'installe Thunderbird pour des amis, qui consultaient leurs mail sur le serveur (orange.fr). Je souhaite récupérer la base de données du carnet d'adresse (+ de 1000 contact !).

Pour cela, je l'exporte en .csv . No probléme. Ce dossiers est constitué de champs super nombreux, la plupart vides("telephone" "code postal" " date anniversaire".... Il n'y a des infos que dans "adresse mail" "prenom" et "nom".

Le problème pour récupérer les données dans Thunderbird est qu'il y a trop de champs, et qu'il ne retient pas les infos de "nom" et "prenom". Je ne me vois pas recésir manuellement les données !

J'ai essayé de modifier le fichier .csv en suprimant des champs entiers inutils, sous win xp avec exel, sous linux avec gnumeric ou open office.

Dès que je modifie le document, les données ne sont plus récupérable avec Thunderbird.

Nota : dans l'opération de synchronisation entre les champs du document importé avec les normes de la base de donnée de thunderbird

ex : capturegh7.png

 

Merci de vos suggestions !

:P

Modifié par Emm'
Lien vers le commentaire
Partager sur d’autres sites

  • Modérateurs

Quelques pistes,

  • ton premier enregistrement qui comprend les noms des champs (en entêtes de colonnes) : es-tu certain que ce sont très exactement les noms qu'attend Thunderbird ?
     
  • malgré ces nommages, présente les données (les colonnes) dans le même ordre que celui de la fenêtre de Thunderbird.
     
  • regarde ton fichier CSV en sortie directe de ton export, en l'ouvrant avec NotePad (ou, s'il est trop gros, avec Word ou un éditeur de texte dont tu disposerais, comme TextPad par exemple) : dans chaque enregistrement, les différents champs sont séparés par des points-virgules. Mais sont-ils entourés par des guillemets ? Si oui, fais le même examen sur le fichier que tu as réécrit après suppression des colonnes vides : les guillemets y sont-ils toujours (car EXCEL a tendance à les enlever) ? Si non, essaie de les remettre à l'aide d'un éditeur de texte : change général de ; en ";" puis ajout de guillemets en tête et en queue de tous les enregistrements (c'est facile avec un éditeur qui sait formuler des expressions régulières). Et regarde si Thunderbird te refuse toujours ces données.
     
  • a pu d'idées... :P

Lien vers le commentaire
Partager sur d’autres sites

Merci Dylav,

 

Thunderbird est assez flexible. Il a la capacité de prendre la base de donnée en csv et que je choisisse à quel champs de la nouvelle base je fais corespondre les anciens champs... Sauf qu'il est limité en quantité de champs à recevoir (là, orange , ils sont gonflé, ils ont pondu une usine à gaz).

 

C'est bien un problème de "". Vu la taille du fichier, je ne vais pas tout retaper à la main ! Je vais y réfléchir. Vu que la manip est faite d'abord pour outlock, je vais peut-être transférer mon fichier dessus puis le récuperer avec TB. La nuit porte conceil :P

Lien vers le commentaire
Partager sur d’autres sites

cat <ton_fichier> | cut -d, -f 1,2,3,4 > nouveau_fichier.csv

 

récupère les champs 1,2,3 et 4 du fichier dont le séparateur (-d) est une virgule

 

sinon avec awk

 

awk -F, '{print $1,$2,$3,$4}' ton_fichier > nouveau_fichier

Lien vers le commentaire
Partager sur d’autres sites

salut Greywolf & merci !

:P sauf qu'il y a un ou plusieurs trucs que je n'est pas compris :

[email protected]:~$ cat <Mes_Contacts.csv> | cut -d, -f 2,45,58 > Mes_contacts8.csv bash: erreur de syntaxe près du jeton `|' inattendu
[email protected]:~$ awk -F, '{print $2,$45,$58}' Mes_Contacts.csv > Mes_Contacts8.csv
awk: cmd. ligne:1: Fatal: ne peut ouvrir le fichier « Mes_Contacts.csv » en lecture (Aucun fichi er ou répertoire de ce type)
[email protected]:~$

Des fois je me dis que je devrais adhérer au club des boulets :P

Lien vers le commentaire
Partager sur d’autres sites

il ne faut pas mettre les caractères < et >; ils ne figurent que pour l'exemple

 

cat Mes_Contacts.csv | cut -d, -f 2,45,58 > Mes_contacts8.csv

 

pour awk, assure toi bien que tu te situes bien dans le bon répertoire (celui qui contient le fichier Mes_contacts.csv )

Lien vers le commentaire
Partager sur d’autres sites

Merci, ça y est, c'est ok. :P

C'est génial tout ce qui peut se faire avec les lignes de commandes linux.

pour awk, assure toi bien que tu te situes bien dans le bon répertoire (celui qui contient le fichier Mes_contacts.csv )

Et oui je pensais que : "[email protected]:~$" j'étais déja dans le Desktop. Un petit "ls" et j'ai vu que non.

J'ai pris la 1ère de tes 2 options.

Amicalement, :P

Emm'

Lien vers le commentaire
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez publier maintenant et vous inscrire plus tard. Si vous avez un compte, connectez-vous maintenant pour publier avec votre compte.
Remarque : votre message nécessitera l’approbation d’un modérateur avant de pouvoir être visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Partager

  • En ligne récemment   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
×
×
  • Créer...