Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Ouvrir session Wndows automatiquement


jparbel
 Share

Messages recommandés

Bonjour,

 

A partir d'un NAS Netgear, je souhaiterais ouvrir une session sur un poste WIN7 grâce à un script PHP sur mon réseau local, sans intervention manuelle.

La première phase de WOL fonctionne bien, mais je suis bloqué sur l'ouverture de session.

Je suis le seul administrateur et utilisateur de mon poste W7, il me suffit donc d'envoyer (et de valider mon mdp de session), mais je ne trouve pas la méthode.

J'ai essayé de désactiver la demande de mdp à l'ouverture grâce à Netplwiz, mais cela ne fonctionne que sur un démarrage et non une sortie de veille par WOL(du moins chez moi)

 

Merci pour votre aide éclairée et toujours précieuse.

 

Bonne journée.

Lien vers le commentaire
Partager sur d’autres sites

bonjour jparbel

 

sur ton poste win7 , vérifie ceci : panneau de config>> options d'alimentation >>clique sur demander un mot de passe pour sortir de veille

 

puis modifie éventuellement (modifier des parametres actuellement non disponibles )

Lien vers le commentaire
Partager sur d’autres sites

Merci ab-web pour ta réponse pertinente, je n'avais pas vu cette option, je peux effectivement sortir de veille sans demander de mot de passe, mais j'en demande un peu plus (on n'est jamais content !)

 

Donc, dans le cas ou l'on n'active pas cette facilité, comment se loguer avec un script ayant pour rôle de transmettre le mot de passe ?

 

Pour l'instant, si je ne désactive pas la demande de mot de passe, je sors de veille en envoyant un magic packet depuis mon NAS, grâce à une tâche CRON, je bloque ensuite sur le mot de passe.

 

Je pense qu'il existe une solution logicielle.

 

Merci pour votre réponse.

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

ceci va peut-être vous aider:

 

Copier/coller ce qui suiten vertdans le bloc notes,

sans ligne blanche au début.mais une à la fin

Fichier ->Enregistrez sous..

Clic sur bureau à gauche

Dans type de fichier->Tous les fichiers

Dans Nom-> regis.reg.

Allez sur le bureau

Cliquez droit sur le fichier ->fusionner

Acceptez la modification du Régistre:

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"DefaultUserName"="Le nom"

"DefaultPassword"="mot de passe"

"AutoAdminLogon"="1"

 

Lien vers le commentaire
Partager sur d’autres sites

Merci pour ta réponse Pear, mais cela ne résout pas mon problème, je dois toujours saisir manuellement le mot de passe pour ouvrir ma session.

 

J'ai besoin, en fait, d'un script côté serveur NAS, exécuté par une tâche Cron, qui envoie les identifiants de login de session à mon poste W7, ce sont donc des commandes Linux.

 

La solution d'AB-WEB fonctionne, mais je souhaiterais, malgré tout, conserver la saisie du mot de passe lorsque je me connecte moi-même en sortie de veille, ceci,bien sûr, pour des raisons de sécurité.

Lien vers le commentaire
Partager sur d’autres sites

Bien sûr, je ne suis pas spécialiste.

 

Cependant il me semble qu'il y a 2 côtés du problème:

1) le ficher reg pour que la machine cible accepte de loguer

2) le script pour le nas qui demande à se loguer.

Je n'ai pas de réponse sur ce second point

Lien vers le commentaire
Partager sur d’autres sites

bonsoir jparbel - pear

 

Merci pour ta réponse Pear, mais cela ne résout pas mon problème, je dois toujours saisir manuellement le mot de passe pour ouvrir ma session.

 

bon je ne passe pas par un serveur .

 

si j'applique la solution de pear j'ouvre ma session sans être obligé de taper mon mot de passe.

Modifié par ab-web
Lien vers le commentaire
Partager sur d’autres sites

Bonsoir Pear et AB-WEB,

 

Merci pour vos solutions respectives, après avoir modifié le registre, je n'avais pas rebooté, cela fonctionne maintenant.

 

En tout cas, il me semble que les 2 solutions sont équivalentes et aboutissent au même résultat : ne pas saisir de mot de passe à l'ouverture de session, c'est une solution mais je souhaiterais aller plus loin :

 

Je suis donc toujours à la recherche de la solution alternative qui consiste à se loguer avec mot de passe à partir de mon NAS sous Linux.

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...