Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[Résolu] Plus d'images pour mes icônes


MirCow
 Share

Messages recommandés

Avec Windows seven 32 bits...

-Explorer ne trouve plus les icônes et démarre très lentement.

-Menu démarrer est inaccessible

- les icônes du bureau sont en place mais sans les images.

 

Iconcache.db supprimé

Il ne se reconstruit pas

 

Si je copie explorer.exe en explorer2.exe, explorer2.exe se lance rapidement et affiche toutes les icônes.

 

J'ai essayé plusieurs outils pour régénérer Iconcache.db sans succès.

Une idée ?

 

Sur la photo de mon bureau qui suit on peut voir:

 

- Les icones sabs les images sur le bureau, texte seulement.

- Explorer.exe sans icones (fenêtre au centre)

- Explorer2.exe (copie identique à explorer.exe) avec les icones (fenêtre de droite)

 

zebulonexplorer.th.jpg

Modifié par MirCow
  • Upvote 1
Lien vers le commentaire
Partager sur d’autres sites

De plus, il m'est impossible de créer un raccourci sur le bureau.

Modifié par MirCow
Lien vers le commentaire
Partager sur d’autres sites

bonjour MirCow

 

tu va faire une restauration en utilisant l'outil de réparation windows .

 

pour cela arrête ton PC. puis démarre le .

 

au tout début du démarrage tapote sur F8 jusqu'a arriver sur un écran qui propose les options de démarrage avancés.

 

choisi réparer : l'outil se lance . plusieurs choix sont proposés .

 

choisi restauration systeme . coche afficher d'autres point ( pour avoir plus de choix )

 

choisi une date avant l'apparition du probleme .

Modifié par ab-web
Lien vers le commentaire
Partager sur d’autres sites

La restauration à un point antérieur au PB est la première chose que j'ai faite, pas d'arrangement du PB.

J'arrive à nouveau à créer un raccourci sur le bureau depuis que j'ai créé un iconcache.db vide.

Le raccourci se crée mais toujours pas d'image associée.

 

Démarré en mode sans échec, le bouton démarrer reste inaccessible.

 

Comment se fait-il que explorer2.exe n'a aucun mal à afficher les icônes ?

Me manquerait-il une dll ? Laquelle ?

Modifié par MirCow
Lien vers le commentaire
Partager sur d’autres sites

re

 

tiens étrange il faut peu etre remonter plus loin .

 

sinon démarrage

 

tapoter F8

 

sur le panneau des optons avancés , choisi derniere bonne configuration connue.

 

PS - absent jusque vers 14H

Lien vers le commentaire
Partager sur d’autres sites

Démarré en mode sans échec, le bouton démarrer reste inaccessible.

arretter et démarrer par le bouton marche arret de l'ordi

 

Comment se fait-il que explorer2.exe n'a aucun mal a afficher les icônes ?

désolé aucune idée

Lien vers le commentaire
Partager sur d’autres sites

Dernière bonne configuration connue effectuée, sans effet.

 

Nouvelle info:

je peux cliquer droit un peu partout sans PB, mais clic droit sur disque C: dans Explorer = Crash blue Screen direct !!!

Idem sur D:

:-?:chpas:

 

PS: je précise que par ailleurs toutes mes applis fonctionnent correctement et sans ralentissement.

Modifié par MirCow
Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

Faire une vérification du disque.

 

Augmenter la taille du cache des icônes, voir ci dessous mais il faudra adapter car c'est pour Win XP !

 

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer]

"Max Cached Icons"="4096"

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

 

Créez un point de restauration et tentez ceci:

 

L'explorateur a rencontré une erreur et doit fermer,les dossiers ne s'ouvrent plus

la barre d'adresse ne s'affiche pas,

Vous avez un message "La mémoire ne peut être read or written"ou encore" DrWatson....":

 

Démarrer->Exécuter

regsvr32 -u shmedia.dll

valider

Redémarrez

 

ensuite

 

Démarrer->ExécuterCopier /coller et validez succesivement

regsvr32 /u shmedia.dll /s

regsvr32 /i browseui.dll /s

regsvr32 /i shell32.dll /s

regsvr32 /u /i shdocvw.dll /s

Enfin, pour complètement désactiver le Dr Watson,se rendre dans la base de registres :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

et mettre la valeur de la chaîne Auto à 0.

 

Si vous avez de nombreux crashs de l'explorer avec le message

Pour protéger votre ordinateur Windows a fermé..

vous pouvez désactiver la fonctionnalité DEP(Data Execution Prevention):

Sous Vista/Seven

Cliquer sur Démarrer

Cliquer sur Tout les Programmes

Cliquer sur Accessoires

Cliquer-droit sur "Invite de commandes"

Cliquer sur "Exécuter en tant qu'administrateur"

Coller cette commande dans la fenetre de prompt :

 

bcdedit.exe /set {current} nx AlwaysOff

 

Presser entrer, la phrase suivante devrait s'afficher "Opération réussie"

Rédemarrer. La fonction DEP est à présent désactivée.

 

Pour la réactiver si nécessaire, donc sans résultat probant, même procédure

 

bcdedit.exe /set {current} nx AlwaysOn

Lien vers le commentaire
Partager sur d’autres sites

Leminou:

Augmenter la taille du cache des icônes, voir ci dessous mais il faudra adapter car c'est pour Win XP !

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\explorer]

"Max Cached Icons"="4096"

--> la même clé existe sous Seven, était à 5000 décimal, mise à 4096 Hexa

 

Pear:

J'ai tout exécuté sans PB sauf que je n'avais pas shmedia.dll sur mamachine.

J'ai mis Shmedia.dll dans system32

et la commande regsvr32 /u shmedia.dll /s est alors passée.

 

Pour HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

et mettre la valeur de la chaîne Auto à 0.

--> Je n'ai rien fait n'étant pas sûr de quelle clé il convient de placer à zéro.

J'ai bien une sous clé avec AutoExclusionList, et dwm.exe à 1 dedans.

 

J'ai donc exécuté toutes vos recommandations.

Après redémarrage, le PB est inchangé.

 

Entre temps, pour avancer, j'ai exécuté:

- sfc /scannow

- chkdsk /F /R

 

Le PB est identique --> donc, DEP ON avec bcdedit.exe /set {current} nx AlwaysOn

Ne me laissez pas tomber SVP :tsss:

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...