Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Reika2000

microphone et line-in

Messages recommandés

Salut,

 

Ce que je veux faire, c'est connecter la sortie son de ma gamecube à mon PC. Je le faisais sous windows via le port microphone et ça fonctionnait très bien.

 

Ma distrib, c'est une knoppix, noyau 2.4.26, le son est configuré, la carte télé marche impeccablement (une pinnacle pctv).

 

Quand je branche la gamecube sur le microphone, j'ai un son extrèmement faible (tout à fond, pcm, microphone, IGain, mon ampli), c'est pratiquement inaudible. Quand je le branche sur line-in, rien.

D'après ce que j'ai compris, le son est déjà préamplifié, et ça serait dangereux de le brancher sur le microphone, il vaudrait mieux le faire sur le line-in.

J'ai essayé via l'alias /dev/mixer de pointer sur chacun des /dev/mixer? mais il n'y en a qu'un qui marche, celui du microphone. J'ai essayé différents mixer (aumix, wmix, kmix).

 

J'avoue que le son sous linux, c'est un peu un grand mystère pour moi. Je passe par arts, en Threaded OSS (xmms et xine marchent parfaitement même simultanément), j'ai mis full duplex . J'ai un shuttle SN41G2 (nforce 2), j'utilise la carte son intégrée (une i810 je crois, sous le label nsound). J'ai pas bien compris l'install des drivers nvidia : je fais make & install, ça a l'air de fonctionner, je rajoute l'alias des modules, mais ça n'a pas l'air d'être pris en compte (en fait j'en sais un peu rien).

 

En fait, je ne sais pas trop où chercher. Si il vous manque certaines informations, n'hésitez pas à demander.

 

Ben je vous remercie pour toute aide :P

Modifié par Reika2000

Partager ce message


Lien à poster
Partager sur d’autres sites

Quel est le but désiré? enregistrer ce qui sort de ta gameCube ou faire passer le son de cette dernière via les enceintes branchées sur ta carte son?

 

l'entrée Line-in n'est pas mutée dans le mixer?

 

as-tu essayé d'enregister ce qui rentre dans /dev/audio ou /dev/dsp?

cat /dev/audio > un_fichier.raw

et de le lire ensuite

 cat un_fichier.raw > /dev/audio

 

l'entrée considérée est-elle configurer pour l'enregistrement?

Réglage du mixer en enregistrement

 

Vous pouvez régler le canal CD en enregistrement en entrant

 

amixer cd rec

 

puis le remettre en lecture avec

 

amixer cd norec.

 

Si vous préférez enregistrer depuis un micro, vous devrez probablement utiliser

amixer record-gain 100; amixer mic 100 rec mute

 

(ne pas mettre l'entrée micro en sourdine produit des parasites si le micro capte son propre signal par les haut-parleurs). La plupart des micros ont un réglage de «gain» permettant d'amplifier le volume ; vous allez probablement devoir l'utiliser si vous ne recevez pas le moindre son du micro.

 

http://www.freenix.fr/unix/linux/HOWTO/min...sa-sound-6.html

Partager ce message


Lien à poster
Partager sur d’autres sites

Le but est bien de faire passer le son de cette dernière via les enceintes branchées sur ta carte son.

 

Les 2 commandes avec cat que tu m'as données me renvoient "périphérique occupé". C'est une indication ou bien cela vient du fait qu'il faille passer par arts pour avoir le son (xmms en oss ne passe pas par exemple, il faut ajouter et choisir le plugin arts) ?

 

J'ai parcouru ton how to, mais je n'ai pas amixer (il n'apparait pas dans les packages debian) et je n'utilise pas alsa, donc je sais pas si c'est la peine d'approfondir. Par les logiciels du genre aumixer ou kmixer, j'ai cependant le même type d'option (configuration de l'entrée en enregistrement, gain, etc.), mais ça ne marche que si je mets microphone en enregistrement et le cable sur microphone (avec un son inaudible malheureusement). C'est d'ailleurs marrant, sous windows j'avais le problème inverse, le son était beaucoup trop fort, il fallait mettre tout au minimum :P

 

J'ai un peu l'impression que mon entrée line-in n'a pas été reconnue sous linux, il faut pas activer quelque chose de plus ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai bien augmenté le IGain (Input Gain) dans aumix, mais l'augmentation n'est pas assez forte pour que le son soit suffisemment fort sur microphone, et je n'entends toujours rien sur l'entrée ligne.

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×