Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Install de librairies...


Messages recommandés

Hello,

 

Ayant Kbear comme logiciel ftp de base sous mandrake et trouvant qu'il est completement nul je l'ai desinstallé et je voudrais installer gFTP a la place (oui j'y suis plus habitué...)

 

Je suis donc aller chercher le dernier gFTP sur le site officiel, 2.0.17, et il est ecrit qu'il faut glib et gtk+.

 

Ok, je vais donc telecharger gtk+ 1.2.10 c'est le plus recent aussi d'apres ce qui est expliqué sur ftp://ftp.gtk.org/

et j'en ai profité pour prendre aussi glib 1.2.9 ainsi que le fichier .gz du nom de "patch glib 1.2.9 to 1.2.10"...

 

j'install glib 1.2.9 sans probleme, et le gz du patch contient juste un fichier dont je ne sais pas quoi faire et qui n'a pas d'extension (oui dsl mais ca me trouble trop) et quand je le double-click ca me lance Kompare (un logiciel qui permet de comparer la difference entre differents fichiers)

 

Je me dis bon tant pis j'ai la 1.2.9 d'installée je vais mettre gtk+ maintenant, et ben c'est raté, je lance le ./configure et au bout d'un moment il me fait le message d'erreur suivant :

 

 

checking for GLIB - version >= 1.2.8...

*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)

*** was found! If glib-config was correct, then it is best

*** to remove the old version of GLIB. You may also be able to fix the error

*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing

*** /etc/ld.so.conf. Make sure you have run ldconfig if that is

*** required on your system.

*** If glib-config was wrong, set the environment variable GLIB_CONFIG

*** to point to the correct copy of glib-config, and remove the file config.cache

*** before re-running configure

no

configure: error:

*** GLIB 1.2.8 or better is required. The latest version of GLIB

*** is always available from ftp://ftp.gtk.org/.

 

 

donc voila il dit qu'il me detecte 1.2.10 mais que le test de version lui retourne 1.2.9...

 

j'ai desinstallé le 1.2.9 donc en toute logique on va dire, et voila l'erreur que j'ai :

 

 

checking for GLIB - version >= 1.2.8... no

*** The glib-config script installed by GLIB could not be found

*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in

*** your path, or set the GLIB_CONFIG environment variable to the

*** full path to glib-config.

configure: error:

*** GLIB 1.2.8 or better is required. The latest version of GLIB

*** is always available from ftp://ftp.gtk.org/.

 

 

Voila je sais pas trop quoi faire, et je n'est pas utilisé de prefix pour changer les chemins d'acces, j'ai tout laissé par defaut JUSTEMENT pour eviter les problemes, c'est raté...

 

Je suis sous Mandrake 10.0 Official

 

 

Merci !!!

Modifié par HeAdLeSs
Lien à poster
Partager sur d’autres sites

urpmi gftp ne serait pas plus simple?

 

as tu édité ta variable d'environnement ou lancer ldconfig (comme préconisé dans le msg d'erreur)?

 

comment sont configurés tes liens:

ls -l /usr/lib/libglib*

Lien à poster
Partager sur d’autres sites

urpmi je sais pas ce que c'est, dsl..

 

non j'ai pas edité les variables, et ldconfig je l'ai pas trouvé...

 

les liens..

 

 

[[email protected] headless]$ ls -l /usr/lib/libglib*

lrwxrwxrwx 1 root root 21 Jul 15 20:08 /usr/lib/libglib-1.2.so.0 -> libglib-1.2.so.0.0.10*

-rwxr-xr-x 1 root root 150092 Sep 8 2003 /usr/lib/libglib-1.2.so.0.0.10*

-rw-r--r-- 1 root root 566548 Aug 27 2003 /usr/lib/libglib-2.0.a

-rwxr-xr-x 1 root root 815 Aug 27 2003 /usr/lib/libglib-2.0.la*

lrwxrwxrwx 1 root root 22 Jul 15 20:10 /usr/lib/libglib-2.0.so -> libglib-2.0.so.0.200.3*

lrwxrwxrwx 1 root root 22 Jul 15 20:09 /usr/lib/libglib-2.0.so.0 -> libglib-2.0.so.0.200.3*

-rwxr-xr-x 1 root root 441960 Aug 27 2003 /usr/lib/libglib-2.0.so.0.200.3*

Lien à poster
Partager sur d’autres sites

c'est apt-get le truk de fainéant ??

 

c'est quoi la syntaxe exact ??

 

> head ki se renseigne avt de tout format...

Modifié par HeAdLeSs
Lien à poster
Partager sur d’autres sites
Invité tesgaz

ssalut,

je ne comprend pas ton problème, gFTP est d'origine sur mandrake (enfin, si tu as mis le paquetage)

je l'utilise pour mon site ????

 

 

y a des fois, je comprend pas tout sur les questions ?

Lien à poster
Partager sur d’autres sites
ssalut,

je ne comprend pas ton problème, gFTP est d'origine sur mandrake (enfin, si tu as mis le paquetage)

je l'utilise pour mon site ????

 

 

y a des fois, je comprend pas tout sur les questions ?

slt,

 

 

sous la mdk 7 je l'avais effectivement de base, mais la j'ai fait une install par defaut de la 10 en cochant "ftp" et je n'ai que Kbear...

Lien à poster
Partager sur d’autres sites

J'ai pas la réponse à ta question mais quelques élements de réponse :

 

pour connaitre le type de ton fichier sans extension : file lenomdufichier

Ca marche généralement assez bien.

 

Urpmi c'est rpm avec la gestion des dépendances. En théorie, si il te manque un package pour installer ton package, ça va te l'installer automatiquement. Quand j'ai laché mandrake de désespoir devant ces problèmes de dépendances, la mise à jour était pas gérée (autrement dit, si ta lib machin était trop vieille ou inadéquate c'était mort) et il y avait des problèmes de sources (package dépendant non trouvé, même sur le net).

 

apt c'est le système de package debian qui est nettement mieux foutu.

apt-get update tu mets ta liste de package connus à jour (en allant matter des sites de packages sur le net)

apt-get dist-upgrade : tout ton système est mis à jour (vaut mieux une bonne connec)

apt-get install lenomdufichier : ça installe. Perso, sur des centaines d'install, j'ai constaté que 2 ou 3 foirages

Plus simple, synaptic te fait ça graphiquement, tu cherches un nom, tu coches et ça s'installe (concrètement, j'ai coché gFtp, cliqué sur install et voila, ça marche en 2.017).

Debian c'est assez balaise (entre autres pour l'install et la configuration), mais knoppix est un live-CD basé dessus, que tu peux tester et installer en 1 ligne de commande et 3 clics (et franchement ça déchire).

Pour moi c'est un peu ça qui fait de mandrake une fausse distrib de débutant. Ok ça s'installe facilement, ok y a des jolis menus, mais (en tout cas jusqu'à la 8, après je sais pas), c'est de l'ordre de l'immaintenable.

Bon c'était la minute de pub :P

Modifié par Reika2000
Lien à poster
Partager sur d’autres sites

Merci Reika2000 pour tes explications,

 

J'ai pu constater que apt-get etait en effet tres sympathique, et actuellement j'en suis au moment ou je dois parametrer mon modem fast 800 sous la debian... et sincerement c'est trop la misere...

 

Mais des que j'ai reussi je mets tout as jour !!! Et a ce propos, un apt-get dist-upgrademe mettra a jour le noyau 2.4.18 ou 2.4.20 (je sais plus) que j'ai actuellement avec le choix du noyau ou forcement la derniere stable release qu'il trouvera ??

 

Merci !!

Lien à poster
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...