Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

[résolu]fixmbr et problemes...


Messages recommandés

Bonsoir tout le monde,

 

j'explique mon problème, il est costaud à resoudre pour moi,

 

j'ai deux disques durs :

1- 40Go avec 2 partitions (C: pour Win, D: pour les sauvegardes etc)

2- 8Go avec 3 partitions, c'est pour Linux

 

mais voilà linux m'as installé grub (normal..) et là j'ai acheté un nouveau disque dur de 160Go mais je peux pas en brancher 3 et comme le petit de 8Go n'est pas à moi et la personne qui me l'as preté me le redemande formaté, je me suis dit ok no problem ça devrait être fastoche nan ?

 

probleme 1 :

si je debranche le disque dur numero 2 (le petit) je peux pas démarrer car c'est surement dessus qu'est Grub

 

problème 2 :

j'ai lu qu'il fallait booter avec le cd de win xp, et aller dans le mode reparation, puis taper fixmbr, ok ce que je fais et là il me met un jolie message, avertissement, le genre de truc inquietant, sachant que sur D: j'ai des données très importantes pour moi, je voudrais pas mais pas du tout qu'il lui arrive un prob pour le moment, or le message de win est que il se peut que ça endommage mes 2 partitions, je me dis ouais ok j'ai lu que ça marchait pour tout le monde pourquoi pas moi, mais le probleme c'est que je suis nické du destin, et donc je prefere rebooter avant de faire une connerie et vous poser la question

 

car tout les posts que j'ai lu, les gens avaient linux et Win sur le même disque dur, et moi c'est sur deux differents, donc est-ce que fixmbr fonctionnera bien et fera qu'au reboot grub me lacheras la grappe et Win se lancerait tout seul comme un grand ?

 

en fait j'ai voulu tester fixmbr donc j'ai debranché mon Graveur pour mettre mon nouveau disque dur à la place et ainsi le formater sous win avec partition magic et créer une partition pour faire mes sauvegardes et apres ben quoi qu'il arrive à C ou D je m'en fiche vu que j'ai sauvé l'important, mais le prob c'est que le pc demarre pas j'ai un message du genre

Secondary IDE error, no 80 cable installed

 

je sais pas ce que c'est donc apparemment pas moyen de faire ça, donc la j'ai plus trop le choix c'est :

-soit debrancher le disque dur numero 2, formater C: et reinstaller win dessus tout en gardant D: intact et ensuite quand tout est clean formater mon nouveau disque dur et créer les partitions (ça à l'air le moins risqué mais j'ai pas le gout de formater C: et reinstaller Win reconfigurer tout ...)

 

-ou tant pis je fonce avec fixmbr sachant que ça peut me faire sauter mes 2 partitions et là je l'aurais bien dans l'os à moins que je me gourre et que ça fonctionne (fixmbr) au quel cas dites le moi

 

bref venez moi en aide s'il vous plait car là je sais pas quoi faire... :P

merci d'avance à mes bienfaiteurs

Lien à poster
Partager sur d’autres sites

ouais seulement le problème c'est pas ça, vu que ce que je voudrais c'est que Win boot tout seul comme un grand, apres si ça c'est fait le cable je l'ai puisque ce sera celui de mon 8Go qui sera rendu à celui qui me l'a preté

donc ma question principale tiens toujours malheureusement :P

Lien à poster
Partager sur d’autres sites

Oui, mais avec un cable à 80 conducteurs à la place de ton graveur, tu vas pouvoir démarrer avec 3 disques durs et faire la sauvegarde.

Ensuite, tu essaierae le fixmbr sans danger pour tes données.

 

Mais ce n'est qu'une suggestion...

Lien à poster
Partager sur d’autres sites

Si tu veux être tranquille et récupérer Windows, il faut restaurer le MBR du disque sur lequel tu bootes (ça se décide dans le BIOS) avec une disquette de boot DOS et la commande "fdisk /mbr" ou le CD de restauration de Windows et "fixmbr".

A partir de là, il faut vérifier que ta partition de boot (c'est celle qui, sur le disque de boot, a le flag "amorçable" quand tu es dans FDISK ou Partition Magic) te permet bien de lancer ton OS.

 

L'erreur "Secondary IDE error, no 80 cable installed" vient du fait que les contrôleurs et les disques durs récents ont besoin d'une nappe qui compte 80 fils (contre 40 pour les anciennes nappes IDE) pour pouvoir fonctionner à plein régime...

Lien à poster
Partager sur d’autres sites
Oui, mais avec un cable à 80 conducteurs à la place de ton graveur, tu vas pouvoir démarrer avec 3 disques durs et faire la sauvegarde.

Ensuite, tu essaierae le fixmbr sans danger pour tes données.

 

Mais ce n'est qu'une suggestion...

oui je sais bien, desolé si j'ai repondu un peu brusquement :-(

mais le probleme c'est que j'ai pas de cable 80pin chez moi et je pourrais pas descendre en ville avant 2jours et j'aimerais bien avoir reglé le probleme en attendant si c'est possible

 

sinon pour KewlCat je vois ça ou exactement dans partition magic si c'est amorçable ? je peux verifier et ainsi te le dires :-P

 

merci pour vos reponses en tout cas :P

Lien à poster
Partager sur d’autres sites

Je vais avoir du mal à t'aider plus que cela vu que je suis sous Linux (que je n'ai pas Partition Magic à ma disposition, et que si je l'avais sous la main, ce serait une vieille version DOS). Peut-être dans les "propriétés" de la partition ?

 

Pour un peu plus de théorie sur le fonctionnement du boot, j'ai trouvé ce lien : http://www.linux-kheops.com/doc/dupoux/disk/presente/

Lien à poster
Partager sur d’autres sites

bon mon frère à monté mon disque dur (le nouveau) sur son pc et il le formate et crée les partitions

ensuite je transfere tout mes fichiers importants, et quand c'est fait je reboot et je test fixmbr

je vous tiens au courant :P

Lien à poster
Partager sur d’autres sites

bon ben fixmbr à très bien fonctionné :-(

 

seulement j'ai un dernier problème

mon disque dur de 160Go j'y ai mis 3 partitions

une de 80Go

une de 10Go

une du reste (65Go)

 

j'ai donc maitenant 5 disques : C:, D:, E:, F:, G:

seulement mon lecteur dvd et mon graveur s'appelaient E et F avant

donc j'ai un problème mon lecteur dvd et graveur n'apparaissent pas dans poste de travail,

même si je met un dvd dans le lecteur il ne se passe rien du tout il n'apparait pas

comment y remedier ??

autre chose windows me dis que je dois me ractiver car il y'a eu un changement significatif, j'ai juste mis un nouveau disque dur ? enfin bref je les appelerais

 

mais comment faire pour réavoir à nouveau mes lecteurs dvd et graveur accessibles ?

 

merci d'avance :P

Lien à poster
Partager sur d’autres sites

c'est reglé un petit tour dans le bios ne faisait rien

j'ai debranché la nappe et rebranché et là c'etait reconnu :-P

 

merci pour votre aide :P

à bientôt :-(

Lien à poster
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...