Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

office 2000 .htm ne retrouve pas ses gifs


Roger44
 Share

Messages recommandés

Bonjour

J'utilise Microsoft Frontpage pour créer un document .htm en y insérant des images stockés stockées dans une bibliothèque. Par la suite je rencontre des problèmes ou pour ouvrir le document avec IE, ou pour l'éditer avec FrontPage. Tout semble dépendre de la postion du .htm par rapport aux .gifs dans la hierarchie des dossiers. Ce problème m'agace depuis pas mal de temps donc je viens de passer un peu de temps dessus, mais je ne suis pas plus avancé. Donc si quelqu'un peut m'aider...

 

Le problème :

-IE et FP ouvrent le fichier sans problèmes:

-IE et FP ouvrent le fichier mais n'affichent pas les images;

-IE ouvre le fichier sans problèmes mais FP de bloque,

 

selon l'emplacement du document. Dans l’image ci-après, les images sont stockées dans le dossier coloré en orange, et un même document donnera le résultat correpondant au point coloré.

 

hierarchie.jpg

 

Peu importe l'origine de l'image, ça peut être une photo personnelle, une image crée avec un logiciel style Paint Shop Pro, ou un .gif en provenance d'un site Web. Que le document soit enrégister sur un disque DOS, NTFS ou clé USB ne change rien non plus

 

Ceci se passe également sur mon deuxième ordi avec une nouvelle installation de XP Fam et Office 2000, donc on dirait une faiblesse d'Office 2000 Front Page, sous XP?, mais je ne trouve rien sur l'Internet à ce sujet.

 

Merci

Lien vers le commentaire
Partager sur d’autres sites

Bonjour!

as tu pense à verifier la cible de tes liens?

une erreur dans ton arborescence?

(Par ex si lors de la creation de ton fichier.htm, les images sources etaient, dans un dossier x,

et que par la suite elles ont ete deplacees, dans un dossier z ...)

Lien vers le commentaire
Partager sur d’autres sites

En fait je suis en présence de deux problèmes. ^

 

1. Le fichier s'ouvre avec IE ou Front Page sans les images. C'est parce que Front page mets / / / / dans le .htm pour indiquer les niveaux de différence entre lui et ses images cibles. Donc si on déplace le .htm à un autre niveau......c'est trop stupide. La solution et de remplacer les ////// par le chemin complet au moment de l'enrégistrement.

 

2. IE ouvre le document sans problèmes tandis que FrontPage se bloque. Contrairement à ce que j'ai dis plus haut, ce pb n'arrive pas sur le portable. Donc j'ai reformatté et installé XP, la version SP2 cette fois, et là c'est différent, j'ai le message "serveur occupé" puis "basculer vers", ça prend 10 à 15 sec mais le document fini par s'ouvrir OK. Que se passe-t-il?

 

C'est un sac de noeuds cette histoire qui m'a pris beaucoup de temps.

-Ce pb ne se produit que quand l'utilise Windows Explorer pour ouvrir un fichier.

-Si je suis dans FrontPage et j'ouvre le fichier, pas de problèmes.

-Si je re-démarre Explorer, pas de pb.

-J'ai moins de pb si le titre du fichier fait moins de 20 caractères.

-Si je copie un fichier qui n'a jamais donné de pb, et coller dans le même dossier, pour avoir "Copie de ...", le fichier parent NE VEUX PLUS S'OUVRIR normalement. Hallucinant!

Si maintenant je réduis la longeur de son titre à moins de 20 caractères, il accepte de s'ouvrir normalement. Si je remets son titre à plus de 20 c, il ne s'ouvre plus normalement. Maintenant si je re-démarre Explorer, je peux l'ouvrir normalement.

 

Ce pb de fichier qui se bloque à l'ouverture est récent. Est-ce un pb de stabilité hardware à laquelle Explorer est sensible? Disque? Alimentation? Refroisissement CPU? Je vais démonter et nettoyer tout ça, mais pas tout de suite puisque pour le moment j'en ai plein le vous savez quoi de cet ordinateur.

Lien vers le commentaire
Partager sur d’autres sites

Bon, j'ai résolu le problème, et c'est très simple, il y a une limite sur la longeur des titres des fichiers. En considérant que 'Mes documents' est le niveau 0, le premier sous-dossier le niveau -1 etc etc, :

 

niveau -2 max 62 caractères par titre

niveau -3 54

niveau -4 41

niveau -5 20

 

SP2 a ces mêmes limites, mais aggrave le problème avec le message 'le serveur est occupé" "basculer vers" mais je n'ai pas réussi à savoir exactement quand il affiche ce stupide message. Et puis je pars en vacances, et puis je ré-installe XP simple dès mon retour, donc je laisse à quelqu'un d'autre ce boulot. Mais c'est sûr, ces messages sont intimement liés à l'utilisation de Windows Explorer et la longueur des titres.

A bon entendeur, salut!

Lien vers le commentaire
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

 Share

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...