Aller au contenu

Messages recommandés

Hello!

 

Lors d'un calcul assez lourd (calcul de zones tampon autour de routes dans un logiciel de cartographie SIG), mon PC a pris 5h pour me donner le résultat.

Durant tout ce temps, RainMeter m'a indiqué une consommation CPU qui restait entre 50% et 60%. De plus, la température du CPU n'a pas dépassé les 40°C.

 

Je me demande juste pourquoi l'utilisation n'est pas montée plus haut afin d'accélérer le temps de traitement... :P

 

Le CPU est un P4 en Hyper Threading, qui simule 2 processeurs, au cas ou cela à qqch à voir avec ma question. :-(

 

Merci pour vos suggestions, a+

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vais apporter une petite précision, ton soft de cartographie est pas au jus que ton processeur est hyper trés dingue. Ce couillon ne fait tourner qu'un thread sur les deux possibles.

Petite astuce qui pourrait fonctionner sans rien casser : CTRL ALT SUPPR

là tu vas avoir le gestionnaire des tâches, dans processus tu regardes si tu peux trouver le fichier .exe de ton logiciel, tu clics droit dessus et tu regardes affinité, tu coches cpu1 et cpu2 et peut être alors il va pouvoir occuper les deux threads, c'est pas certain mais çà se pourrait bien...

Modifié par The Brain

Partager ce message


Lien à poster
Partager sur d’autres sites

Re

dans processus tu regardes si tu peux trouver le fichier .exe de ton logiciel, tu clics droit dessus et tu regardes affinité, tu coches cpu1 et cpu2 et peut être alors il va pouvoir occuper les deux threads, c'est pas certain mais çà se pourrait bien..

Les 2 CPU sont déjà cochés dans la rubrique affinité concernant mon logiciel de carto.

 

bin voila , tu as ta réponse , c'est l'HT qui fait ca icon_smile.gif

ton pc bosse a 100% mais ca te montre 50% car il fait croire qu'il y a 2 cpu

J'ai fait le même genre de calcul sur un P4 sans Hyper Threading, et là aussi, le CPU reste la plupart du temps dans les 55%! :P

 

Bon c'était juste de la curiosité, on va pas se prendre la tête pour ça! :-(

 

++

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est que ton soft est programmé de même, il semblerait qu'il calcule pas tant que çà en définitif, ou en tous cas pas dans tous les registres de calcul du CPU. (2 registres en général, addition/soustraction et calculs en virgule flottante)

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×