Aller au contenu
anta_res

Changer l'ordre des actions du menu clic droit

Messages recommandés

Salut a tous

 

Voila mon Pb, lorsque que j'ouvre mon poste de travail et que je double clic sur un de mes lecteur ça m'ouvre le fenetre de recherche au lieu d'ouvrir le lecteur. Et lorsque je clic droit sur mon lecteur c'est l'option rechercher ki est en haut du menu en gras. Ouvir est en dessous.

Je voudrai que ce soit ouvir ki soit prioritaire mais je n'ai pas trouver comment changer ca.

 

Je pense que c'est tout bete mais ca fait un moment que je cherche et j'arrive pas a trouver la solution.

 

merci d'avance pour votre aide.

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut,

 

Colle et copie ce texte dans le bloc notes, et nomme le comme tu veux,

avec l'extension reg, et clique dessus pour l'ajouter au registre :

 

Windows Registry Editor Version 5.00

 

[HKEY_CLASSES_ROOT\Folder\shell]

 

[HKEY_CLASSES_ROOT\Folder\shell\explore]

"BrowserFlags"=dword:00000022

"ExplorerFlags"=dword:00000021

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\command]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\

  65,00,20,00,2f,00,65,00,2c,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,\

  00,25,00,49,00,2c,00,25,00,4c,00,00,00

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec]

@="[ExploreFolder(\"%l\", %I, %S)]"

"NoActivateHandler"=""

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\application]

@="Folders"

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\ifexec]

@="[]"

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\ddeexec\topic]

@="AppProperties"

 

[HKEY_CLASSES_ROOT\Folder\shell\MenuText]

@="Command Prompt Here"

 

[HKEY_CLASSES_ROOT\Folder\shell\MenuText\Command]

@="cmd.exe /k cd \"%1\""

 

[HKEY_CLASSES_ROOT\Folder\shell\open]

"BrowserFlags"=dword:00000010

"ExplorerFlags"=dword:00000012

 

[HKEY_CLASSES_ROOT\Folder\shell\open\command]

@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\

  00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00,72,00,2e,00,65,00,78,00,\

  65,00,20,00,2f,00,69,00,64,00,6c,00,69,00,73,00,74,00,2c,00,25,00,49,00,2c,\

  00,25,00,4c,00,00,00

 

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec]

@="[ViewFolder(\"%l\", %I, %S)]"

"NoActivateHandler"=""

 

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\application]

@="Folders"

 

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\ifexec]

@="[]"

 

[HKEY_CLASSES_ROOT\Folder\shell\open\ddeexec\topic]

@="AppProperties"

 

C'est la clé HKEY_CLASSES_ROOT\Folder\shell qui va résoudre ton problème.

(Celle que j'ai sur mon pc)

 

Tu peux supprimer ces lignes si tu veux :

 

[HKEY_CLASSES_ROOT\Folder\shell\MenuText]

@="Command Prompt Here"

 

[HKEY_CLASSES_ROOT\Folder\shell\MenuText\Command]

@="cmd.exe /k cd \"%1\""

(Je les avais rajouté pour ouvrir la commande dos directement dans le dossier sélectionné en sélectionnant "Prompt here"

dans le menu contextuel)

Modifié par Champagne

Partager ce message


Lien à poster
Partager sur d’autres sites

J'avais oublié ces lignes, que j'ai rajouté en premier:

 

Windows Registry Editor Version 5.00

 

[HKEY_CLASSES_ROOT\Folder\shell]

 

[HKEY_CLASSES_ROOT\Folder\shell\explore]

"BrowserFlags"=dword:00000022

"ExplorerFlags"=dword:00000021

 

[HKEY_CLASSES_ROOT\Folder\shell\explore\command]

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut anta_res, Champagne, Tesgaz,

 

les miens marchent et ils ont déjà fait leurs preuves...

Fusionne ces 2 clés :

FolderKey.reg

DirectoryKey.reg

 

(Champagne c'est bien de prendre la clé folder mais il ne faut pas oublier directory)

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour votre aide mais ca ne fonctionne toujours pas j'ai eu bo fusionner vos clé, losque que je double clic sur un lecteur ca m'ouvre toujours la fenetre rechercher. Ce ki est bizard c'est que ca ne fait ca que dans le poste de travail. Une foit que je suis rentrer sur le lecteur kan je double clic sur un dossier ca marche comme d'hab il s'ouvre.

Partager ce message


Lien à poster
Partager sur d’autres sites
(Champagne c'est bien de prendre la clé folder mais il ne faut pas oublier directory)

 

Merci, je n'oublierai pas la prochaine fois ! :P

Partager ce message


Lien à poster
Partager sur d’autres sites
Merci pour votre aide mais ca ne fonctionne toujours pas j'ai eu bo fusionner vos clé, losque que je double clic sur un lecteur ca m'ouvre toujours la fenetre rechercher. Ce ki est bizard c'est que ca ne fait ca que dans le poste de travail. Une foit que je suis rentrer sur le lecteur kan je double clic sur un dossier ca marche comme d'hab il s'ouvre.

532683[/snapback]

Il faut se relogguer pour que ça fonctionne :P

 

Essaye aussi celle la : MyComputerKey.reg

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement

×