Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

BaK

Mémoire virtuelle

Messages recommandés

Hello!

 

Lors de la réinstallation d'un poste XP SP2, je suis confronté au problème suivant:

 

A chaque démarrage, à l'affichage de l'écran de bienvenue, un bip se fait entendre et l'écran reste figé. A l'aide de alt+tab j'arrive à afficher une fenêtre qui me dit que la mémoire virtuelle était insuffisante et Windows a dû en créer! Je fais OK, le bureau apparaît et je peux travailler normalement.

 

Lorsque je vais ajouter de la mémoire virtuelle, j'en mets un peu sur C:/ (256MB) et le reste sur D:/ (768MB). Pour chaque partition, je clique sur Définir, et je vois apparaître les valeurs mentionnées ci-dessus.

Par contre, sur le bas de cette fenêtre, la quantitié de mémoire allouée reste à 0MB!

Je pense que c'est normal, que les modifs vont être appliquées lors du reboot. Mais non, même message d'erreur au prochain démarrage! :P:P

 

Je suis bien en Admin, j'ai tous les droits sur les partitions (NTSF) et il y a suffisemment de place libre sur chaque partition!

 

Qqun a une idée du problème?

 

 

Merci, a+

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut

 

Je ne suis pas du tout sur que tu puisses ainsi "découper" la mémoire virtuelle.

 

Essaie en ne mettant "que" 768 mo sur d et supprime celle sur c

 

A ce sujet :

 

Par contre, sur le bas de cette fenêtre, la quantitié de mémoire allouée reste à 0MB!

Je pense que c'est normal, que les modifs vont être appliquées lors du reboot. Mais non, même message d'erreur au prochain démarrage!

 

tu pourrais mettre une copie d'écran ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Re

 

Merci pour vos réponses!

 

Je ne suis pas du tout sur que tu puisses ainsi "découper" la mémoire virtuelle

Moi oui, je l'ai fait sur mon PC et ça fonctionne sans prob! :-P

 

tu pourrais mettre une copie d'écran ?

Euh non, désolé, pas de connexion internet pour ce poste... :P

Je le recopierai quand je l'aurai sous les yeux! Le message dit que Windows n'avait pas assez de mémoire virtuelle à disposition et qu'il a dû en rajouter! Ensuite il indique où se rendre pour paramétrer la mémoire virtuelle!

 

Essaye aussi simplement:

Effets visuels

"laisser Windows choisir etc..."

avancé:

"les programmes 2x"

mémoire virtuelle:

"taille gérée par le système

J'ai essayé, mais ça fait pareil. Toujours 0MB de mémoire virtuelle après le reboot! :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Re Bak,

Désolé, j'ai encore jamais vu ce problème, sauf sur des DD qui manquaient

d'espace libre.

Quand tu clique sur définir, par exemple: tu mets 500 et dans l'autre fenêtre

800 après tu clique sur définir, immédiatement les chiffres 500-800 apparaissent

dans la fenêtre en haut chez moi.

Attention:

En faisant ça tu peux avoir ce message d'avertissement:

si le fichier d'échange sur le volume c a une taille initiale de moins de 511 mégaoctects, alors il est possible que le système ne puisse pas créer un fichier d'information de débogage si une erreur irrécupérable se produit. Voulez-vous quand même continuer?

Est-ce qu'une fois tu as eu ce message?

A+

Partager ce message


Lien à poster
Partager sur d’autres sites

revérifies bien les droits NTFS, fais peut être une réappropriation des lecteurs, j'ai déjà rencontrer des bug de fichier Swap sous 2000 sur une réinstall et a l'époque un formatage de la partition en question avait régler le pb..

Partager ce message


Lien à poster
Partager sur d’autres sites

Re

 

Voici le message:

Titre de la fenêtre : Mémoire virtuelle limitée

Votre système n'a pas de fichier d'échange ou le fichier d'échange est trop petit.

 

Pour corriger le problème, ... ici il indique où se rendre pour faire les modifs sur la mémoire virtuelle

 

Quand tu clique sur définir, par exemple: tu mets 500 et dans l'autre fenêtre

800 après tu clique sur définir, immédiatement les chiffres 500-800 apparaissent

dans la fenêtre en haut chez moi.

Pour moi aussi les chiffres apparaissent bien en haut dans la fenêtre. Par contre en bas, en texte d'info non modifiable, la valeur est à zéro. Et comme au reboot je retombe sur le message d'erreur ci-dessus, la modif ne se fait visiblement pas! Pourtant j'appuie bien sur Définir! :P

 

 

Attention:

En faisant ça tu peux avoir ce message d'avertissement:

si le fichier d'échange sur le volume c a une taille initiale de moins de 511 mégaoctects, alors il est possible que le système ne puisse pas créer un fichier d'information de débogage si une erreur irrécupérable se produit. Voulez-vous quand même continuer?

Non, jamais eu ce message.

 

 

revérifies bien les droits NTFS, fais peut être une réappropriation des lecteurs, j'ai déjà rencontrer des bug de fichier Swap sous 2000 sur une réinstall et a l'époque un formatage de la partition en question avait régler le pb..

+1

J'ai effectivement déjà fait l'expérience de ce type de bug sous 2000!

Ici j'ai donc contrôlé ça en 1er. L'admin a bien tous les droits sur les partitions, et j'ai même ajouté tous les droits à 'Tout le monde', mais sans effet! :-(

 

J'ai essayé en Mode sans échec. Là apparaît mon compte admin, mais aussi un compte Administrateur, qui n'est pas visible en mode normal de démarrage! :P

Est-ce normal?

 

Florent> Qu'est ce que tu entends par : fais peut être une réappropriation des lecteurs ?

 

Pis la cerise sur le gâteau, l'ordi ne veux plus s'arrêter, il reboot à la place! :-P

 

Bref, tout va bien... :P

 

Je précise que ce PC n'a jamais été connecté au Net, donc vraisemblablement sans virus!

Sinon l'antivirus et MCaffee (j'aime pas trop ce truc..), et il me mets sans cesse des alertes quand je veux changer des paramètres dans MSConfig p. ex. Je sais pas s'il pourrait aussi bloquer cette histoire de mémoire...

 

 

Merci pour votre aide, a+

Partager ce message


Lien à poster
Partager sur d’autres sites
revérifies bien les droits NTFS, fais peut être une réappropriation des lecteurs, j'ai déjà rencontrer des bug de fichier Swap sous 2000 sur une réinstall et a l'époque un formatage de la partition en question avait régler le pb..

Yep ca m'est arrive recement apres avoir modifie les restrictions....

 

Pour commencer, ouvre un dossier et fais va dans "outil" au dessus, puis la clic sur "option des dossier" puis affichage, puis tu decoche la case "Utiliser le partage de fichier simple" et tu valide.

En suite, pour chaqun de tes disk, tu fais un clic droit puis propiete et la tu aura un ongle "Securite", tu clic dessus et tu vas dans "parametres avance" et puis dans l'onglet "proprietaire" et la tu t'approprie le disk :P

Partager ce message


Lien à poster
Partager sur d’autres sites

Re

 

Alors après avoir fait:

 

Pour commencer, ouvre un dossier et fais va dans "outil" au dessus, puis la clic sur "option des dossier" puis affichage, puis tu decoche la case "Utiliser le partage de fichier simple" et tu valide.

En suite, pour chaqun de tes disk, tu fais un clic droit puis propiete et la tu aura un ongle "Securite", tu clic dessus et tu vas dans "parametres avance" et puis dans l'onglet "proprietaire" et la tu t'approprie le disk

et en mettant la coche pour que je devienne propriétaire de tous les sous-dossiers également

-> aucun changement :-P:P

 

Bon comme le PC ne veut plus s'arrêter, mais reboote à la place, je vais conseiller à son propriétaire de refaire l'installation de son OS (il vient de la faire ça ne devrait pas poser trop de problèmes... :P )

 

Merci du coup de main, je vous tiens au courant si ça va mieux par la suite!

 

++

Partager ce message


Lien à poster
Partager sur d’autres sites

Votre contenu devra être approuvé par un modérateur

Invité
Vous postez un commentaire en tant qu’invité. Si vous avez un compte, merci de vous connecter.
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×