Aller au contenu
  • Pas encore inscrit ?

    Pourquoi ne pas vous inscrire ? C'est simple, rapide et gratuit.
    Pour en savoir plus, lisez Les avantages de l'inscription... et la Charte de Zébulon.
    De plus, les messages que vous postez en tant qu'invité restent invisibles tant qu'un modérateur ne les a pas validés. Inscrivez-vous, ce sera un gain de temps pour tout le monde, vous, les helpeurs et les modérateurs ! :wink:

Notpa

Commentaires-remarques sur le JALC « Jeux de mots »

Messages recommandés

Plutôt que de polluer le JALC de messages concernant les erreurs éventuelles du programme Chari.exe, il est préférable de poster ici vos remarques (bug, suggestions,, questions). Ça allègera le JALC et centralisera ici les messages.

Pour le problème de la propal de nthor où les mots se trouvaient avec des ? générés, ceci est dû au codage ANSII ou Unicode, voir UTF-8. La preuve   : copie de la zone concernée de nthor :

CRÉATION DE NOUVELLES

Positionner le curseur en début puis, à l'aide de la flèche droite, se déplacer lettre par lettres. Après la lettre A, il faut faire 10 fois la flèche pour arriver au T. Après le N de Création, une fois de plus. Ce qui prouve qu'il y a des parasites insérés et non visibles dans les mots. Mon programme chari est un peu perdu car il reçoit les ?.

Si je colle ce texte dans NotePad++, j'ai : CRÉATION DE NOUVELLES en UTF-8. Si je le convertis en ANSII, j'ai CRÉATION DE NOUVELLES.

Mon programme n'est pas en cause, Je ne sais pas pourquoi ce n'est pas systématique et ce qui provoque ce problème, ni comment y palier.

Des idées ?

Partager ce message


Lien à poster
Partager sur d’autres sites

A votre avis, le texte qui arrive dans propal est sous quel format ? ANSII ? UTF-8 ? Unicode ? Il serait possible en VB de faire la conversion. Mais je dois savoir quel est le format d'entrée.

Partager ce message


Lien à poster
Partager sur d’autres sites

Les lettres restantes ? Alors, il va falloir que Notpa trouve le souci, puisque la liste est intégrée avec la correction de la proposition précédente, copiée dans le presse-papier par la commande 'Copier' du programme. Serait-ce le presse-papier qui serait source du problème ? Je dis ça, je n'y connais rien...

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui, je me souviens que la lettre collé étant bleu il a fallu que je la repasse en rouge.
Peut être le fait de copier/coller une lettre de couleur qui mets le bordel dans l'éditeur du forum ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai écrit un petit programme pour voir ce qu'il y a dans le presse-papier. Et bien les ??? sont bien là ! Donc, il y a bien l'insertion de ??? dans le presse-papier à cause du format dans le post du JALC.  Je peux bien sûr les supprimer mais comment déterminer un vrai ? d'un faux ? ?

Partager ce message


Lien à poster
Partager sur d’autres sites

Ils y sont dès l'initialisation d'un nouveau texte de référence ?

Jai remarqué par ailleurs que sélectionner en 'copier' une lettre (sans espace devant ni derrière) parmi les lettres restantes, et la 'coller' dans un mot en cours de rédaction, insère systématiquement un espace 'avant'  et 'après'. (Effectué dans l'éditeur du forum)

Par ailleurs, j'ai vu un autre petit souci mais que je n'ai pas pu reproduire, et je n'ai plus exactement le texte d'erreur rencontré, mais j'avais soit mal positionné le curseur dans la zone de proposition, soit il manquait la fin de la phrase, en tout cas ile message d’erreur  parlait de 'hors zone'  ou quelque chose du même genre, cliquer sur 'OK' a une nouvelle fois fermé le programme sans avertissement...

Partager ce message


Lien à poster
Partager sur d’autres sites

Ça serait l'insertion de couleur que provoque ça ? Pas possible car on le fait toujours et on ne rencontre pas l'erreur des ???. Pourquoi dans le cas présent et pas dans les autres qui sont aussi coloriés ?

Pour ton autre petit souci, j'ai besoin de plus d'infos !

Partager ce message


Lien à poster
Partager sur d’autres sites

CRÉATION DE NOUVELLES

Pas étonnant qu'il faille faire avancer 10 fois le curseur (7 fois, en réalité) ! C'est tout simplement parce que tu oublies qu'est cachée là la balise de fin de couleur rouge

[color=red]CREA[/color]TION

En revanche, si tu fais un copier/coller dans le BlocNotes (et c'est bien cela qu'il faut faire), ton curseur passera directement du A au T.

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You are posting as a guest. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...